summaryrefslogtreecommitdiff
path: root/app-containers/podman-compose
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-06 02:07:39 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-06 02:07:39 +0000
commitd285f0ab4ab38d4ea1cd0757a465db5f06764e06 (patch)
tree1fec673dcd26669902404a2986868912c5b41860 /app-containers/podman-compose
parenta6764d56b1c85c8272783500983011c143c72d80 (diff)
gentoo auto-resync : 06:12:2024 - 02:07:38
Diffstat (limited to 'app-containers/podman-compose')
-rw-r--r--app-containers/podman-compose/Manifest3
-rw-r--r--app-containers/podman-compose/metadata.xml12
-rw-r--r--app-containers/podman-compose/podman-compose-1.2.0.ebuild40
3 files changed, 55 insertions, 0 deletions
diff --git a/app-containers/podman-compose/Manifest b/app-containers/podman-compose/Manifest
new file mode 100644
index 000000000000..8075698c4e06
--- /dev/null
+++ b/app-containers/podman-compose/Manifest
@@ -0,0 +1,3 @@
+DIST podman-compose-1.2.0.gh.tar.gz 84708 BLAKE2B ab1f458cef6db99c5727a6676cd1a15ccc58108a14763b9bf8e1093bc674e1adbee21c81744a0cb7798be6134e7b566a4ed9222be71bda0d8f7e4568b3d2fcb7 SHA512 2b45bcb331e334d362a0906563377e1514aca95f50c575e4b53039e58394b39af1ceeb606d90c652ef6d8cc5e8764a27edf11fc9782a89b186812a474b583579
+EBUILD podman-compose-1.2.0.ebuild 790 BLAKE2B 76a151aafae24cb48a7ebc1e673b8f881db1eb8ee97cae27c8e55761ff23af22a473b6bd463fbdc3d0dde80e79dda95d5cf35cabe5f769e376e94acef02570a8 SHA512 9218e8cee42b89327e8274437aa8e50099383ff742b90532641fba50d97abd9e3741cc182e3140fc2f395fcbe18e4ee02920fcc5954f3bb6ba479b11a5014a63
+MISC metadata.xml 387 BLAKE2B 9df848de1538d10b16425c1e8f4cb20eddc2f24c6472ff595fbb04904a2249d5e2e2283b3ce35cd9cd4d4a50ea51927d85c2ec4e9e2ede75ce8865db235e68d9 SHA512 f4cd09e8dec20ad6edaf43787522afccbbc8fecd9fb2ac8d0a805180856ec5e61528fc9a537714d8475e4fb2c019e160503c87a8ac2fa4fdc40ca54e84adb262
diff --git a/app-containers/podman-compose/metadata.xml b/app-containers/podman-compose/metadata.xml
new file mode 100644
index 000000000000..993b06717a6d
--- /dev/null
+++ b/app-containers/podman-compose/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>zmedico@gentoo.org</email>
+ <name>Zac Medico</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">podman-compose</remote-id>
+ <remote-id type="github">containers/podman-compose</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-containers/podman-compose/podman-compose-1.2.0.ebuild b/app-containers/podman-compose/podman-compose-1.2.0.ebuild
new file mode 100644
index 000000000000..e0cc4093d423
--- /dev/null
+++ b/app-containers/podman-compose/podman-compose-1.2.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+inherit distutils-r1
+
+DESCRIPTION="A script to run docker-compose.yml using Podman"
+HOMEPAGE="https://github.com/containers/podman-compose"
+SRC_URI="https://github.com/containers/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ app-containers/aardvark-dns
+ app-containers/netavark
+ app-containers/podman
+"
+
+RDEPEND="
+ ${DEPEND}
+ dev-python/pyaml[${PYTHON_USEDEP}]
+ dev-python/python-dotenv[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest pytests
+}