summaryrefslogtreecommitdiff
path: root/app-containers/skopeo/files/makefile-1.14.0.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-23 16:28:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-23 16:28:44 +0000
commit191f9d51469a31970723ed9eb0aee70ffe63094e (patch)
tree2502e164870943a5ca491043010657f1b83e4a27 /app-containers/skopeo/files/makefile-1.14.0.patch
parent2114f9bc3d55c52f926a43f08765b350871e86f2 (diff)
gentoo auto-resync : 23:11:2023 - 16:28:43
Diffstat (limited to 'app-containers/skopeo/files/makefile-1.14.0.patch')
-rw-r--r--app-containers/skopeo/files/makefile-1.14.0.patch38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-containers/skopeo/files/makefile-1.14.0.patch b/app-containers/skopeo/files/makefile-1.14.0.patch
new file mode 100644
index 000000000000..ee3383925a2b
--- /dev/null
+++ b/app-containers/skopeo/files/makefile-1.14.0.patch
@@ -0,0 +1,38 @@
+# Patch by Rahil Bhimjiani (IRC: rahilarious) (rahil3108@gmail.com)
+#
+# Rationale behind this patch:
+# 1. We don't install these files (policy.json default.yaml) as part of skopeo because podman, buildah, et. al need them as well, and there's no need for those to depend on skopeo just for configuration. Rely on app-containers/containers-common which has them split out instead. See https://bugs.gentoo.org/849863
+# 2. Remove install-*: because it tries to (re)compile stuff (which we already built in src_compile) on install commands. src_install should only install, not compile
+#
+#
+--- a/Makefile
++++ b/Makefile
+@@ -158,23 +158,20 @@
+ rm -rf bin docs/*.1 completions/
+
+ install: install-binary install-docs install-completions
+- install -d -m 755 ${DESTDIR}${LOOKASIDEDIR}
+ install -d -m 755 ${DESTDIR}${CONTAINERSCONFDIR}
+- install -m 644 default-policy.json ${DESTDIR}${CONTAINERSCONFDIR}/policy.json
+ install -d -m 755 ${DESTDIR}${REGISTRIESDDIR}
+- install -m 644 default.yaml ${DESTDIR}${REGISTRIESDDIR}/default.yaml
+
+-install-binary: bin/skopeo
++install-binary:
+ install -d -m 755 ${DESTDIR}${BINDIR}
+ install -m 755 bin/skopeo ${DESTDIR}${BINDIR}/skopeo
+
+-install-docs: docs
++install-docs:
+ ifneq ($(DISABLE_DOCS), 1)
+ install -d -m 755 ${DESTDIR}${MANDIR}/man1
+ install -m 644 docs/*.1 ${DESTDIR}${MANDIR}/man1
+ endif
+
+-install-completions: completions
++install-completions:
+ install -d -m 755 ${DESTDIR}${BASHINSTALLDIR}
+ install -m 644 completions/bash/skopeo ${DESTDIR}${BASHINSTALLDIR}
+ install -d -m 755 ${DESTDIR}${ZSHINSTALLDIR}
+ install -m 644 completions/zsh/_skopeo ${DESTDIR}${ZSHINSTALLDIR}
+ install -d -m 755 ${DESTDIR}${FISHINSTALLDIR}