summaryrefslogtreecommitdiff
path: root/app-containers/umoci
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-22 14:08:05 +0000
commit93a93e9a3b53c1a73142a305ea1f8136846942ee (patch)
treeb9791a06ab3284e27b568412c59316c66240c682 /app-containers/umoci
parent2771f79232c273bc2a57d23bf335dd81ccf6af28 (diff)
gentoo resync : 22.12.2021
Diffstat (limited to 'app-containers/umoci')
-rw-r--r--app-containers/umoci/Manifest5
-rw-r--r--app-containers/umoci/metadata.xml8
-rw-r--r--app-containers/umoci/umoci-0.2.1.ebuild42
-rw-r--r--app-containers/umoci/umoci-0.4.6.ebuild35
4 files changed, 90 insertions, 0 deletions
diff --git a/app-containers/umoci/Manifest b/app-containers/umoci/Manifest
new file mode 100644
index 000000000000..b2bdc62d4b35
--- /dev/null
+++ b/app-containers/umoci/Manifest
@@ -0,0 +1,5 @@
+DIST umoci-0.2.1.tar.gz 241472 BLAKE2B 2802fcb14e717a6460f9dc06226d3b430cce2181838a32064e86987131317947a4b117e91d11f981fa1df027804dbf2d92472b5c21749783b4f2ed371c699e7e SHA512 dfd7bbd1afd232400a9bffaf6c074d28ce4ce696c9f3c70bd436cc41b96928415d0793d57b1cf34dd70efd7d0e5eb567eaeea65d793c27ff9ea46fb190bd1807
+DIST umoci-0.4.6.tar.gz 2273608 BLAKE2B d5a36c78918697b9c8f54a5c4b914a9124b5e989dff3efc81a9f64f1bd276189d15a565a6ec2e8d4021925017e9a7a17f7cc5359a552f7c57dda414c25d2fb02 SHA512 0614dd583e00b6e2e69256f1ae1d3316e5bb5989a177d18c5ceacf3af18ab82ccf8edef879b6c813855d878d5af53c541ac433d81e6c20796885a26c57564118
+EBUILD umoci-0.2.1.ebuild 921 BLAKE2B caa93ba823c4e8f26d9c65ebeae4f96412dbd47221ccc6a2180ca09ba8ef8ad5bd0bf6a3817547745744657c981b298d2047cd4cc8bfca899cdd254e0aa43159 SHA512 875c57b7d8ba2d7f7485866bc2a12b210505fcbab62abfa901cb5353efc8e77738938cd0380c99b02bd05dd8b34ef2b42e7a23543dfab0925e34580029d40fa9
+EBUILD umoci-0.4.6.ebuild 797 BLAKE2B b79c2ac05f6ed5ae1db9e1d04781a6f46c4f2a17ec8c70db0a3a6e7e5ec96605b480b3a5a8f5386a822b9e68d46bbce34e968dc13930147515d2d0627a9c07b8 SHA512 e3217bb2e870b11ce3ac2e7cf5341193cee6b57dae1b85a33e1ae3ba6499d6f5deb8bf2852a5c9bc92fc2a3500390c5b2dac447cdcbf88310d5e55f27fb433f2
+MISC metadata.xml 249 BLAKE2B 08603bf9d754b59bae12620988552abc7f76b87a1390d02038789eba034c22412a3593d10f443794a5171ff3905c2b5c822368b2eb9f53a528097b7b6c80ffe9 SHA512 338d72efbd040697be98aad4229b81c9694eb27ecbc39f3a18332f4cc766a46b4a0a92f32612203259bf58f5838d0aff7f0b1abec7766f6cd2394c73f7f0b251
diff --git a/app-containers/umoci/metadata.xml b/app-containers/umoci/metadata.xml
new file mode 100644
index 000000000000..db463f3eeb66
--- /dev/null
+++ b/app-containers/umoci/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>williamh@gentoo.org</email>
+ <name>William Hubbs</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/app-containers/umoci/umoci-0.2.1.ebuild b/app-containers/umoci/umoci-0.2.1.ebuild
new file mode 100644
index 000000000000..ad66e4afe83d
--- /dev/null
+++ b/app-containers/umoci/umoci-0.2.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+EGO_PN="github.com/openSUSE/umoci"
+COMMIT=0465f83826bc4f52e6e3c4dbb1022ec5792c421f
+inherit golang-vcs-snapshot
+
+DESCRIPTION="Manipulation tool for OCI images"
+HOMEPAGE="https://github.com/openSUSE/umoci"
+SRC_URI="https://github.com/openSUSE/umoci/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-go/go-md2man"
+
+S="${WORKDIR}/${P}/src/${EGO_PN}"
+
+RESTRICT="test"
+
+src_compile() {
+ set -- env GOPATH="${WORKDIR}/${P}:$(get_golibdir_gopath)" \
+ go build -v -work -x \
+ -ldflags "-w -X main.gitCommit=${COMMIT} -X main.version=${PV}" \
+ -o "bin/${PN}" ./cmd/${PN}
+ echo "$@"
+ "$@" || die
+ cd man
+ for f in *.1.md; do
+ go-md2man -in ${f} -out ${f%%.md} || die
+ done
+}
+
+src_install() {
+dobin bin/${PN}
+doman man/*.1
+dodoc CHANGELOG.md
+einstalldocs
+}
diff --git a/app-containers/umoci/umoci-0.4.6.ebuild b/app-containers/umoci/umoci-0.4.6.ebuild
new file mode 100644
index 000000000000..f315c80c886b
--- /dev/null
+++ b/app-containers/umoci/umoci-0.4.6.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+COMMIT=5efa06acfb3bb4e65d2711cf5255970948e047cf
+inherit go-module
+
+DESCRIPTION="Manipulation tool for OCI images"
+HOMEPAGE="https://github.com/opencontainers/umoci"
+SRC_URI="https://github.com/opencontainers/umoci/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="dev-go/go-md2man"
+
+RESTRICT+=" test "
+
+src_compile() {
+ go build -buildmode=pie -mod=vendor \
+ -ldflags "-w -X main.gitCommit=${COMMIT} -X main.version=${PV}" \
+ -o "bin/${PN}" ./cmd/${PN} || die
+ cd doc/man
+ for f in *.1.md; do
+ go-md2man -in ${f} -out ${f%%.md} || die
+ done
+}
+
+src_install() {
+ dobin bin/${PN}
+ doman doc/man/*.1
+ dodoc CHANGELOG.md
+ einstalldocs
+}