summaryrefslogtreecommitdiff
path: root/app-containers
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-14 04:04:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-14 04:04:03 +0100
commit2916cf6049cf9d3092021e247d56c580df6029a7 (patch)
treec796a6fc8b6fd0e4fd5ac06b009000b438fed7d9 /app-containers
parent7b5306e0d287565138e8b051e32f57e6af6ae0ed (diff)
gentoo auto-resync : 14:10:2024 - 04:04:03
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/Manifest.gzbin8883 -> 8879 bytes
-rw-r--r--app-containers/distrobox/Manifest2
-rw-r--r--app-containers/distrobox/distrobox-1.8.0.ebuild35
3 files changed, 37 insertions, 0 deletions
diff --git a/app-containers/Manifest.gz b/app-containers/Manifest.gz
index 28fa2ea9c663..6e75688ff404 100644
--- a/app-containers/Manifest.gz
+++ b/app-containers/Manifest.gz
Binary files differ
diff --git a/app-containers/distrobox/Manifest b/app-containers/distrobox/Manifest
index b82d14ba7757..2ea595ee2a2c 100644
--- a/app-containers/distrobox/Manifest
+++ b/app-containers/distrobox/Manifest
@@ -1,4 +1,6 @@
DIST distrobox-1.7.2.1.tar.gz 6888919 BLAKE2B 1fd4e49585f686cf9f434c3285935bdda1131684b74dfcc20b018ab9853fb13516f3dbaf7c16b9ea55a0d038e3d9eb297bcea74c95755fbe60ef6512a9ce0df8 SHA512 aaf4324a9a31844dc08a6cc4e06d3b725675c92df01b558e733c96701d7e9700baabc1afad97ce5e2a8e2345defcea71c85f0ea6667249316f850aeca5aea149
+DIST distrobox-1.8.0.tar.gz 6915152 BLAKE2B ac1d3e8b99c1f9ec93518ec92c023aab76849a258e0482c23667ac3e7f4f80b4e93a4c7f0636c1bdd93dfe3dc67ccfc28261fb7f83d998259b8a0209534d3c90 SHA512 5d34c8aea935a6ea328071268b63ba8a5cd3e7962f85e9753e0adfcca6121c560d790124a1ce288ec6362e4c58e4e732d45a2873053a48a3d9b8bd823ddd72c5
EBUILD distrobox-1.7.2.1.ebuild 734 BLAKE2B 391976f5651c6072522ceb8439f16217d4ae674939b051633b0d32fe2bcd55950e1636665eed225031f672d339ab4fa984e0efb30254e237feb4d60bf14d09ec SHA512 ff39262d7637f63373dc2068ef5887c4d7f30c0fe6225dd25c4485a54beff7cfb8c8838d6d7615bb855ea03ec9d3a965bbddeba63910ba8017f9ab1e820805ff
+EBUILD distrobox-1.8.0.ebuild 735 BLAKE2B d890d017d6ca94fe6969486b6c32a89554e7b15d3650633604f4014d3befe4abe2289e786ac1b106ce20b821617c89c1ab9a6ceb45b31f856e3f6bdfaa876222 SHA512 b46ba4f4e35f13721750a8db9fb255e776c2f08ba64b939d6b9c9faef13e5bfda72b9a970d5f0e486f2ea1ebe63adba125fe3e0505a77a6c346ecd03025f4cfd
EBUILD distrobox-9999.ebuild 747 BLAKE2B c0e47c0cd8b825792647ae6bc12f9771eb2527d62b1e779e652b0580103e5668f191ffa2fd9db3ccabdb078c48d68ce3054390ced200112202f9ee9c2c3c6bcd SHA512 8e7673d428025cf9515f8f93169464afeaec9d2cd9050774dcd8d09f47e933e69a6b0787b7ac9b56842a9e1490149a6ac51f5ffe6915aa345407c8ef5a948b2a
MISC metadata.xml 957 BLAKE2B a02f57f2c65a9241edbc6a1e99170712ceca000977c2271ba51c5311e7718471585ea791ed8c978a86a961d02450623c05b5f9006d4386be2130df08341b0e49 SHA512 65f455bcfd246a8de0084e1534dc85f09435f1fad2590ba87dda0bed90d8fa976d3fad2142b2006a596e713d3d91f0d3d3156017cebacf9dc7883596edb0740f
diff --git a/app-containers/distrobox/distrobox-1.8.0.ebuild b/app-containers/distrobox/distrobox-1.8.0.ebuild
new file mode 100644
index 000000000000..0a328c47011d
--- /dev/null
+++ b/app-containers/distrobox/distrobox-1.8.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Use any Linux distribution inside your terminal (powered by docker/podman)"
+HOMEPAGE="https://distrobox.it/
+ https://github.com/89luca89/distrobox/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/89luca89/${PN}.git"
+else
+ SRC_URI="https://github.com/89luca89/${PN}/archive/${PV}.tar.gz
+ -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-3" # GPL-3.0-only !
+SLOT="0"
+
+RDEPEND="
+ || (
+ app-containers/docker
+ app-containers/podman
+ )
+"
+
+src_install() {
+ sh ./install --prefix "${ED}/usr" || die "${PN} install script failed"
+
+ dodoc *.md
+}