summaryrefslogtreecommitdiff
path: root/app-containers
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-19 00:15:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-19 00:15:15 +0000
commit2e512e4e32285f8c4eb19586d014cb9d31454ec9 (patch)
treee5884cadbd260c6936495a63b92f4503d54e5428 /app-containers
parent5264c18a325553759d67fb4e059db03cf3fc5c81 (diff)
gentoo auto-resync : 19:02:2025 - 00:15:15
Diffstat (limited to 'app-containers')
-rw-r--r--app-containers/Manifest.gzbin9397 -> 9395 bytes
-rw-r--r--app-containers/nvidia-container-toolkit/Manifest2
-rw-r--r--app-containers/nvidia-container-toolkit/nvidia-container-toolkit-1.17.4.ebuild57
3 files changed, 59 insertions, 0 deletions
diff --git a/app-containers/Manifest.gz b/app-containers/Manifest.gz
index 6c7242d0efe5..4f107d00579a 100644
--- a/app-containers/Manifest.gz
+++ b/app-containers/Manifest.gz
Binary files differ
diff --git a/app-containers/nvidia-container-toolkit/Manifest b/app-containers/nvidia-container-toolkit/Manifest
index a8a982314670..3f44a84d3558 100644
--- a/app-containers/nvidia-container-toolkit/Manifest
+++ b/app-containers/nvidia-container-toolkit/Manifest
@@ -1,5 +1,7 @@
AUX config.toml 1130 BLAKE2B 24a0a33239b688bd9cfc001dc35e5f3d3ef365a322a0652ed113b54e6fa8708d98972cb6902c9de0b5a47e50460834646a3ae0763f95006e580673ff4833a34d SHA512 47d687f3c73810d2fd46d97ed00f33ff5f10cb09708828fefb6d0e542a10b4d6c8e84a91f75de09b3ba642226b19224205e635fc1db9862b9a3d6a3a3bdc854b
DIST nvidia-container-toolkit-1.17.3.tar.gz 2718001 BLAKE2B 455a4159c45846951e8ebaee94393e20764e9e6cac10247dcbd4d9a16431a529ebe9bd6146fb590c1ea92f2e5f4c5561adfa6b8b495fe79f761e5664661acad4 SHA512 8c7a4290a1decc448c72e9a09213e0dc4e418ec633cefb16bb6b01fef7c502d23ed72cc1f3cc6583cad07feae5ca3cf44dad73e1274e042e3b26bdc7a4152b95
+DIST nvidia-container-toolkit-1.17.4.tar.gz 2720079 BLAKE2B 48f040872e6545455736bd8b4931ebc3988cb78d51c3a763987504b882ad2a79ada9e98251f06f14f2199cd89680beb14e84fdc444ef3a51ac1b7e1d89e95d98 SHA512 ba79670cfc5e0abec388af858f2f7f1a153c5bc90f0b9540ffc6a095b8724f08c329742bc22cdc700299e063668bf574a7ac0bfa4c964763370c9b0500d5057c
EBUILD nvidia-container-toolkit-1.17.3.ebuild 1502 BLAKE2B 108370a31d77c4955f32c17caf016f00697b5c6d38d9155c58c7c241f4b5f48683999dc20683fca8a0313ae3b5934227cea18f867c30bdd681a740a7cd8e6869 SHA512 17e283bf4797d75df39aac82dbdcf57764b8a5a527111e0b2512357548ad04bf879cbfdb0a460ffb930e39850f1cd15bbfd4bce44951e47a2e03ea050b20b015
+EBUILD nvidia-container-toolkit-1.17.4.ebuild 1503 BLAKE2B 54fab115bf07264d79c4b143c5b8cea230e186e12050dfa9b46d7badac3402a16078f10f1de1f2a2fdc5099ba4e728e67431c3b968564a11ccbd4877f900f13d SHA512 6165794821359548dc4f99af36cfcb950ae8144efcfff3749998e98ad8744303e56417996c0402e11b495538be2a7d8e5f35b3d74e70ad8a1d24b502299b9556
EBUILD nvidia-container-toolkit-9999.ebuild 1486 BLAKE2B f3e27b073ed2334130f506df05c097ea5caad732b270dea53bb6c07218d2b3b156eececc5d932942e38e690e894981bb8099054b9769475bdd83646623c45e1c SHA512 8a781577a9f29d04ebfb622f2e66f9d0d2e46657852b5c779793b3d28b85198b38c21d94e5521209f5794d909b37f51725fafa061433a94b33115382db898b06
MISC metadata.xml 1672 BLAKE2B 3bb58cdae08bd91f99f505959c22d38e7aab8715e0160267789d17fc4fbc2f73c22a27a2e8d9b17c3a89e921727bddc72d41f8131718265ef04b6925ea265b34 SHA512 ff02a65b51bfa54dea7cd20ca864b9c50109b50bad0d64a5ecb9bdc99fef1318ff0cec23724b99361f46fcdb8f09cc8195abc3f99c6aa31bd1c82cd3225bed51
diff --git a/app-containers/nvidia-container-toolkit/nvidia-container-toolkit-1.17.4.ebuild b/app-containers/nvidia-container-toolkit/nvidia-container-toolkit-1.17.4.ebuild
new file mode 100644
index 000000000000..95f1f966d9b2
--- /dev/null
+++ b/app-containers/nvidia-container-toolkit/nvidia-container-toolkit-1.17.4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+EGO_PN="github.com/NVIDIA/${PN}"
+
+inherit go-module
+
+DESCRIPTION="NVIDIA container runtime toolkit"
+HOMEPAGE="https://github.com/NVIDIA/container-toolkit"
+
+if [[ "${PV}" == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/NVIDIA/${PN}.git"
+else
+ SRC_URI="
+ https://github.com/NVIDIA/${PN}/archive/v${PV/_rc/-rc.}.tar.gz -> ${P}.tar.gz
+ "
+ S="${WORKDIR}/${PN}-${PV/_rc/-rc.}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+
+# Some tests may require specific environmental setups or additional hardware.
+RESTRICT="test" # Bug 831702
+
+RDEPEND="
+ >=sys-libs/libnvidia-container-$(ver_cut 1-2)
+"
+
+src_compile() {
+ emake binaries
+}
+
+src_install() {
+ dobin nvidia-cdi-hook \
+ nvidia-container-runtime \
+ nvidia-container-runtime.cdi \
+ nvidia-container-runtime.legacy \
+ nvidia-container-runtime-hook \
+ nvidia-ctk
+ insinto "/etc/nvidia-container-runtime"
+ doins "${FILESDIR}/config.toml"
+}
+
+pkg_postinst() {
+ elog "Your docker or containerd (if applicable) service may need restart"
+ elog "after install this package:"
+ elog "OpenRC: rc-service containerd restart; rc-service docker restart"
+ elog "systemd: systemctl restart containerd; systemctl restart docker"
+ elog "You may need to edit your /etc/nvidia-container-runtime/config.toml"
+ elog "file before running ${PN} for the first time."
+ elog "For details, please see the NVIDIA docker manual page."
+}