summaryrefslogtreecommitdiff
path: root/app-crypt/acme-client
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-crypt/acme-client
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-crypt/acme-client')
-rw-r--r--app-crypt/acme-client/Manifest3
-rw-r--r--app-crypt/acme-client/acme-client-0.1.16.ebuild30
-rw-r--r--app-crypt/acme-client/metadata.xml13
3 files changed, 46 insertions, 0 deletions
diff --git a/app-crypt/acme-client/Manifest b/app-crypt/acme-client/Manifest
new file mode 100644
index 000000000000..d871368d2c38
--- /dev/null
+++ b/app-crypt/acme-client/Manifest
@@ -0,0 +1,3 @@
+DIST acme-client-portable-0.1.16.tgz 53129 BLAKE2B ece1ce752fc2f0828264ed15a454f1b1e91c0e8041add10acc6fe385566b32fafa07c530f5b88dfe73a351a2ec4e427096d2e8a2714f8eea1eee71c0cc721102 SHA512 730c20bdf9d72b24e66c54b009a282e04da3ea8ce3b9eb053750672c53c9586b2879d87a565ddbab033d7ba6a577dd6399313b20cf654b185905db4de988b6b7
+EBUILD acme-client-0.1.16.ebuild 611 BLAKE2B bff00297ac2a3a1fcd972196f4711e0378570860bd8aab91a87395ba57acb8ec9fd90a90b6d8233c9cb37bfd84fe7e1bbcc0062728b2092546e123aed5f5dd43 SHA512 7dd8c35117b0fd66ee1dfbcbf83cf36407b547b9c47cf124227f5532a63e6044715db69a688f98910d35768f36b504d02cbc128e2782d554ef0786dcf9ab237e
+MISC metadata.xml 500 BLAKE2B 2fe75ff442811bc3141c050cc66a14418d2a3eadfdb69faf03dd2c3d944ad33581b5d4dbe8f50a446f144f095ea71da525873c8888e75759d95b15d42013eb7b SHA512 a07671d8912b83c15baebd76cfd41b8e023f8796a18a4487f6af712f3dad1967b90e35f366e1751cb1574b1b94f6746e464240ff2974cdb033895c8a8fd8c80c
diff --git a/app-crypt/acme-client/acme-client-0.1.16.ebuild b/app-crypt/acme-client/acme-client-0.1.16.ebuild
new file mode 100644
index 000000000000..938a037ee398
--- /dev/null
+++ b/app-crypt/acme-client/acme-client-0.1.16.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="a secure ACME client"
+HOMEPAGE="https://kristaps.bsd.lv/acme-client"
+SRC_URI="https://kristaps.bsd.lv/acme-client/snapshots/${PN}-portable-${PV}.tgz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/libressl
+ dev-libs/libbsd"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${PN}-portable-${PV}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ DESTDIR="${D}" PREFIX="/usr" MAN1DIR="/usr/share/man/man1" emake install
+ dodoc ChangeLog
+}
diff --git a/app-crypt/acme-client/metadata.xml b/app-crypt/acme-client/metadata.xml
new file mode 100644
index 000000000000..86cb5dc28cec
--- /dev/null
+++ b/app-crypt/acme-client/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>cedk@gentoo.org</email>
+ <name>Cédric Krier</name>
+ </maintainer>
+ <longdescription lang="en">
+ acme-client is a client for Let's Encrypt users, but one designed for
+ security. No Python. No Ruby. No Bash. A straightforward, open source
+ implementation in C that isolates each step of the sequence.
+ </longdescription>
+</pkgmetadata>