summaryrefslogtreecommitdiff
path: root/app-crypt/acme
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-05 05:53:25 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-05 05:53:25 +0100
commit3f5490a92f684d302af15210584c70ed8ea3fab4 (patch)
tree641a95536c4796f995e98f72b6c4cc833c94bfac /app-crypt/acme
parent1b2c0d19f75523db182b267901484f87abf732cf (diff)
gentoo auto-resync : 05:10:2023 - 05:53:25
Diffstat (limited to 'app-crypt/acme')
-rw-r--r--app-crypt/acme/Manifest2
-rw-r--r--app-crypt/acme/acme-2.7.0.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/app-crypt/acme/Manifest b/app-crypt/acme/Manifest
index 295589a43ee2..e7f237d6b3a6 100644
--- a/app-crypt/acme/Manifest
+++ b/app-crypt/acme/Manifest
@@ -1,4 +1,6 @@
DIST certbot-2.6.0.gh.tar.gz 1336339 BLAKE2B 0c0575ad553ebe0f3ab56da750572bca46b30d034033e43c30c3793c114050ad824a277eab0be5a47326ea099e58e9a421448b53fc1b9173afae9a0ec308ac62 SHA512 d694156886484511f5a38fb5e40f98b2e2dbe4bc5110c95b2084ec03b39cb0eb9bbc623c7bca4a81054e980c8dbac752949042391813298a27be7e70410882e3
+DIST certbot-2.7.0.gh.tar.gz 1336481 BLAKE2B 224f26819ee55b99a26540e7f56a8466c806d08149cce511d28d77ce9f5fb8073ec65e6cfa3e0c168ca84ddcbf85478ff335b84feaadee66db6c5a811be202be SHA512 1e1defcd143f804a36b50e3104d239bf20873545474ceb654269a5879e15cfbb76a18bd569f5e6e12de1036779e72c74d9896707daabc314fc5d67acc1c5180d
EBUILD acme-2.6.0.ebuild 1506 BLAKE2B eaac3de9e1b624f7ce6ae78429e94b7828dd3075ca8dccb438833fdbf3441b13d4e66c9a7b933691581c8edb87ab2a8971641b67b66b8387b46e52a74dc4b57f SHA512 dfe6e029e7f6c525d366b5399ffa5513ce2fb113cab50892d9b4dea01b74ca867d316f81dec93f93a14fbb902b596f2662358bcf561a69c172ea7094520bbc2e
+EBUILD acme-2.7.0.ebuild 1510 BLAKE2B 90d6f2b5c740938e43199b63deabb24c58482977654f6c2a4eb76493961772a4f296452af46dbb1b9437c823a6916b6d2a5d6a3155793198720b5988604e9239 SHA512 b6324a3f7aae817df99ea8e58d21ba380824126dd810717a0053c4849754b833003d7cf399aefb514d9377accbb823ac81b2c9d0c0a9d095313d701e5ddc3f09
EBUILD acme-9999.ebuild 1510 BLAKE2B 90d6f2b5c740938e43199b63deabb24c58482977654f6c2a4eb76493961772a4f296452af46dbb1b9437c823a6916b6d2a5d6a3155793198720b5988604e9239 SHA512 b6324a3f7aae817df99ea8e58d21ba380824126dd810717a0053c4849754b833003d7cf399aefb514d9377accbb823ac81b2c9d0c0a9d095313d701e5ddc3f09
MISC metadata.xml 401 BLAKE2B 30a2ac1f03749a8e3bb98723c57f47ab6bcf7bfa58c2b6e21c309fae279feca0d3612df6c2a1dafaf27b4f0781c583a140322feac1a1cf2c13e50861cad129ea SHA512 d8e725b71ca81ce4ca6565ed58271b283c25394448f0f48f726f232122577c33d5b2d726e117419b2fae99f9dae29a8080bb9564eccbca13368c83988cf3da01
diff --git a/app-crypt/acme/acme-2.7.0.ebuild b/app-crypt/acme/acme-2.7.0.ebuild
new file mode 100644
index 000000000000..88e179e64295
--- /dev/null
+++ b/app-crypt/acme/acme-2.7.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+PARENT_PN="certbot"
+PARENT_P="${PARENT_PN}-${PV}"
+
+if [[ "${PV}" == *9999 ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ EGIT_SUBMODULES=()
+ EGIT_CHECKOUT_DIR="${WORKDIR}/${PARENT_P}"
+else
+ SRC_URI="
+ https://github.com/certbot/certbot/archive/v${PV}.tar.gz
+ -> ${PARENT_P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="An implementation of the ACME protocol"
+HOMEPAGE="
+ https://github.com/certbot/certbot
+ https://letsencrypt.org/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+S="${WORKDIR}/${PARENT_P}/${PN}"
+
+BDEPEND="
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ )
+"
+# The requirement is really 17.5.0 but easier to require latest stable >= 23.1.1
+# to avoid broken 23.1.0.
+RDEPEND="
+ dev-python/chardet[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-3.2.1[${PYTHON_USEDEP}]
+ >=dev-python/josepy-1.13.0[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-23.1.1[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2019.3[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.20.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.3.0[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest