summaryrefslogtreecommitdiff
path: root/app-crypt/acme
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /app-crypt/acme
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'app-crypt/acme')
-rw-r--r--app-crypt/acme/Manifest4
-rw-r--r--app-crypt/acme/acme-1.10.1.ebuild69
-rw-r--r--app-crypt/acme/metadata.xml2
3 files changed, 73 insertions, 2 deletions
diff --git a/app-crypt/acme/Manifest b/app-crypt/acme/Manifest
index 27430e8896d7..3b201057aac6 100644
--- a/app-crypt/acme/Manifest
+++ b/app-crypt/acme/Manifest
@@ -1,4 +1,6 @@
+DIST certbot-1.10.1.tar.gz 1416402 BLAKE2B e00ba6bf69dbf4bc91be325d4c9ba470214aeef18b4ad4ac5efbf7d077ffa9498e9cff2eff00045bc1024930f95ec56e1773c3a193a982b393caf7ee19f8ccc0 SHA512 332e92dd7d91b9774e55ef8d2c0217a57167a26d1e86d36196fc601b4abb23f40033f94112c4b4bff5f8bc54e1e32ecd68b1f01e7d67bc4fd8f7dd98ce0362cc
DIST certbot-1.9.0.tar.gz 1425703 BLAKE2B 9bf78824649870b3e1fc3175aae551cbfaa675a8930a89f35ba2330647d86798e4fc43011c617be2d278ab20c43dd05b02e8e61956dd7f9d10d444181874346e SHA512 098d8c077f5760c1f40f7d673820488ad7643c8b9c12561a58921cd95f60ae76515cefc19f822747f3385a68eba6f49fe5484b20142994ef67a26b0b16293ce8
+EBUILD acme-1.10.1.ebuild 1727 BLAKE2B ac84ebb7f4297d6c2161f92ca674459aac9aff9eeabdefc5809a86821f7e93c91711380ec73748ba65440ff9e9d301e48b2f5e88ebeb4f4043bde6443962d26f SHA512 d1f1b78f04222efea90fe258cd1a45c43da90cea1d45b5158d72fb7a094c3f04d0b84a2e073fed365eaeea8a20c383fc572378d679ac37a1fd332a309d18c281
EBUILD acme-1.9.0.ebuild 1721 BLAKE2B b6f1bf82f1a856659e423bf64da1e1db084e6ce9a3583cbdad5de574441b2b2a1216f23961352decd9323f8c6c115502d426312070891e1411d8632054a871ef SHA512 a017fea91a2c3b3ef8596e8a80b3bc9576e7fe80f4cea844b0be5a56c12578854a27b46c2921d0b5f32add2f4b64154a54b1183442c051366ae3764910cec668
EBUILD acme-9999.ebuild 1723 BLAKE2B 1f9dcf588af71aa02df863c8d2704b261586fb72b088161cf4fd0643a941e7cf55f9d450c3a6c39bc9075092b63d62f7a16f2f5b295870de41c3bf409ab4e191 SHA512 cf5d3780b7dc9faf510b00ecd4342b52b6133f5852c7afe732ca50e52825cc6f8d55e3400928d3e99793e2457b86e8c0c1d199820fe3e2a086c596b4586970f0
-MISC metadata.xml 384 BLAKE2B 55780995cb61c11ca859c9f1de17b1c22c9c92902f551ccd1ee6f030df9d513bb5519a2c62bf33bc6a5872790d033ba966e5ed137d84a4f66ab4ba7636a88887 SHA512 cf8393b25aa363bc1db4ebd23274affd1eaf999a4c2ab8d359730f421961dafd5c96fcf14c247f3f5419616116e2351d72fbf0e29301ea44ac522e865c7b0fa1
+MISC metadata.xml 376 BLAKE2B 5a7076ef341b2599d7e91af0f563af2f1e1d7d9e85a02d78af75d87ea2f57ab06f603da824cb5e256191a25869c51891d5ce4c6dbf23fff1caa891fe4672828e SHA512 c3a734211c0053c85646aaa7ab03af05b021342b345da4bef5e37941ac19530a7f122abf276a9e7cd0b00ff7f3a087892ff6e98a4bec937dacae38f142a547ec
diff --git a/app-crypt/acme/acme-1.10.1.ebuild b/app-crypt/acme/acme-1.10.1.ebuild
new file mode 100644
index 000000000000..e6b050a6c6a9
--- /dev/null
+++ b/app-crypt/acme/acme-1.10.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python{3_6,3_7,3_8,3_9})
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/certbot/certbot/archive/v${PV}.tar.gz -> certbot-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+ S=${WORKDIR}/certbot-${PV}/acme
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="An implementation of the ACME protocol"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/cryptography-1.3.4[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/josepy-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.15.1[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.10[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.3.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+ distutils-r1_src_compile
+ if use doc ; then
+ cd docs || die
+ sphinx-build -b html -d _build/doctrees . _build/html
+ fi
+}
+
+python_test() {
+ nosetests -w ${PN} || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/app-crypt/acme/metadata.xml b/app-crypt/acme/metadata.xml
index d0f0d1620b50..4f4e4466f8aa 100644
--- a/app-crypt/acme/metadata.xml
+++ b/app-crypt/acme/metadata.xml
@@ -7,6 +7,6 @@
</maintainer>
<upstream>
<remote-id type="pypi">acme</remote-id>
- <remote-id type="github">letsencrypt/letsencrypt</remote-id>
+ <remote-id type="github">certbot/certbot</remote-id>
</upstream>
</pkgmetadata>