summaryrefslogtreecommitdiff
path: root/app-crypt/acme
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /app-crypt/acme
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'app-crypt/acme')
-rw-r--r--app-crypt/acme/Manifest4
-rw-r--r--app-crypt/acme/acme-1.4.0.ebuild69
-rw-r--r--app-crypt/acme/acme-9999.ebuild1
3 files changed, 72 insertions, 2 deletions
diff --git a/app-crypt/acme/Manifest b/app-crypt/acme/Manifest
index e50459e711f9..c8dd6ab0ff94 100644
--- a/app-crypt/acme/Manifest
+++ b/app-crypt/acme/Manifest
@@ -1,4 +1,6 @@
DIST certbot-1.3.0.tar.gz 1362945 BLAKE2B bb36a7737275332f018d7f2283286e07e041892cc366f79e68df9eee7e57ca2186d36895d1923b032068a365878d09e49e17c1399a7418dbd8607c9a7efc1c26 SHA512 4205cdd1f3ddf500b9b952744db234636c086a856df80acd2d776305f4501eed07995e453e5c9b2c711fb0d1f1987d2bb8baaa13fccce8e000a38f486cfdc5d3
+DIST certbot-1.4.0.tar.gz 1381435 BLAKE2B 57d70a12ee38e1ba96f4c8c594c1940403e33d4cdf5111472a9c0c7d41061b2201792c38d9bb4ec516358f5592d2f689eeab31e1e686a534418b20eba2df4b4b SHA512 8926f724c47c0249e2e420cd8944f0b106682efaa2d9b211491ea4524fe4e64bb3ff4f21fd756996049d781a68294ab8307bd077b6d96fa00e09cbbdf4e59261
EBUILD acme-1.3.0-r1.ebuild 1770 BLAKE2B dd2b344dc9157631cadafaec85f9bf220444917e71be0166a513d2eb0ac9d863aa3369f2c61c11bf4b9fb9054a1a0e59b28fe6b92aa0c686133fb4b8cbcefc71 SHA512 caba8e15d9e396d9707cf868cc1ec76be17b462d5be08508df8f02ef16c093b55ae770e8f68e97a0d19cd030a8ac087c3e980829eccb8458f5e1bf770a86d947
-EBUILD acme-9999.ebuild 1772 BLAKE2B fd15cbcf90416ad182432bbee91d262fbcc5b3b3304fe226b61a6ff368c9ecdeea8d554a2b57ccf3d280da9cb0d8bcd4a32de5c8fe5b2b53a890db6084bc7544 SHA512 e905702e2cf1f89e453876a828d377c2c50cb5f157b7fe538501a24ade7306bcf9be160b8bd748156d6769a15c21d363a02be0c90517a0d89c7082c7fefc1e42
+EBUILD acme-1.4.0.ebuild 1737 BLAKE2B 06af2a535bda2baf9baa807647ede63d0189d66e0bedf02e5ec1fe4d33f4b804a4c620163bee5247ae9558d886f918bea761aeb361636a18138c4f91dee9cb54 SHA512 a8f6f502cc67c3bf355e064718293d31fbb993563a12cf87c2dafe41f724e60e6e93a4bdc3ac048a4fc7c2b5fe7be169510b0a779937e26347052ab83fee92eb
+EBUILD acme-9999.ebuild 1737 BLAKE2B 06af2a535bda2baf9baa807647ede63d0189d66e0bedf02e5ec1fe4d33f4b804a4c620163bee5247ae9558d886f918bea761aeb361636a18138c4f91dee9cb54 SHA512 a8f6f502cc67c3bf355e064718293d31fbb993563a12cf87c2dafe41f724e60e6e93a4bdc3ac048a4fc7c2b5fe7be169510b0a779937e26347052ab83fee92eb
MISC metadata.xml 384 BLAKE2B 55780995cb61c11ca859c9f1de17b1c22c9c92902f551ccd1ee6f030df9d513bb5519a2c62bf33bc6a5872790d033ba966e5ed137d84a4f66ab4ba7636a88887 SHA512 cf8393b25aa363bc1db4ebd23274affd1eaf999a4c2ab8d359730f421961dafd5c96fcf14c247f3f5419616116e2351d72fbf0e29301ea44ac522e865c7b0fa1
diff --git a/app-crypt/acme/acme-1.4.0.ebuild b/app-crypt/acme/acme-1.4.0.ebuild
new file mode 100644
index 000000000000..1d83c8b8d408
--- /dev/null
+++ b/app-crypt/acme/acme-1.4.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python{3_6,3_7,3_8})
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+ S=${WORKDIR}/${P}/${PN}
+else
+ SRC_URI="https://github.com/certbot/certbot/archive/v${PV}.tar.gz -> certbot-${PV}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+ S=${WORKDIR}/certbot-${PV}/acme
+fi
+
+inherit distutils-r1
+
+DESCRIPTION="An implementation of the ACME protocol"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/cryptography-1.3.4[${PYTHON_USEDEP}]
+ >=dev-python/idna-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/josepy-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.13.1[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.10[${PYTHON_USEDEP}]
+ >=dev-python/requests-toolbelt-0.3.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ )
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+ >=dev-python/setuptools-1.0[${PYTHON_USEDEP}]
+"
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+ distutils-r1_src_compile
+ if use doc ; then
+ cd docs || die
+ sphinx-build -b html -d _build/doctrees . _build/html
+ fi
+}
+
+python_test() {
+ nosetests -w ${PN} || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/app-crypt/acme/acme-9999.ebuild b/app-crypt/acme/acme-9999.ebuild
index baec59de4e1e..1d83c8b8d408 100644
--- a/app-crypt/acme/acme-9999.ebuild
+++ b/app-crypt/acme/acme-9999.ebuild
@@ -28,7 +28,6 @@ RDEPEND="
>=dev-python/cryptography-1.3.4[${PYTHON_USEDEP}]
>=dev-python/idna-2.0.0[${PYTHON_USEDEP}]
>=dev-python/josepy-1.1.0[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
>=dev-python/pyopenssl-0.13.1[${PYTHON_USEDEP}]
dev-python/pyrfc3339[${PYTHON_USEDEP}]
dev-python/pytz[${PYTHON_USEDEP}]