summaryrefslogtreecommitdiff
path: root/app-crypt/acmebot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /app-crypt/acmebot
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'app-crypt/acmebot')
-rw-r--r--app-crypt/acmebot/Manifest2
-rw-r--r--app-crypt/acmebot/acmebot-2.7.0.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/app-crypt/acmebot/Manifest b/app-crypt/acmebot/Manifest
index 1eb0a0579c7e..f227dfa50f96 100644
--- a/app-crypt/acmebot/Manifest
+++ b/app-crypt/acmebot/Manifest
@@ -1,4 +1,6 @@
DIST acmebot-2.3.0.tar.gz 64841 BLAKE2B 92bfb9a58722b9955fe908e2fcb1a3ee593bf87e3fdf3dc9564bcbe291b13c553ad426673c337a59344287da64c4ee5cffc734f8dfb60447f96d6234814f0167 SHA512 3951cc7138eb0b83bd802a2e0a221fa985209ba276028606d887b7d2eff84c35db034f4a3d8a6836b3ac149c6dbfa27b1ea47e864f549f8d88b758b40407c4f4
+DIST acmebot-2.7.0.tar.gz 76385 BLAKE2B 28b0fd81735e2dbff493dbcfe0194d62dea8d233866dcb235bb0efac562d2f3884f53226f979e8cd6050078f59b0b1e6d20d2eeea6d762363526686ef8c5ead1 SHA512 1b8fa21c2dc60a940e2fa13d5d599025088644862c985749d72f4f16ebd4ad48970b7fcf656fb34cf63d3c2ff2cbb157d7446c17a7f9da3cffd8611e499c400e
EBUILD acmebot-2.3.0-r1.ebuild 1204 BLAKE2B 3e8c2819fbfcf03532e9d3a4e27bab49d1c71b731ed57e1b9670feeb2976e87b9ba996d4d86f44b5e64d83ec6150cdf86ad4797365558875fec738eeb3e85150 SHA512 f55d679599a23d555e295b4ff5d6618c0b6ba8412da22d139bf9502a78509984fda7654eed2c69781e37c02e13482be723469468297697820df68ad221d1467f
+EBUILD acmebot-2.7.0.ebuild 1439 BLAKE2B 0a2d1e8fcd954aeb170d93d89aabdf694fa912bbffeb87e99a554fee0d4d929df906c0de785b8bad53fbc183cf4fa02c703ea5529afe2c29ef08584345bfce1b SHA512 46324c58e46f480cb1b9b7cff47f220df96a40c4c8714769a517e5e8be52d7ccba9c058bcf2944962e1cfcf357ac5b1c06e3b5031abebf2008c59501d57d41b3
EBUILD acmebot-9999.ebuild 1204 BLAKE2B 3e8c2819fbfcf03532e9d3a4e27bab49d1c71b731ed57e1b9670feeb2976e87b9ba996d4d86f44b5e64d83ec6150cdf86ad4797365558875fec738eeb3e85150 SHA512 f55d679599a23d555e295b4ff5d6618c0b6ba8412da22d139bf9502a78509984fda7654eed2c69781e37c02e13482be723469468297697820df68ad221d1467f
MISC metadata.xml 216 BLAKE2B 20531789dc11e43feee7ec315a0c1c7249fdf73764e29cb7d6db439826e9ff72f24a5cdb8eb7f1ab99bbb41fb6e4226874a1d1fa4185de52598602bb3b0479a3 SHA512 e881b59fe49746eb25ad66c258b41aba501e4eb563129093a3898ea970a20506e7898f7c355cfcf99605234962bf2c77c1309c258b9a2b84ee4302ccb71c9dbd
diff --git a/app-crypt/acmebot/acmebot-2.7.0.ebuild b/app-crypt/acmebot/acmebot-2.7.0.ebuild
new file mode 100644
index 000000000000..e6b7da902b1b
--- /dev/null
+++ b/app-crypt/acmebot/acmebot-2.7.0.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python3_{7,8})
+EGIT_REPO_URI="https://github.com/plinss/${PN}.git"
+[[ $PV == 9999 ]] && _scm=git-r3
+
+inherit ${_scm} python-single-r1
+
+DESCRIPTION="Certificate manager bot using ACME protocol"
+HOMEPAGE="https://github.com/plinss/acmebot"
+if [[ $PV != 9999 ]]; then
+ SRC_URI="https://github.com/plinss/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+[[ $PV != 9999 ]] && KEYWORDS="~amd64 ~x86"
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND=""
+RDEPEND="${PYTHON_DEPS}
+ $(python_gen_cond_dep '
+ >=dev-python/appdirs-1.4.3[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/pyparsing-2.2.0[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/packaging-16.8[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/pyopenssl-17.5.0[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/pydns-3.1.0:3[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/cryptography-2.1.4[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/asn1crypto-0.24.0[${PYTHON_MULTI_USEDEP}]
+ >=app-crypt/acme-0.25.1[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/pyyaml-3.1[${PYTHON_MULTI_USEDEP}]
+ ')
+ "
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+src_prepare() {
+ default
+ python_fix_shebang .
+}
+
+src_configure() {
+ :
+}
+src_compile() {
+ :
+}
+
+src_install() {
+ python_doscript acmebot
+ insinto /etc/logrotate.d
+ doins logrotate.d/acmebot
+ insinto /etc/acmebot
+ doins acmebot.example.json
+ dodoc README.rst
+}