summaryrefslogtreecommitdiff
path: root/app-crypt/ccid
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-crypt/ccid
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-crypt/ccid')
-rw-r--r--app-crypt/ccid/Manifest6
-rw-r--r--app-crypt/ccid/ccid-1.4.27.ebuild61
-rw-r--r--app-crypt/ccid/ccid-1.4.29.ebuild61
-rw-r--r--app-crypt/ccid/files/92_pcscd_ccid-2.rules50
-rw-r--r--app-crypt/ccid/metadata.xml12
5 files changed, 190 insertions, 0 deletions
diff --git a/app-crypt/ccid/Manifest b/app-crypt/ccid/Manifest
new file mode 100644
index 000000000000..a9603bd12b03
--- /dev/null
+++ b/app-crypt/ccid/Manifest
@@ -0,0 +1,6 @@
+AUX 92_pcscd_ccid-2.rules 2275 BLAKE2B a72b8d2bb8cf56f621a0762dac95500f93afa224228f403395c9590758c8fa986b3e8d0d1b12353ec7fed5a40f6af900fcd57eaaa7b339018fe42c2b509c0c5d SHA512 f327eee35ca6009069389f935ca89feea4e693e8f0c73f8f218d2639faee4ce35df85832a71e3fe98ce24aae31861aa8bd290833e59ada75c1e1a2df9ff0a477
+DIST ccid-1.4.27.tar.bz2 632817 BLAKE2B a18de0594c9535c4564bc27886fc69a0edc54343941d77b9558f331a932d12d2b58303ae3994337e380f16648f7bb2a8aa90c00aae4c7cffe242e000003c5dcd SHA512 14fb5d9878ed36de912d860d8537758170781f225957a99d5fed447dcfba0cba3133f78d2cc4bc7db60d3527399f70e4a7d1d1f8348fb50d1bcfc75820a23522
+DIST ccid-1.4.29.tar.bz2 635761 BLAKE2B ff14bc6e181a6d44b8ef463a2255d0362842f6e1e7c79e0a01caaba0a88892f7b0f2bd9d2dadae7be8b0655d2502e5471cff29e582928d62235fa070f2eb1ba8 SHA512 9ff37acad086e959f660069b245fe06ecada140623025a19dfbff55edec71e1e72bce09ac4fc506ad985dd0831dafc6b12f5a5b109b38bf9ba7583856eb19418
+EBUILD ccid-1.4.27.ebuild 1492 BLAKE2B 23f38ec767ff61b9da25eb292439956069b64ad2d162ada3454eeb2fe4db4d2436458a85e7f1858719d268a64e0d9db4bfc4c4062a5dea853e6075876dd4c16d SHA512 37a42df7ba9eeb766ad42f3e79d1bd85b80a753f11f7a4ebb0b088a95498212ea0d6fd98d541e28da0a39698d3446c6429416cc9fabedd9bf176bb0f9ea5add3
+EBUILD ccid-1.4.29.ebuild 1497 BLAKE2B e01d89f17e0f2d4932d92aa80f23143a5bc6bfd02566dfbbdc7730f8a2fd96f39064f898d6732c0f071be65ad9bf588e52bc01e0e2f447c5fce68940ee6eb74f SHA512 946b90228ee7f78abc5a825bb89df3c1d626bbff046e7833bd89eefc6b80b17b881606984b66dbb1fdeeeadb27cc19a5535102253fd5122bfa2e4b2928ca0c3b
+MISC metadata.xml 397 BLAKE2B 0b62fc531114bb9221d17ee3524db0858f4ff373b71a1b7beda520035eaf5679a63a420381dc52e40942a519bf15f95fae97b531267df133cf68687c49dad565 SHA512 8e8643f46728232ffffe25fe9906948c6a8bb94733dbdeaf2700afd0cf4a7567a27698c1832edf858c2a433187cac9d847dc7ad709d6398133b40b639e37cb4b
diff --git a/app-crypt/ccid/ccid-1.4.27.ebuild b/app-crypt/ccid/ccid-1.4.27.ebuild
new file mode 100644
index 000000000000..cb96feb53855
--- /dev/null
+++ b/app-crypt/ccid/ccid-1.4.27.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs udev
+
+DESCRIPTION="CCID free software driver"
+HOMEPAGE="https://ccid.apdu.fr/"
+SRC_URI="https://ccid.apdu.fr/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ppc ppc64 ~sparc x86"
+IUSE="twinserial kobil-midentity +usb"
+
+RDEPEND=">=sys-apps/pcsc-lite-1.8.3
+ usb? ( virtual/libusb:1 )"
+DEPEND="${RDEPEND}
+ kernel_linux? ( virtual/pkgconfig )"
+
+DOCS=( README AUTHORS )
+
+src_configure() {
+ econf \
+ LEX=: \
+ $(use_enable twinserial) \
+ $(use_enable usb libusb)
+}
+
+src_compile() {
+ default
+ use kobil-midentity && emake -C contrib/Kobil_mIDentity_switch
+}
+
+src_install() {
+ default
+
+ if use kobil-midentity; then
+ dosbin contrib/Kobil_mIDentity_switch/Kobil_mIDentity_switch
+ doman contrib/Kobil_mIDentity_switch/Kobil_mIDentity_switch.8
+ fi
+
+ if use kernel_linux; then
+ # note: for eudev support, rules probably will always need to be
+ # installed to /usr
+
+ # ccid >=1.4.11 version changed the rules drastically in a minor
+ # release to no longer use the pcscd group. Using the old ones in
+ # the mean time.
+ udev_newrules "${FILESDIR}"/92_pcscd_ccid-2.rules 92-pcsc-ccid.rules
+
+ # disable Kobil_mIDentity_switch udev rule with USE=-kobil-midentity
+ if ! use kobil-midentity; then
+ sed \
+ -e '/Kobil_mIDentity_switch/s/^/#/' \
+ -i "${D}/$(get_udevdir)"/rules.d/92-pcsc-ccid.rules || die
+ fi
+
+ fi
+}
diff --git a/app-crypt/ccid/ccid-1.4.29.ebuild b/app-crypt/ccid/ccid-1.4.29.ebuild
new file mode 100644
index 000000000000..96196218e361
--- /dev/null
+++ b/app-crypt/ccid/ccid-1.4.29.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs udev
+
+DESCRIPTION="CCID free software driver"
+HOMEPAGE="https://ccid.apdu.fr/"
+SRC_URI="https://ccid.apdu.fr/files/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="twinserial kobil-midentity +usb"
+
+RDEPEND=">=sys-apps/pcsc-lite-1.8.3
+ usb? ( virtual/libusb:1 )"
+DEPEND="${RDEPEND}
+ kernel_linux? ( virtual/pkgconfig )"
+
+DOCS=( README AUTHORS )
+
+src_configure() {
+ econf \
+ LEX=: \
+ $(use_enable twinserial) \
+ $(use_enable usb libusb)
+}
+
+src_compile() {
+ default
+ use kobil-midentity && emake -C contrib/Kobil_mIDentity_switch
+}
+
+src_install() {
+ default
+
+ if use kobil-midentity; then
+ dosbin contrib/Kobil_mIDentity_switch/Kobil_mIDentity_switch
+ doman contrib/Kobil_mIDentity_switch/Kobil_mIDentity_switch.8
+ fi
+
+ if use kernel_linux; then
+ # note: for eudev support, rules probably will always need to be
+ # installed to /usr
+
+ # ccid >=1.4.11 version changed the rules drastically in a minor
+ # release to no longer use the pcscd group. Using the old ones in
+ # the mean time.
+ udev_newrules "${FILESDIR}"/92_pcscd_ccid-2.rules 92-pcsc-ccid.rules
+
+ # disable Kobil_mIDentity_switch udev rule with USE=-kobil-midentity
+ if ! use kobil-midentity; then
+ sed \
+ -e '/Kobil_mIDentity_switch/s/^/#/' \
+ -i "${D}/$(get_udevdir)"/rules.d/92-pcsc-ccid.rules || die
+ fi
+
+ fi
+}
diff --git a/app-crypt/ccid/files/92_pcscd_ccid-2.rules b/app-crypt/ccid/files/92_pcscd_ccid-2.rules
new file mode 100644
index 000000000000..ca4d1ce1b729
--- /dev/null
+++ b/app-crypt/ccid/files/92_pcscd_ccid-2.rules
@@ -0,0 +1,50 @@
+# udev rules to set the access rights of CCID smart card readers
+# so they can be used by pcscd
+
+# $Id: 92_pcscd_ccid.rules 6587 2013-04-05 16:31:55Z rousseau $
+
+# Gemplus PCMCIA Card
+#SUBSYSTEMS=="pcmcia", DRIVERS=="serial_cs", ACTION=="add", ATTRS{prod_id1}=="Gemplus", ATTRS{prod_id2}=="SerialPort", ATTRS{prod_id3}=="GemPC Card", RUN+="/usr/sbin/pcscd --hotplug"
+
+# If not adding the device, go away
+ACTION!="add", GOTO="pcscd_ccid_rules_end"
+SUBSYSTEM!="usb", GOTO="pcscd_ccid_rules_end"
+ENV{DEVTYPE}!="usb_device", GOTO="pcscd_ccid_rules_end"
+
+# Kobil mIDentity
+ATTRS{idVendor}=="0d46", ATTRS{idProduct}=="4081", RUN+="/usr/sbin/Kobil_mIDentity_switch"
+
+# generic CCID device (bInterfaceClass = 0x0b)
+# change group from default "root" to "pcscd"
+ENV{ID_USB_INTERFACES}=="*:0b0000:*", ENV{PCSCD}="1"
+
+# set USB power management to auto. "power/level" has been deprecated in
+# Linux 2.6.35 and replaced by "power/control"
+ENV{ID_USB_INTERFACES}==":0b0000:", RUN+="/bin/sh -c 'if test -e /sys/$env{DEVPATH}/power/control; then echo auto > /sys/$env{DEVPATH}/power/control; elif test -e /sys/$env{DEVPATH}/power/level; then echo auto > /sys/$env{DEVPATH}/power/level; fi'"
+
+# non CCID generic (InterfaceClass: 0xFF)
+# CherrySmartTerminalST2XXX.txt
+ATTRS{idVendor}=="046a", ATTRS{idProduct}=="003e", ENV{PCSCD}="1"
+# DellSK-3106.txt
+ATTRS{idVendor}=="413c", ATTRS{idProduct}=="2100", ENV{PCSCD}="1"
+# MySmartPad.txt
+ATTRS{idVendor}=="09be", ATTRS{idProduct}=="0002", ENV{PCSCD}="1"
+# SCR3310-NTTCom USB SmartCard Reader
+ATTRS{idVendor}=="04e6", ATTRS{idProduct}=="511a", ENV{PCSCD}="1"
+# SCR331-DI USB Smart Card Reader
+ATTRS{idVendor}=="04e6", ATTRS{idProduct}=="5120", ENV{PCSCD}="1"
+# SCR331-DI.txt
+ATTRS{idVendor}=="04e6", ATTRS{idProduct}=="5111", ENV{PCSCD}="1"
+# SDI010.txt
+ATTRS{idVendor}=="04e6", ATTRS{idProduct}=="5121", ENV{PCSCD}="1"
+# SPR532.txt
+ATTRS{idVendor}=="04e6", ATTRS{idProduct}=="e003", ENV{PCSCD}="1"
+# Verisign_secure_storage_token.txt
+ATTRS{idVendor}=="08e6", ATTRS{idProduct}=="1359", ENV{PCSCD}="1"
+# Verisign_secure_token.txt
+ATTRS{idVendor}=="08e6", ATTRS{idProduct}=="ace0", ENV{PCSCD}="1"
+# SchlumbergerSema Cyberflex Access e-gate
+ATTRS{idVendor}=="0973", ATTRS{idProduct}=="0003", ENV{PCSCD}="1"
+
+# All done
+LABEL="pcscd_ccid_rules_end"
diff --git a/app-crypt/ccid/metadata.xml b/app-crypt/ccid/metadata.xml
new file mode 100644
index 000000000000..6a1239505f77
--- /dev/null
+++ b/app-crypt/ccid/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>crypto@gentoo.org</email>
+ <name>Crypto</name>
+ </maintainer>
+ <use>
+ <flag name="kobil-midentity">Build and install Kobil_mIDentity_switch tool</flag>
+ <flag name="twinserial">Enable twinserial reader</flag>
+ </use>
+</pkgmetadata>