summaryrefslogtreecommitdiff
path: root/app-crypt/certbot-apache
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-09 06:41:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-09 06:41:15 +0000
commitd94fef9a5708b8e64f363f4a71f0b56caef5efe4 (patch)
treeb8041134209c7d8f47560e719b584508ea78180f /app-crypt/certbot-apache
parent9991465b0b90d77b2a8a2ae833b6ecd99e6b5101 (diff)
gentoo auto-resync : 09:01:2025 - 06:41:15
Diffstat (limited to 'app-crypt/certbot-apache')
-rw-r--r--app-crypt/certbot-apache/Manifest2
-rw-r--r--app-crypt/certbot-apache/certbot-apache-3.1.0.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/app-crypt/certbot-apache/Manifest b/app-crypt/certbot-apache/Manifest
index fdd02d912a36..483520c76b8e 100644
--- a/app-crypt/certbot-apache/Manifest
+++ b/app-crypt/certbot-apache/Manifest
@@ -1,4 +1,6 @@
DIST certbot-2.10.0.gh.tar.gz 2322931 BLAKE2B cb84815ec2db2b4b365f2f2bdee1749263b540a1b67f9195280bdb122307337d294beb403bc05b236a94ed0782b0d093e2b8527a65cb69cac949fa627388e8bd SHA512 444981952140376808a9aa475a692df91e60fffc6d45902a3f809bc07311a7d6597ad56e712d3dae234450eb1c735db431182e784bc748511e68bf4f5f2d6cbd
+DIST certbot-3.1.0.gh.tar.gz 2299990 BLAKE2B 596f11d4ebb161ee6ba67f4f150a77e081399f11f4e4652923c94297661149c9cb889afc51b46b6111847820823d90edc3a7f1e14c451122f88e6e777bf48795 SHA512 efd0b0c1540a6e3b631fa80eac65c9e8b31b1e5e1242f56d3723ca7e1b1b2121dfe1bf8e122fe9a9b994460553f1fa085b11d1369b3160f5c51c939b2cccd638
EBUILD certbot-apache-2.10.0.ebuild 1059 BLAKE2B 2641256468b204ce2a9594154025201ec733d73ecd6191cfeae7143db0ff860f1a12a65cea08bd07163a3ae9ef3809582bf1646f9077d8191c4a9fa8ef0830c8 SHA512 6077a0fa14c31bdeab385fb3c81ee831576e0baabb1aa76d153e046cc1d5a6919ec64050f6eaa3297d6a2cf2307c243d4244326070af0317858e58ab92cf49d4
+EBUILD certbot-apache-3.1.0.ebuild 1061 BLAKE2B cb61fe539dabd637ef7ca2fbff92bee1a21db4af6a838f95ccae05b2fb71964c758d607130bfda566c4365f84063aad7aa6f798b36029d67d6167366eb957de5 SHA512 aa2725b05140f64c93476319261c5940f09a8582741cdb051c0cc13da2b622404c696343aa25a687211ab80819271541ebaddc0afeb7057d23409dca3b06964d
EBUILD certbot-apache-9999.ebuild 1061 BLAKE2B a2e239e321f4087db6bb21f600cff8ed20ae1add9b4e402f5ca2a1762633a7a2a2edf7e9dcec510ef21b68ed91d68064a573e8bb9c186d77a89d36ac4baa5e83 SHA512 77fdc3ea4cce89c1811f6dad1cdda02b18a6f3f394acd908ef168d958337dac200c109ddce5fbdf299afaaf6c4315c8af60242a72d6f66b1cfee994b419af6e2
MISC metadata.xml 411 BLAKE2B 5876f2ab00aae84a0649504ffa17ea14abba64e38c915adb12f8817736b83ca19b4c220d79fff23259a772a621c145b0987bbe9ac959b956113b2e1ec40f5123 SHA512 ab6822225853f8941e2bf841b945c3dc484eb9c9667f8583f52951ca87e264315a50d44985fbd9487793e8b72c9a0bd05c0a267f06bf60f64003ad94820267ba
diff --git a/app-crypt/certbot-apache/certbot-apache-3.1.0.ebuild b/app-crypt/certbot-apache/certbot-apache-3.1.0.ebuild
new file mode 100644
index 000000000000..b65adf0df968
--- /dev/null
+++ b/app-crypt/certbot-apache/certbot-apache-3.1.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+PARENT_PN="${PN%-apache}"
+PARENT_P="${PARENT_PN}-${PV}"
+
+if [[ "${PV}" == *9999 ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ EGIT_SUBMODULES=()
+ EGIT_CHECKOUT_DIR="${WORKDIR}/${PARENT_P}"
+else
+ SRC_URI="
+ https://github.com/certbot/certbot/archive/v${PV}.tar.gz
+ -> ${PARENT_P}.gh.tar.gz
+ "
+ # Only for amd64, arm64 and x86 because of dev-python/python-augeas
+ KEYWORDS="~amd64 ~arm64 ~x86"
+fi
+
+DESCRIPTION="Apache plugin for Certbot (Let’s Encrypt client)"
+HOMEPAGE="
+ https://github.com/certbot/certbot/
+ https://pypi.org/project/certbot-apache/
+ https://letsencrypt.org/
+"
+
+S="${WORKDIR}/${PARENT_P}/${PN}"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="
+ >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
+ dev-python/python-augeas[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest