summaryrefslogtreecommitdiff
path: root/app-crypt/certbot-dns-dnsimple
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-26 19:26:07 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-26 19:26:07 +0000
commitacfd7c956a7b45da7af1452ec12e0b2d5e6ac65b (patch)
tree13151a7440c2560b01e3cf5bd56ad280482b88bf /app-crypt/certbot-dns-dnsimple
parent67dbd3ba144944fbf4b466be1b5fa0569b774e6f (diff)
gentoo auto-resync : 26:02:2025 - 19:26:07
Diffstat (limited to 'app-crypt/certbot-dns-dnsimple')
-rw-r--r--app-crypt/certbot-dns-dnsimple/Manifest2
-rw-r--r--app-crypt/certbot-dns-dnsimple/certbot-dns-dnsimple-3.2.0.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/app-crypt/certbot-dns-dnsimple/Manifest b/app-crypt/certbot-dns-dnsimple/Manifest
index d4aee39c6c57..6571a3cdbf5f 100644
--- a/app-crypt/certbot-dns-dnsimple/Manifest
+++ b/app-crypt/certbot-dns-dnsimple/Manifest
@@ -1,3 +1,5 @@
DIST certbot-2.10.0.gh.tar.gz 2322931 BLAKE2B cb84815ec2db2b4b365f2f2bdee1749263b540a1b67f9195280bdb122307337d294beb403bc05b236a94ed0782b0d093e2b8527a65cb69cac949fa627388e8bd SHA512 444981952140376808a9aa475a692df91e60fffc6d45902a3f809bc07311a7d6597ad56e712d3dae234450eb1c735db431182e784bc748511e68bf4f5f2d6cbd
+DIST certbot-3.2.0.gh.tar.gz 2309823 BLAKE2B 30ff3f40dc4d7724ad7b9a5eaf48f15fa579d49902dd23d21d8b2d36a4371da05f8c9417b0b2bf49a12565ba9dec180a9d805f22e0e8d1342ae5ea64b43d5219 SHA512 8fc3753dcdc954e143da31a0308269b99abadcdefc008c54c2cabac14a3bf99e757f1007349806a7dabf4a8fe19fd3a365ddea85c1dbeb3b453ae91503ea2288
EBUILD certbot-dns-dnsimple-2.10.0.ebuild 899 BLAKE2B 7cf6e2cab506a2835651cc2072e6f9deca6173aeddcbc7a8b655f7d9b7052de25e2f36c23b1777ae2dfe5ce6643f721d09218b458b71abe97276f0cc894eb318 SHA512 710fb98ebca2be80b7a4dda4dfdf9a3cf15caf783b86ee2579e30d7be60efd8c90da2a03bc0163fd7401c54b2a1e2f1db5499014ebad5b0b8e611ccc5b4ca196
+EBUILD certbot-dns-dnsimple-3.2.0.ebuild 1222 BLAKE2B 1edcd7c917bf3069687a8f3785a4ea7148733672839f175f5f59e19b5390b199a22b3797ea96b84eacb0a59936c46d97a781fe5ad9b16433cdf22ff30ffceaf0 SHA512 e54d7be1e00d565389f0ea7b2474d4bc36f50ff97c6bdbdf21b08976c66047087e510100e0396f294cd9000e9ee1885101dd9f23c81dda38129d15c55c44dae5
MISC metadata.xml 569 BLAKE2B d554766b1b933cefdeced04082594e224d1f6bc66036cacecb649f2c21a0135ee5000a043c0587157453afb4a3f4ffd8096a89c654124d9424db4456bee8cf53 SHA512 fd01e6495d9fd1d28ce47a729bf014b953b57cd01227e682fd6f34c1e0fc15f4799d7cff98fb0e9eb3af150765b6906ec15693257a125e65187469ab451c38d3
diff --git a/app-crypt/certbot-dns-dnsimple/certbot-dns-dnsimple-3.2.0.ebuild b/app-crypt/certbot-dns-dnsimple/certbot-dns-dnsimple-3.2.0.ebuild
new file mode 100644
index 000000000000..5dc15f86d763
--- /dev/null
+++ b/app-crypt/certbot-dns-dnsimple/certbot-dns-dnsimple-3.2.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+PARENT_PN="certbot"
+PARENT_P="${PARENT_PN}-${PV}"
+
+if [[ "${PV}" == *9999 ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ EGIT_SUBMODULES=()
+ EGIT_CHECKOUT_DIR="${WORKDIR}/${PARENT_P}"
+else
+ SRC_URI="
+ https://github.com/certbot/certbot/archive/v${PV}.tar.gz
+ -> ${PARENT_P}.gh.tar.gz
+ "
+ # Only for amd64 and x86 because of dev-python/dns-lexicon
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="DNSimple Authenticator plugin for Certbot (Let’s Encrypt Client)"
+HOMEPAGE="
+ https://github.com/certbot/certbot
+ https://pypi.org/project/certbot-dns-dnsimple/
+ https://certbot-dns-dnsimple.readthedocs.io/en/stable/
+ https://letsencrypt.org/
+"
+
+S="${WORKDIR}/${PARENT_P}/${PN}"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+# See certbot/setup.py for acme >= dep
+RDEPEND="
+ >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/dns-lexicon-3.14.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest