summaryrefslogtreecommitdiff
path: root/app-crypt/certbot-dns-nsone
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-26 19:26:07 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-26 19:26:07 +0000
commitacfd7c956a7b45da7af1452ec12e0b2d5e6ac65b (patch)
tree13151a7440c2560b01e3cf5bd56ad280482b88bf /app-crypt/certbot-dns-nsone
parent67dbd3ba144944fbf4b466be1b5fa0569b774e6f (diff)
gentoo auto-resync : 26:02:2025 - 19:26:07
Diffstat (limited to 'app-crypt/certbot-dns-nsone')
-rw-r--r--app-crypt/certbot-dns-nsone/Manifest2
-rw-r--r--app-crypt/certbot-dns-nsone/certbot-dns-nsone-3.2.0.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/app-crypt/certbot-dns-nsone/Manifest b/app-crypt/certbot-dns-nsone/Manifest
index 97157e1cd11b..77574527ef13 100644
--- a/app-crypt/certbot-dns-nsone/Manifest
+++ b/app-crypt/certbot-dns-nsone/Manifest
@@ -1,3 +1,5 @@
DIST certbot-1.18.0.gh.tar.gz 1332615 BLAKE2B eb086710b943893025d6e1091470ca02de074232372f4c9fa21fa83a347fe54df988b9553c8cf6afd6e166b8c464d595171984c984008a872e16c0179bb774b2 SHA512 94b16ba0586e0f5d3036280c68f9976c25889ca48fbbe7aded41f0d9feba2300a3f0ff8fe321b39d8642bcdd874c7332cf2acb3187b5869fe415831f58a75a7b
+DIST certbot-3.2.0.gh.tar.gz 2309823 BLAKE2B 30ff3f40dc4d7724ad7b9a5eaf48f15fa579d49902dd23d21d8b2d36a4371da05f8c9417b0b2bf49a12565ba9dec180a9d805f22e0e8d1342ae5ea64b43d5219 SHA512 8fc3753dcdc954e143da31a0308269b99abadcdefc008c54c2cabac14a3bf99e757f1007349806a7dabf4a8fe19fd3a365ddea85c1dbeb3b453ae91503ea2288
EBUILD certbot-dns-nsone-1.18.0-r1.ebuild 881 BLAKE2B 618bd9da56d0c182196aa57ff92c6883ee3b09d4ae216615500d39b2c2faaf68e3af2a12261f39678fc9235154940a33f6c7ce49752efabf24c7bd6bf7e92b52 SHA512 c3b3c9b7fd5336fe7280cdee2b38613a27f8e4cc99b116f07899339acb220f56cdb2defdb923ed5e0dfc99c5233ad19daa75b68b327a3090f9e91a676051da0d
+EBUILD certbot-dns-nsone-3.2.0.ebuild 1207 BLAKE2B c04be060fc789d8064cacb26099e975cdc1cca89cb828d3d7354658954bd3bdc7ecedd3d5454cea2b58018b0d82bc41c175d982ecb03e3a8297c2381a2ac2877 SHA512 d35ff15f9f1979d24e5bab64f4018dfc2fbaf62256268d11d8120dc5db7ae078d5a9279354302208297b3ff9e897900f8ff9b1c30fd17bd5053c5e240c9c5a9e
MISC metadata.xml 407 BLAKE2B 8f65d9f92992da12fcd4fcb71f67ee91b1029af1a784bd03e2d3726a1ac9bb14f161692b2f12c9553e0fc6e45d6088e505a8d616f3c209445332a191f572e731 SHA512 b7ded216ba7f9e9babdfef03565444233d48e132807064bb9befb3a551b1344e75def76da891a5e40f102610da8ca05e6182f0501bf296c25543fae378c94ccd
diff --git a/app-crypt/certbot-dns-nsone/certbot-dns-nsone-3.2.0.ebuild b/app-crypt/certbot-dns-nsone/certbot-dns-nsone-3.2.0.ebuild
new file mode 100644
index 000000000000..aec7cd0fdb2a
--- /dev/null
+++ b/app-crypt/certbot-dns-nsone/certbot-dns-nsone-3.2.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+PARENT_PN="certbot"
+PARENT_P="${PARENT_PN}-${PV}"
+
+if [[ "${PV}" == *9999 ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ EGIT_SUBMODULES=()
+ EGIT_CHECKOUT_DIR="${WORKDIR}/${PARENT_P}"
+else
+ SRC_URI="
+ https://github.com/certbot/certbot/archive/v${PV}.tar.gz
+ -> ${PARENT_P}.gh.tar.gz
+ "
+ # Only for amd64 and x86 because of dev-python/dns-lexicon
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="NS1 DNS Authenticator plugin for Certbot (Let’s Encrypt Client)"
+HOMEPAGE="
+ https://github.com/certbot/certbot
+ https://pypi.org/project/certbot-dns-nsone/
+ https://letsencrypt.org/
+"
+
+S="${WORKDIR}/${PARENT_P}/${PN}"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+# See certbot/setup.py for acme >= dep
+RDEPEND="
+ >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]
+ >=dev-python/dns-lexicon-3.14.1[${PYTHON_USEDEP}]
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest