summaryrefslogtreecommitdiff
path: root/app-crypt/certbot-nginx
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-04 00:07:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-04 00:07:50 +0100
commitdafa6f367240d1f5329ca89fb6f78985dbdc025b (patch)
tree96ba5ff3cc1d06604d928ca1b58ed15a4f8733dc /app-crypt/certbot-nginx
parenta3bb28551df94028000fb72308a9e9baa01458b0 (diff)
gentoo auto-resync : 04:06:2024 - 00:07:50
Diffstat (limited to 'app-crypt/certbot-nginx')
-rw-r--r--app-crypt/certbot-nginx/Manifest6
-rw-r--r--app-crypt/certbot-nginx/certbot-nginx-2.10.0.ebuild3
-rw-r--r--app-crypt/certbot-nginx/certbot-nginx-2.9.0.ebuild52
-rw-r--r--app-crypt/certbot-nginx/certbot-nginx-9999.ebuild3
4 files changed, 4 insertions, 60 deletions
diff --git a/app-crypt/certbot-nginx/Manifest b/app-crypt/certbot-nginx/Manifest
index dce1bde87a1b..b9c4ba13bea1 100644
--- a/app-crypt/certbot-nginx/Manifest
+++ b/app-crypt/certbot-nginx/Manifest
@@ -1,6 +1,4 @@
DIST certbot-2.10.0.gh.tar.gz 2322931 BLAKE2B cb84815ec2db2b4b365f2f2bdee1749263b540a1b67f9195280bdb122307337d294beb403bc05b236a94ed0782b0d093e2b8527a65cb69cac949fa627388e8bd SHA512 444981952140376808a9aa475a692df91e60fffc6d45902a3f809bc07311a7d6597ad56e712d3dae234450eb1c735db431182e784bc748511e68bf4f5f2d6cbd
-DIST certbot-2.9.0.gh.tar.gz 1346993 BLAKE2B cf7fb4676dc31442abe11ef50d18073480a46f4ab19cc328da599b1372509af683b4c6010b46f31bce5703949e88b4702d404bd8582a1361caad43ec8f02cb94 SHA512 27c15ce8e4450f432fbc271cd847d27c7f1bce552cc6e5f2a91f1fbfc09ebe331b54bab17639b86c19605de059767015665c26e872c3b0699edb1c85392a0546
-EBUILD certbot-nginx-2.10.0.ebuild 1182 BLAKE2B 8e766ea39bf754c50af02139fc8be1c429e0618f09f904e824158459510bfddb4e00d9861b7612e23136ed74d6d2b1194017c87125607644efd372dcc0fbd573 SHA512 245cd6126b4844e89aa7b1e710cfc0b7e788200c94e21dc4b375a9be05493bcb12e0ac7cd4aacd01d7891bb7f1038711956e09dd3d0fce8f84656f945be3134b
-EBUILD certbot-nginx-2.9.0.ebuild 1182 BLAKE2B 40bc47f9e03d808a7c168b151851e42f472d726df042e1e7c36983ccbacda8ec7d26736713fdbf8f5fa728ecb9206195c74483441e830e72b66f2389010ade09 SHA512 d124f5d851c4b57d143e20f13d360407489d4eaaaeebf9b77023350f6a207d5ff255c5ffe42e1873a73c4504ce999f34ecdd30c342e22934c8d9da48961bcbf0
-EBUILD certbot-nginx-9999.ebuild 1186 BLAKE2B 11b7c97d3301352c06fe49a26e285c126f48629fc6f5637b9c68f7ae2891d5b7ed7c27fdb13e92f7f49f938f1d124e8d3081dc1e744bd9ce17ac21f75767f2ac SHA512 5106bc389de129fa30e3c677436a0c2daafed31f04c3e1ce4c6c6b43e1c2b243c133f89db82182c36a26c792f8a50597dfa308fdc9bfd7af4e73c1c30d938dd2
+EBUILD certbot-nginx-2.10.0.ebuild 1181 BLAKE2B 51a16d81e44535bffda13ef01946bfeed350bc14cee45add0a81c199f78c58e4c53dc18c9dc897caa03b8862fbcde2fdb33866bed4a61b1c9ed4e2f26da8531f SHA512 e4d049958a31d7fd00ab726395087b3418dc196e1292f29f5a99140d981889a989725bb23d436f65ee9f468251d01ad9f63633acec5f1bfb4c405cf901fc48ed
+EBUILD certbot-nginx-9999.ebuild 1185 BLAKE2B e6e9e5af8cbed1873b6429cf15974d2d91ae7f836814815e79a23e40d67c81679d9532331b7b67cd76117a80f094c0d392579080548e814db450add5a2b724d8 SHA512 f8ed3a116230a1f1f56002fe9db704928fcccd2b410543e646a0bed7b8c56ce1a1c3a47bf126b8292bbd2325d4369084b3397660fa625197082dfe30d0f2f7ac
MISC metadata.xml 335 BLAKE2B 048854ec6bc919f9bf9b0bc74e7c291841cbfea0e571f43437937c5dd78cc65f9df53463adcf313441e01323491709b462bd9bc364876eb1508a83b3426b6b78 SHA512 25ac45574a568e362c419dfbeade4a977afa2885e7b32fb4c3d4c765450b09aa98cf419df1a39ab194518ad6f2b582e162d4dd4eec14f278635d63bf66352523
diff --git a/app-crypt/certbot-nginx/certbot-nginx-2.10.0.ebuild b/app-crypt/certbot-nginx/certbot-nginx-2.10.0.ebuild
index c7c737694976..87265cf83dd8 100644
--- a/app-crypt/certbot-nginx/certbot-nginx-2.10.0.ebuild
+++ b/app-crypt/certbot-nginx/certbot-nginx-2.10.0.ebuild
@@ -31,11 +31,10 @@ HOMEPAGE="
https://letsencrypt.org/
"
+S="${WORKDIR}/${PARENT_P}/${PN}"
LICENSE="Apache-2.0"
SLOT="0"
-S="${WORKDIR}/${PARENT_P}/${PN}"
-
BDEPEND="
test? ( dev-python/pytest[${PYTHON_USEDEP}] )
"
diff --git a/app-crypt/certbot-nginx/certbot-nginx-2.9.0.ebuild b/app-crypt/certbot-nginx/certbot-nginx-2.9.0.ebuild
deleted file mode 100644
index bba940ea8e40..000000000000
--- a/app-crypt/certbot-nginx/certbot-nginx-2.9.0.ebuild
+++ /dev/null
@@ -1,52 +0,0 @@
-# Copyright 1999-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-DISTUTILS_USE_PEP517=setuptools
-
-inherit distutils-r1
-
-PARENT_PN="${PN%-nginx}"
-PARENT_P="${PARENT_PN}-${PV}"
-
-if [[ "${PV}" == *9999 ]]; then
- inherit git-r3
-
- EGIT_REPO_URI="https://github.com/certbot/certbot.git"
- EGIT_SUBMODULES=()
- EGIT_CHECKOUT_DIR="${WORKDIR}/${PARENT_P}"
-else
- SRC_URI="
- https://github.com/certbot/certbot/archive/v${PV}.tar.gz
- -> ${PARENT_P}.gh.tar.gz
- "
- KEYWORDS="amd64 arm arm64 ~ppc64 ~riscv x86"
-fi
-
-DESCRIPTION="Nginx plugin for Certbot (Let’s Encrypt client)"
-HOMEPAGE="
- https://github.com/certbot/certbot
- https://letsencrypt.org/
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-
-S="${WORKDIR}/${PARENT_P}/${PN}"
-
-BDEPEND="
- test? ( dev-python/pytest[${PYTHON_USEDEP}] )
-"
-
-# The requirement is really 17.5.0 but easier to require latest stable >= 23.1.1
-# to avoid broken 23.1.0.
-RDEPEND="
- >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
- >=app-crypt/certbot-${PV}[${PYTHON_USEDEP}]
- >=dev-python/pyopenssl-23.1.1[${PYTHON_USEDEP}]
- >=dev-python/pyparsing-2.2.1[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
diff --git a/app-crypt/certbot-nginx/certbot-nginx-9999.ebuild b/app-crypt/certbot-nginx/certbot-nginx-9999.ebuild
index db555ce797a5..a8a7e0f2fb38 100644
--- a/app-crypt/certbot-nginx/certbot-nginx-9999.ebuild
+++ b/app-crypt/certbot-nginx/certbot-nginx-9999.ebuild
@@ -31,11 +31,10 @@ HOMEPAGE="
https://letsencrypt.org/
"
+S="${WORKDIR}/${PARENT_P}/${PN}"
LICENSE="Apache-2.0"
SLOT="0"
-S="${WORKDIR}/${PARENT_P}/${PN}"
-
BDEPEND="
test? ( dev-python/pytest[${PYTHON_USEDEP}] )
"