summaryrefslogtreecommitdiff
path: root/app-crypt/certbot/certbot-2.11.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-03-12 01:49:51 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-03-12 01:49:51 +0000
commitef0fedb39c21a343a3f316726f272bad9005b22c (patch)
tree0d64e58453e117f61a9e1641532926278f51b72e /app-crypt/certbot/certbot-2.11.1.ebuild
parentcf7807d7aea23a99a144afceaba961cfed652b5f (diff)
gentoo auto-resync : 12:03:2025 - 01:49:51HEADmaster
Diffstat (limited to 'app-crypt/certbot/certbot-2.11.1.ebuild')
-rw-r--r--app-crypt/certbot/certbot-2.11.1.ebuild66
1 files changed, 66 insertions, 0 deletions
diff --git a/app-crypt/certbot/certbot-2.11.1.ebuild b/app-crypt/certbot/certbot-2.11.1.ebuild
new file mode 100644
index 000000000000..7409e1be4746
--- /dev/null
+++ b/app-crypt/certbot/certbot-2.11.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+if [[ "${PV}" == *9999 ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ EGIT_SUBMODULES=()
+ EGIT_CHECKOUT_DIR="${WORKDIR}/${P}"
+else
+ SRC_URI="
+ https://github.com/certbot/certbot/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="amd64 arm arm64 ~ppc64 ~riscv x86"
+fi
+
+DESCRIPTION="Let’s Encrypt client to automate deployment of X.509 certificates"
+HOMEPAGE="
+ https://github.com/certbot/certbot
+ https://pypi.org/project/certbot/
+ https://letsencrypt.org/
+"
+
+S="${WORKDIR}/${P}/${PN}"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+IUSE="selinux"
+
+BDEPEND="
+ test? (
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ )
+"
+
+# See certbot/setup.py for acme >= dep
+RDEPEND="
+ >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/configargparse-1.5.3[${PYTHON_USEDEP}]
+ >=dev-python/configobj-5.0.6[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-3.2.1[${PYTHON_USEDEP}]
+ >=dev-python/distro-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/josepy-1.13.0[${PYTHON_USEDEP}]
+ <dev-python/josepy-2[${PYTHON_USEDEP}]
+ >=dev-python/parsedatetime-2.4[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2019.3[${PYTHON_USEDEP}]
+ selinux? ( sec-policy/selinux-certbot )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}