summaryrefslogtreecommitdiff
path: root/app-crypt/certbot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-26 19:26:07 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-26 19:26:07 +0000
commitacfd7c956a7b45da7af1452ec12e0b2d5e6ac65b (patch)
tree13151a7440c2560b01e3cf5bd56ad280482b88bf /app-crypt/certbot
parent67dbd3ba144944fbf4b466be1b5fa0569b774e6f (diff)
gentoo auto-resync : 26:02:2025 - 19:26:07
Diffstat (limited to 'app-crypt/certbot')
-rw-r--r--app-crypt/certbot/Manifest1
-rw-r--r--app-crypt/certbot/certbot-3.2.0.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/app-crypt/certbot/Manifest b/app-crypt/certbot/Manifest
index 8c87d04a2ceb..ad8adbaf24df 100644
--- a/app-crypt/certbot/Manifest
+++ b/app-crypt/certbot/Manifest
@@ -9,5 +9,6 @@ EBUILD certbot-2.11.0.ebuild 1528 BLAKE2B 34449bcf95187bed02f610a3ab4b5252e241b4
EBUILD certbot-3.0.1.ebuild 1572 BLAKE2B 0200fb1f4425354e788fce567e63a4e302afa1409c73085491c3f32e7bce0d9830521e2907ad7c03f29f8e9ce10931a53bb11d385a643ee21417194c5767d453 SHA512 dd4680db1d2157a551d76639a4586b4ff6e9d68677e969009f78697a1b50a5e9799765102602a8075b3da41f93980060756c22f13a03f7152d92072eb4287e66
EBUILD certbot-3.1.0.ebuild 1572 BLAKE2B 92f7bef4a2b4eaa3251d20fd44b33544687acd4cdc7aa2dc7d7bfea69a30163c13c19b2b4e0b78c9fc3c977054e35937d4bba387aa4bc3dce76ca573539e150e SHA512 f43cf0ceb6fb9644aa963b2e74f22cb5104ffcd5564b3d860ab449463a62f934aa34497119916825d6bf1eb701916caa48bb62b701344d167619ca778ee46c3a
EBUILD certbot-3.2.0-r100.ebuild 6569 BLAKE2B c1bee15c1b8b04ec82ef46701aed25eac0820528c12ad2cc7e4e69fb535de22bd8a35feebaead266a56966f7bab77bd61b2c6bf8a5edadb6ae117e8ea43de6ca SHA512 3f77673f981f585a260a9d40ccf75f09072cd35f9a86e9047729a3274e70f400f001a13a1856f23ef7b302b3a1e8cbded498f42cfc566110e86a2cde4532e8e4
+EBUILD certbot-3.2.0.ebuild 1572 BLAKE2B f70a02b18dfe12e3768ee98be8392c6d9d753dcb5a69f37aa488634748c7bf685abb6a5ffcbb8330f5b82808d6b9fcf7146c129c3b637134418710d9f65b9fac SHA512 4f0815c0a793bce1d2870480069dd67bcee5795638bb5b5cbf61334a019ea0cb31135df4f57c2488e67d23d928190f1f2d7d9ea6a54e59a8ec975eb46161b372
EBUILD certbot-9999.ebuild 1572 BLAKE2B 0200fb1f4425354e788fce567e63a4e302afa1409c73085491c3f32e7bce0d9830521e2907ad7c03f29f8e9ce10931a53bb11d385a643ee21417194c5767d453 SHA512 dd4680db1d2157a551d76639a4586b4ff6e9d68677e969009f78697a1b50a5e9799765102602a8075b3da41f93980060756c22f13a03f7152d92072eb4287e66
MISC metadata.xml 1684 BLAKE2B 10bc000ed0b87bd03b7e58882c36e7100654a71a9d0e0ebaf29018524af20ab5fdbeb1ce950ab16a5fa33f99ccc3936c5070cc200e92700ecf21a74a44233fdd SHA512 db04143763a2a42fb026bbc51eae9128e30214873b134ccb4d4ad8fcbe7e1c7284b7928fcec2b6c6ea58dd49acc5cf33312c4fe0af3f001f69fc441032972369
diff --git a/app-crypt/certbot/certbot-3.2.0.ebuild b/app-crypt/certbot/certbot-3.2.0.ebuild
new file mode 100644
index 000000000000..55f7d401c841
--- /dev/null
+++ b/app-crypt/certbot/certbot-3.2.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+if [[ "${PV}" == *9999 ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ EGIT_SUBMODULES=()
+ EGIT_CHECKOUT_DIR="${WORKDIR}/${P}"
+else
+ SRC_URI="
+ https://github.com/certbot/certbot/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="Let’s Encrypt client to automate deployment of X.509 certificates"
+HOMEPAGE="
+ https://github.com/certbot/certbot
+ https://pypi.org/project/certbot/
+ https://letsencrypt.org/
+"
+
+S="${WORKDIR}/${P}/${PN}"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+IUSE="selinux"
+
+BDEPEND="
+ test? (
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ )
+"
+
+# See certbot/setup.py for acme >= dep
+RDEPEND="
+ >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/configargparse-1.5.3[${PYTHON_USEDEP}]
+ >=dev-python/configobj-5.0.6[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-43.0.0[${PYTHON_USEDEP}]
+ >=dev-python/distro-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/josepy-1.13.0[${PYTHON_USEDEP}]
+ <dev-python/josepy-2[${PYTHON_USEDEP}]
+ >=dev-python/parsedatetime-2.4[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2019.3[${PYTHON_USEDEP}]
+ selinux? ( sec-policy/selinux-certbot )
+"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}