summaryrefslogtreecommitdiff
path: root/app-crypt/certbot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-10 11:34:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-10 11:34:01 +0000
commitcc901a8ce7c6bfe97e3b4f048619693d360ae348 (patch)
treec250ff07a4d508fa08b487b616e0ae8aff2f0d8e /app-crypt/certbot
parentc9badf79e4669147edb94182af5776072f2ffaea (diff)
gentoo auto-resync : 10:02:2024 - 11:34:00
Diffstat (limited to 'app-crypt/certbot')
-rw-r--r--app-crypt/certbot/Manifest2
-rw-r--r--app-crypt/certbot/certbot-2.9.0.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/app-crypt/certbot/Manifest b/app-crypt/certbot/Manifest
index 12c25b5cdb66..f39c7c70ed85 100644
--- a/app-crypt/certbot/Manifest
+++ b/app-crypt/certbot/Manifest
@@ -1,4 +1,6 @@
DIST certbot-2.8.0.gh.tar.gz 1344483 BLAKE2B f9957367ae65f69ab43a83993b29da4d28c0d01bd7a89ebefcbfb82915c26167b7443d08f6ee4d28e029f5a58736dee01700a30261aaa1dc0290273868da08e9 SHA512 2fbaf5349e7ef0dcb054c3b22d63007c588cbdc0d23d484a56e62ad38d21c91b838887e6e94cf9c0045a4382567c342288a796c81307deba84a246f5cc3bc5d6
+DIST certbot-2.9.0.gh.tar.gz 1346993 BLAKE2B cf7fb4676dc31442abe11ef50d18073480a46f4ab19cc328da599b1372509af683b4c6010b46f31bce5703949e88b4702d404bd8582a1361caad43ec8f02cb94 SHA512 27c15ce8e4450f432fbc271cd847d27c7f1bce552cc6e5f2a91f1fbfc09ebe331b54bab17639b86c19605de059767015665c26e872c3b0699edb1c85392a0546
EBUILD certbot-2.8.0.ebuild 1542 BLAKE2B ae50a268d1cf78da60ec04063d8c6df338e96cae6c0fb457401d69e3f63c9f4640d12bb9f5d157cd50e1a098a0d998d4f788399348daa21a8a9cde8bc270a39c SHA512 63f065d7ce851f5774d64946708fee5234adc6e3f97995b7381f7d6d3ed917611b69223b30ec8d061a91fd4ece70ecc42544f50de08c6779219564eb5c12e487
+EBUILD certbot-2.9.0.ebuild 1546 BLAKE2B 88743f6d0f350b5f9d2811c443d9c7ea00c3970c18a682de0993d7e3a239578c10d8638df987a1707bdea693de4959aa4784dacccf73dac618275f5622af6167 SHA512 9f248366bfa8f4a54b19c2c2819b1887efed72d484a2af03eb590c810244827e697c973f9a8d402bd6df71ba6b293e5f323700fcd30982af9af725b63cd75f2b
EBUILD certbot-9999.ebuild 1546 BLAKE2B babd7b37f08f1bec100a6c677e7c2b91c8f93b8c60407991fb2bc582ce98079168412dc64ae137d0298b61ad360d4aef9b6720ec1ff120bf2c6f08f17138a6d3 SHA512 20d19fb38e4feb7999bf5d393b89596e8654d728f0027328ad6382e1bf12275034fc6cacca0732468ddba6dcec2d40a335d253b05f8302e438dd4c3c5638aca7
MISC metadata.xml 359 BLAKE2B 7f8ac46ecea304579baca80978cc35905720d1950caa183b5b5b297afab8bf6ea328324bacc438e9ecd91176230e42e55deda1c15e1ba73c63b2021ac2842c0f SHA512 a50b1db5a30eac290ac6645fcb30b0d5c4d8e51d83cff284e76358ee4fe7cef9366e40b06f532ba64a2131672972ea10b73541a9bd42cc323c17f6d26f6b0197
diff --git a/app-crypt/certbot/certbot-2.9.0.ebuild b/app-crypt/certbot/certbot-2.9.0.ebuild
new file mode 100644
index 000000000000..0f29c796b738
--- /dev/null
+++ b/app-crypt/certbot/certbot-2.9.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+if [[ "${PV}" == *9999 ]]; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ EGIT_SUBMODULES=()
+ EGIT_CHECKOUT_DIR="${WORKDIR}/${P}"
+else
+ SRC_URI="
+ https://github.com/certbot/certbot/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+DESCRIPTION="Let’s Encrypt client to automate deployment of X.509 certificates"
+HOMEPAGE="
+ https://github.com/certbot/certbot
+ https://letsencrypt.org/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+IUSE="selinux"
+
+S="${WORKDIR}/${P}/${PN}"
+
+BDEPEND="
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ )
+"
+
+# See certbot/setup.py for acme >= dep
+RDEPEND="
+ >=app-crypt/acme-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/ConfigArgParse-1.5.3[${PYTHON_USEDEP}]
+ >=dev-python/configobj-5.0.6[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-3.2.1[${PYTHON_USEDEP}]
+ >=dev-python/distro-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/josepy-1.13.0[${PYTHON_USEDEP}]
+ >=dev-python/parsedatetime-2.4[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2019.3[${PYTHON_USEDEP}]
+ selinux? ( sec-policy/selinux-certbot )
+"
+
+distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest