summaryrefslogtreecommitdiff
path: root/app-crypt/certbot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /app-crypt/certbot
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'app-crypt/certbot')
-rw-r--r--app-crypt/certbot/Manifest4
-rw-r--r--app-crypt/certbot/certbot-1.4.0.ebuild48
-rw-r--r--app-crypt/certbot/certbot-9999.ebuild1
3 files changed, 51 insertions, 2 deletions
diff --git a/app-crypt/certbot/Manifest b/app-crypt/certbot/Manifest
index 2fcde050d00a..cd426cefd3d9 100644
--- a/app-crypt/certbot/Manifest
+++ b/app-crypt/certbot/Manifest
@@ -1,4 +1,6 @@
DIST certbot-1.3.0.tar.gz 1362945 BLAKE2B bb36a7737275332f018d7f2283286e07e041892cc366f79e68df9eee7e57ca2186d36895d1923b032068a365878d09e49e17c1399a7418dbd8607c9a7efc1c26 SHA512 4205cdd1f3ddf500b9b952744db234636c086a856df80acd2d776305f4501eed07995e453e5c9b2c711fb0d1f1987d2bb8baaa13fccce8e000a38f486cfdc5d3
+DIST certbot-1.4.0.tar.gz 1381435 BLAKE2B 57d70a12ee38e1ba96f4c8c594c1940403e33d4cdf5111472a9c0c7d41061b2201792c38d9bb4ec516358f5592d2f689eeab31e1e686a534418b20eba2df4b4b SHA512 8926f724c47c0249e2e420cd8944f0b106682efaa2d9b211491ea4524fe4e64bb3ff4f21fd756996049d781a68294ab8307bd077b6d96fa00e09cbbdf4e59261
EBUILD certbot-1.3.0.ebuild 1482 BLAKE2B c937a391b768757ed01f31fa96596da3cad08ea7394af1b5f5a9a828ef97a4a948b9315a3fc499742eb95dd3370f2d303b52886dcc6df75d2d502801a18aa62d SHA512 e7081e69f95c7d2aec45938ca6cc7e3da6dc00d038cb3d9167e1e33102b84d06e6a7a3ff13c5734c933c0b062d1e07203d6002a3a3f1609c14874679d2b3d077
-EBUILD certbot-9999.ebuild 1484 BLAKE2B ec9e79981e59a16061161afacfbb68e889bbcc2f39874914af18f9442c762fa617c05132779b84ae8df5fc96680a3b96b7773cf7e82e6ced118d5a21c7c6eba6 SHA512 df7ebbc90d3f07e67507936ceff7f346dba3a8f91f6fa7a94bcf69fbff2c817f85df0da336c5bacc97643b32cdbde781fa0e66ac29df8ca14c4cf71856c23f24
+EBUILD certbot-1.4.0.ebuild 1449 BLAKE2B 33697537a8dfe539c1aee02b90745fd8da1150c94c9d842f17e3703c79f24fb5ba8b54a95a3f450d340abdc0240663e0b338c86a5a0b4e1506a591bc2a5e5a99 SHA512 a725b74a30ba0b7afd8ec12a02cdbbbb2f69054f588fc8f6da3ba47fdba481ba5b39b70f5609e1e874397d5e53319deb2a5589a2044079d009034fbdec0c3fe7
+EBUILD certbot-9999.ebuild 1449 BLAKE2B 33697537a8dfe539c1aee02b90745fd8da1150c94c9d842f17e3703c79f24fb5ba8b54a95a3f450d340abdc0240663e0b338c86a5a0b4e1506a591bc2a5e5a99 SHA512 a725b74a30ba0b7afd8ec12a02cdbbbb2f69054f588fc8f6da3ba47fdba481ba5b39b70f5609e1e874397d5e53319deb2a5589a2044079d009034fbdec0c3fe7
MISC metadata.xml 334 BLAKE2B e7b28e7d3e7c6fdce0c5120b29fbf5aa607408e2add6c0ad42e921fb1add9def38c6cb191129a5a6e1f0e3ea119caa6cdc74955b572e5d2c6f854d0b7c7c521a SHA512 a24ccf633fc9c2670dcd35801d95bd8ca0f4ea4d3d53b6651f2e8e3e280b95ec8a464d99f5423942c14b0777ae4551f46c1ff285caea460bc91cbc417a7a5b70
diff --git a/app-crypt/certbot/certbot-1.4.0.ebuild b/app-crypt/certbot/certbot-1.4.0.ebuild
new file mode 100644
index 000000000000..182f2b91d51b
--- /dev/null
+++ b/app-crypt/certbot/certbot-1.4.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=(python{3_6,3_7,3_8})
+
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="https://github.com/certbot/certbot.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+S=${WORKDIR}/${P}/${PN}
+
+inherit distutils-r1
+
+DESCRIPTION="Let's encrypt client to automate deployment of X.509 certificates"
+HOMEPAGE="https://github.com/certbot/certbot https://letsencrypt.org/"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+CDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ ${CDEPEND}
+ >=app-crypt/acme-0.40.0[${PYTHON_USEDEP}]
+ >=dev-python/configargparse-0.9.3[${PYTHON_USEDEP}]
+ dev-python/configobj[${PYTHON_USEDEP}]
+ >=dev-python/cryptography-2.8[${PYTHON_USEDEP}]
+ >=dev-python/distro-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/josepy-1.1.0[${PYTHON_USEDEP}]
+ >=dev-python/parsedatetime-1.3[${PYTHON_USEDEP}]
+ dev-python/pyrfc3339[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/zope-component[${PYTHON_USEDEP}]
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # required as deps of deps can trigger this too...
+ echo ' ignore:.*collections\.abc:DeprecationWarning' >> ../pytest.ini
+ distutils-r1_python_prepare_all
+}
diff --git a/app-crypt/certbot/certbot-9999.ebuild b/app-crypt/certbot/certbot-9999.ebuild
index 5bbead32041e..182f2b91d51b 100644
--- a/app-crypt/certbot/certbot-9999.ebuild
+++ b/app-crypt/certbot/certbot-9999.ebuild
@@ -32,7 +32,6 @@ RDEPEND="
>=dev-python/cryptography-2.8[${PYTHON_USEDEP}]
>=dev-python/distro-1.0.1[${PYTHON_USEDEP}]
>=dev-python/josepy-1.1.0[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
>=dev-python/parsedatetime-1.3[${PYTHON_USEDEP}]
dev-python/pyrfc3339[${PYTHON_USEDEP}]
dev-python/pytz[${PYTHON_USEDEP}]