summaryrefslogtreecommitdiff
path: root/app-crypt/easy-rsa/easy-rsa-3.0.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-10-07 11:03:14 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-10-07 11:03:14 +0100
commit957235cf19a691360c720f7913672adda4258ed0 (patch)
tree812bba7928f4293ead05a7ee9c1ac39c5ef9f12e /app-crypt/easy-rsa/easy-rsa-3.0.5.ebuild
parent62f67115b5c46134c34f88f4b1cbdacc19384c0a (diff)
gentoo resync : 07.10.2018
Diffstat (limited to 'app-crypt/easy-rsa/easy-rsa-3.0.5.ebuild')
-rw-r--r--app-crypt/easy-rsa/easy-rsa-3.0.5.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-crypt/easy-rsa/easy-rsa-3.0.5.ebuild b/app-crypt/easy-rsa/easy-rsa-3.0.5.ebuild
new file mode 100644
index 000000000000..ff99431b6daa
--- /dev/null
+++ b/app-crypt/easy-rsa/easy-rsa-3.0.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Small RSA key management package, based on OpenSSL"
+HOMEPAGE="https://openvpn.net/"
+SRC_URI="https://github.com/OpenVPN/easy-rsa/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="libressl"
+
+DEPEND="!libressl? ( >=dev-libs/openssl-0.9.6:0 )
+ libressl? ( dev-libs/libressl )"
+RDEPEND="${DEPEND}
+ !<net-vpn/openvpn-2.3"
+
+src_install() {
+ exeinto /usr/share/easy-rsa
+ doexe easyrsa3/easyrsa
+ insinto /usr/share/easy-rsa
+ doins -r easyrsa3/{vars.example,openssl-easyrsa.cnf,x509-types}
+ dodoc README.quickstart.md ChangeLog
+ dodoc -r doc
+ doenvd "${FILESDIR}/65easy-rsa" # config-protect easy-rsa
+}