summaryrefslogtreecommitdiff
path: root/app-crypt/elettra/elettra-1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-crypt/elettra/elettra-1.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-crypt/elettra/elettra-1.0.ebuild')
-rw-r--r--app-crypt/elettra/elettra-1.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-crypt/elettra/elettra-1.0.ebuild b/app-crypt/elettra/elettra-1.0.ebuild
new file mode 100644
index 000000000000..e2c94db63b25
--- /dev/null
+++ b/app-crypt/elettra/elettra-1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+inherit toolchain-funcs
+
+MY_P="${PN}-src-${PV}"
+
+DESCRIPTION="Plausible deniable file cryptography"
+HOMEPAGE="http://www.winstonsmith.info/julia/elettra/"
+SRC_URI="http://www.winstonsmith.info/julia/elettra/${MY_P}.tar.gz"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/zlib
+ app-crypt/mhash
+ dev-libs/libmcrypt"
+
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ $(tc-getCC) ${CFLAGS} ${LDFLAGS} -I. src/*.c \
+ -lz `libmcrypt-config --cflags --libs` -lmhash \
+ -o elettra || die "compilation failed"
+}
+
+src_install() {
+ dobin elettra || die "dobin failed"
+ dodoc README || die "dodoc failed"
+}