summaryrefslogtreecommitdiff
path: root/app-crypt/gkeys
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-crypt/gkeys
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-crypt/gkeys')
-rw-r--r--app-crypt/gkeys/Manifest4
-rw-r--r--app-crypt/gkeys/gkeys-0.2.ebuild57
-rw-r--r--app-crypt/gkeys/gkeys-9999.ebuild66
-rw-r--r--app-crypt/gkeys/metadata.xml8
4 files changed, 135 insertions, 0 deletions
diff --git a/app-crypt/gkeys/Manifest b/app-crypt/gkeys/Manifest
new file mode 100644
index 000000000000..e6c4e2442a7f
--- /dev/null
+++ b/app-crypt/gkeys/Manifest
@@ -0,0 +1,4 @@
+DIST gkeys-0.2.tar.bz2 47726 BLAKE2B f85fcad78251ce8e4b49d452332af869140611161256663310c3a050f7a3c5313f6e37836d90c5a40b1abb043ff7412cea3b5decd3f1c6db24ff5811dd1b9709 SHA512 0c594b5f451329e5e85998bb96243812e0c6e7ef7fa4db0f276a870148adffcf41acc31631fb28c44c473690f154e130ddcb10b986d4546ca19e2cc8cda95036
+EBUILD gkeys-0.2.ebuild 1695 BLAKE2B bc828662f5fe44bc4be7023400046a46795136f3f2887aeea46c3119aa81ac5c6db69788d852b425162cb578955c28db1b69c37dce7c1729b39715e2b81e4963 SHA512 5d5f50b3b660fa70a73df0c31c290280d7995bc6474a0cfaa48fba0778e4f5b00a29bcae8af3a267e04b08e0e93cf500e940a6ad3b64179a3f4415fe392f6496
+EBUILD gkeys-9999.ebuild 1616 BLAKE2B 2cc22c233eea764f86fccea3ded59745a50010ddf22fd1210f0ea8bf0b30b43f1ceb2b3b2b16ed5db890f35fffa8acd97fb5ee06177c11fbb77cdae9502e255d SHA512 b564c3d2806de902f6e4b5308dc9b45d05c1718cb9db7bf3e344bbef5ed5300cbedb342f5b064e58db1c835ce832cfee86d58754a2c900c616958e3d9bfa792a
+MISC metadata.xml 257 BLAKE2B cf62bcaddae6a9a234fa866aa93f3f8435bc640ded3947993321f8a85e622a2cc0d3df0290bec76b227a4286544314e6a31dc37026482541b4922d6dc11d174a SHA512 62e56bca988936416042bb794e7c8dad9930a46c1f81f51c60a22f3f43e2d0babaacdbef430a6f8ecc8ea7d949effa6136b6d066dabb0a80fde55c36ea3c080c
diff --git a/app-crypt/gkeys/gkeys-0.2.ebuild b/app-crypt/gkeys/gkeys-0.2.ebuild
new file mode 100644
index 000000000000..82fd2a17cd93
--- /dev/null
+++ b/app-crypt/gkeys/gkeys-0.2.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+
+inherit distutils-r1
+
+DESCRIPTION="An OpenPGP/GPG key management tool for seed files and keyrings"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Gentoo-keys"
+SRC_URI="https://dev.gentoo.org/~dolsen/releases/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ app-crypt/gnupg
+ >=dev-python/pyGPG-0.2[${PYTHON_USEDEP}]
+ >=dev-python/ssl-fetch-0.4[${PYTHON_USEDEP}]
+ dev-python/snakeoil[${PYTHON_USEDEP}]
+ >=app-crypt/gentoo-keys-201501052117
+ "
+
+python_install_all() {
+ distutils-r1_python_install_all
+ keepdir /var/log/gkeys
+ fperms g+w /var/log/gkeys
+}
+
+pkg_preinst() {
+ chgrp users "${D}"/var/log/gkeys
+}
+
+pkg_postinst() {
+ einfo "This is experimental software."
+ einfo "The API's it installs should be considered unstable"
+ einfo "and are subject to change."
+ einfo
+ einfo "This version includes a new gkeys-gpg command"
+ einfo "It can be used as an alternate gpg command for git"
+ einfo "It will set the correct keyring to verify signed commits"
+ einfo "provided the key it needs to verify against is part of the gkeys"
+ einfo "keyring system. It only works for verification, any other call "
+ einfo "to it will re-direct directly to the normal gpg command."
+ einfo
+ einfo "Please file any enhancement requests, or bugs"
+ einfo "at https://bugs.gentoo.org"
+ einfo "We are also on IRC @ #gentoo-keys of the Freenode network"
+ einfo
+ ewarn "There may be some Python 3 compatibility issues still."
+ ewarn "Please help us debug, fix and report them in Bugzilla."
+}
diff --git a/app-crypt/gkeys/gkeys-9999.ebuild b/app-crypt/gkeys/gkeys-9999.ebuild
new file mode 100644
index 000000000000..7ab5b3f58306
--- /dev/null
+++ b/app-crypt/gkeys/gkeys-9999.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+PYTHON_COMPAT=(python{2_7,3_4,3_5,3_6})
+
+#EGIT_PROJECT="gentoo-keys.git"
+EGIT_BRANCH="master"
+
+inherit distutils-r1 git-r3
+
+EGIT_REPO_URI="https://anongit.gentoo.org/git/proj/gentoo-keys.git"
+
+DESCRIPTION="An OpenPGP/GPG key management tool and python libs"
+HOMEPAGE="https://wiki.gentoo.org/wiki/Project:Gentoo-keys"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+KEYWORDS=""
+
+DEPEND=""
+RDEPEND="${DEPEND}
+ app-crypt/gnupg
+ =dev-python/pyGPG-9999[${PYTHON_USEDEP}]
+ =dev-python/ssl-fetch-9999[${PYTHON_USEDEP}]
+ >=dev-python/snakeoil-0.6.5[${PYTHON_USEDEP}]
+ >=app-crypt/gentoo-keys-201501052117
+ "
+
+S="${WORKDIR}/$P/gkeys"
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+ # copy these 2 into our subdir from the master level
+ cp ../LICENSE ./ || die "cp LICENSE failed"
+ cp ../README.md ./ || die "cp README.me failed"
+ cp -R ../py2man ./ || die "cp-R py2man failed"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ keepdir /var/log/gkeys
+ fperms g+w /var/log/gkeys
+}
+
+pkg_preinst() {
+ chgrp users "${D}"/var/log/gkeys
+}
+
+pkg_postinst() {
+ einfo
+ einfo "This is experimental software."
+ einfo "The API's it installs should be considered unstable"
+ einfo "and are subject to change."
+ einfo
+ einfo "Please file any enhancement requests, or bugs"
+ einfo "at https://bugs.gentoo.org"
+ einfo "We are also on IRC @ #gentoo-keys of the freenode network"
+ einfo
+ ewarn "There may be some python 3 compatibility issues still."
+ ewarn "Please help debug/fix/report them in bugzilla."
+}
diff --git a/app-crypt/gkeys/metadata.xml b/app-crypt/gkeys/metadata.xml
new file mode 100644
index 000000000000..1937e8c82b4b
--- /dev/null
+++ b/app-crypt/gkeys/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gkeys@gentoo.org</email>
+ <name>Gentoo-keys Project Team</name>
+ </maintainer>
+</pkgmetadata>