summaryrefslogtreecommitdiff
path: root/app-crypt/gorilla/gorilla-1.4-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /app-crypt/gorilla/gorilla-1.4-r2.ebuild
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'app-crypt/gorilla/gorilla-1.4-r2.ebuild')
-rw-r--r--app-crypt/gorilla/gorilla-1.4-r2.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/app-crypt/gorilla/gorilla-1.4-r2.ebuild b/app-crypt/gorilla/gorilla-1.4-r2.ebuild
new file mode 100644
index 000000000000..860983172a00
--- /dev/null
+++ b/app-crypt/gorilla/gorilla-1.4-r2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Password Safe in secure way with GUI interface"
+HOMEPAGE="https://github.com/zdia/gorilla/wiki"
+SRC_URI="https://github.com/zdia/gorilla/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+DEPEND="
+ >=dev-lang/tcl-8.4.19:=
+ >=dev-lang/tk-8.4.19:=
+ dev-tcltk/iwidgets
+ dev-tcltk/bwidget
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-script-destdir.patch
+)
+
+src_configure() {
+ ./configure || die "econf failed"
+}
+
+src_compile() { :; }
+
+src_install() {
+ PREFIX="/opt/${P}"
+
+ insinto ${PREFIX}
+ doins -r gorilla.tcl isaac.tcl twofish sha1 blowfish pwsafe pics
+
+ dobin gorilla
+}