summaryrefslogtreecommitdiff
path: root/app-crypt/jitterentropy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-08 04:26:34 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-08 04:26:34 +0100
commit325837835fc86686829aaa6acace3d3c06c74cea (patch)
tree6cc31680e4ce26ab26e863fd7b72d0ffe2d9366f /app-crypt/jitterentropy
parent7ad61ca2bfc8f8da08d2fb3085e4333dcccb0a64 (diff)
gentoo auto-resync : 08:10:2024 - 04:26:34
Diffstat (limited to 'app-crypt/jitterentropy')
-rw-r--r--app-crypt/jitterentropy/Manifest2
-rw-r--r--app-crypt/jitterentropy/jitterentropy-3.6.0.ebuild48
2 files changed, 50 insertions, 0 deletions
diff --git a/app-crypt/jitterentropy/Manifest b/app-crypt/jitterentropy/Manifest
index 72040f3fbc00..376cb69d0dad 100644
--- a/app-crypt/jitterentropy/Manifest
+++ b/app-crypt/jitterentropy/Manifest
@@ -1,3 +1,5 @@
DIST jitterentropy-3.4.1.tar.gz 86110 BLAKE2B 729ef7d01a17c9eb16cc352da0286bd292f2faae63754b06036dbb44d52e85e2e2e0d2a38ac57d4350eaebbc47457f0457a988a657f7fe6c5d782d50922552d2 SHA512 c832b33c084a8c56fb9ee0c0f7397fa9206cbd6fcbea047495e543566fc0d9b5d8978c8668103203d87b5b70c0e177f9ef7cc614b3ce689b90fbb8b85e6fedbb
+DIST jitterentropy-3.6.0.tar.gz 96456 BLAKE2B 5e4fc185f16b59456a681e37f90de3b1e381bd6269bf72294822c1b8db11bbd5fe48640f2f38257c9b1238df38df7d95c2d1b9136b12364dde6e5cf3395c2e6e SHA512 8b234d0ac8115d004e8b1f41318e42d72324dfcbea0b3ba96499a6f9d740e13659c5bea032f77baad8d8ea3846fcd628665df573ab12b6111785f4bb5954834c
EBUILD jitterentropy-3.4.1.ebuild 1612 BLAKE2B 85c6cc080600653d37a2c091fb51d4c2abbaf93c908b3afb960c0602a1119a26bbff808cddeff6296571adb174f5faf3adba8668337936a142d8c7b81a6b5048 SHA512 52c793e33aa66556bdd63fcb12b1362900b4ae32d58d5a4891baaeae3b2327a8dcc14b6d8d459484ef409769be4e91963292fb2c713cd6239e9f2a657fc7f6c6
+EBUILD jitterentropy-3.6.0.ebuild 1617 BLAKE2B 1f6624eb6ac1c681c234bfae976db6a4724fada69ef6945c1e434e5604f97ac6bdfee21e1cdf7159417c4da8fb956190ebbd84f2b2236bf72aed810fa2d10d9a SHA512 89fdc682279d092558b6504f65ad5df7eb9cc232fcf71d798554c95d9fd016e25b10f6d353bc221f6b695af6765bc62f6f6c8772f727ecb7c32a1abe52529eea
MISC metadata.xml 681 BLAKE2B c0777e7525bc36dd9a65680b2cb0b918d73f9e091fe686b7d7ec3ec4441b73c776bf8d3526cf8f16dcb34228532a633b9d6d9df18b2dc626f602eb813cf53634 SHA512 1cc9f7bdca491ac96ce85adf9a0fe1462e52e1da99181750aaf362197dde3c68e9278ead72e0ca81b689812edcb3670e1a143ef37c5dab7b646b818df5c893a1
diff --git a/app-crypt/jitterentropy/jitterentropy-3.6.0.ebuild b/app-crypt/jitterentropy/jitterentropy-3.6.0.ebuild
new file mode 100644
index 000000000000..987687b0feb5
--- /dev/null
+++ b/app-crypt/jitterentropy/jitterentropy-3.6.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Hardware RNG based on CPU timing jitter"
+HOMEPAGE="https://github.com/smuellerDD/jitterentropy-library"
+SRC_URI="https://github.com/smuellerDD/jitterentropy-library/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-library-${PV}"
+
+# For future reference, tests/raw-entropy/validation-{restart,runtime}
+# have a weird license clause where it says:
+# The licensee IS NOT granted permission to redistribute the source code or
+# derivatives of the source code, and the binaries compiled from the source
+# code or its derivatives to any third parties.
+# Do not package these two components!
+LICENSE="BSD"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="static-libs"
+
+src_prepare() {
+ default
+
+ # Disable man page compression on install
+ sed -e '/\tgzip.*man/ d' -i Makefile || die
+}
+
+src_compile() {
+ # Upstream defines some of CFLAGS in the Makefile using '?='
+ # This allows those default flags to be overwritten by
+ # user-defined CFLAGS. Restore some of the defaults.
+ append-cflags '-fwrapv' '-fvisibility=hidden' '-fPIE'
+ # Optimizations are not allowed by upstream, which already
+ # overrides CFLAGS in Makefile. We need to handle CPPFLAGS here.
+ append-cppflags '-O0'
+ emake AR="$(tc-getAR)" CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake PREFIX="${EPREFIX}/usr" \
+ LIBDIR="$(get_libdir)" \
+ DESTDIR="${D}" \
+ INSTALL_STRIP="install" \
+ install $(usex static-libs install-static '')
+}