summaryrefslogtreecommitdiff
path: root/app-crypt/kbfs/kbfs-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-29 11:22:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-10-29 11:22:34 +0000
commitbd7908c6630f38067350d396ac5d18c3cc2434a0 (patch)
tree3559b3e11424f5529527f2474d8a977a91ee3389 /app-crypt/kbfs/kbfs-9999.ebuild
parent8b2628ad8526c806375e7b157889e4274b70248b (diff)
gentoo resync : 29.10.2017
Diffstat (limited to 'app-crypt/kbfs/kbfs-9999.ebuild')
-rw-r--r--app-crypt/kbfs/kbfs-9999.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/app-crypt/kbfs/kbfs-9999.ebuild b/app-crypt/kbfs/kbfs-9999.ebuild
index 4da71bde3c9a..b084faeb8f15 100644
--- a/app-crypt/kbfs/kbfs-9999.ebuild
+++ b/app-crypt/kbfs/kbfs-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -12,7 +12,7 @@ EGIT_REPO_URI="https://github.com/keybase/kbfs.git"
LICENSE="BSD"
SLOT="0"
KEYWORDS=""
-IUSE=""
+IUSE="git"
DEPEND="
>=dev-lang/go-1.6:0
@@ -37,8 +37,16 @@ src_compile() {
-tags production \
-o "${T}/kbfsfuse" \
github.com/keybase/kbfs/kbfsfuse
+ use git && \
+ GOPATH="${WORKDIR}" \
+ go build -v -x \
+ -tags production \
+ -o "${T}/git-remote-keybase" \
+ github.com/keybase/kbfs/kbfsgit/git-remote-keybase
}
src_install() {
dobin "${T}/kbfsfuse"
+ use git && \
+ dobin "${T}/git-remote-keybase"
}