summaryrefslogtreecommitdiff
path: root/app-crypt/loop-aes-losetup
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-crypt/loop-aes-losetup
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-crypt/loop-aes-losetup')
-rw-r--r--app-crypt/loop-aes-losetup/Manifest4
-rw-r--r--app-crypt/loop-aes-losetup/loop-aes-losetup-2.28.2.ebuild79
-rw-r--r--app-crypt/loop-aes-losetup/metadata.xml11
3 files changed, 94 insertions, 0 deletions
diff --git a/app-crypt/loop-aes-losetup/Manifest b/app-crypt/loop-aes-losetup/Manifest
new file mode 100644
index 000000000000..5836d2a48d2d
--- /dev/null
+++ b/app-crypt/loop-aes-losetup/Manifest
@@ -0,0 +1,4 @@
+DIST loop-AES-v3.7j.tar.bz2 326818 BLAKE2B ca2db3162298e2e28dcc6feb5e6ba885a08097acafb9937a69898e6944c62cbb1c0ef601e13c0547550721430bf770f187ee71bc5e642d6107c982fae9d03462 SHA512 e1b59680680e2b40bb42cad9f1e89a344c7bfd0ee01fdc26151e9edea64b5111744588bc05c672de16c76ae0a3e4d6a8d4c4c9c09709a9f93bfc62a2f64ba7c7
+DIST util-linux-2.28.2.tar.xz 4149700 BLAKE2B da38a047b4a7dc867ba72aea149d515665375089d880d43c40f6d19a09ee33023d64b95c15073d6a83a36ee58ff6d47ef08671ab841b533bb747a337c5da6c02 SHA512 ac1c2d4c92bbc4eabed464cb0334c1d9b21e58df0f07f0b26e7adcfa188879de8632d195b65a4358c5e11e14ac6e09a1c6206265bbf1fab4ce122414bee7e940
+EBUILD loop-aes-losetup-2.28.2.ebuild 2390 BLAKE2B 51c6abdeff7924eca6e5f5e0d288adfe782a5440aa0a5db47a59afdd801b5b21fb9e3f9cef505b50cb15727d3e23b4c1238edd1c5d3e88d02bccf2b6df1fb1c2 SHA512 c71049614a40863c8634b142d16beb671f0cf77607b541018cfc44ab4bcfccf8b85e6f568e55963a30be8650d86c8fe6b0138914c7b0449592fe27062a6bcab3
+MISC metadata.xml 318 BLAKE2B 645d30bddca8c141085ee99caba70b409c1318c175f6f25c0a16b81d2286f1c1b74ab694d2100fd20b1bf16bf5f4134c4642370b99bdedd8d2cc015a822ec768 SHA512 93c67a250f19a2a17bde884a0f493b5b675ae2e0b4dd89164dc8a052e7adb9b2b5ebd07a43fb5432a8198216134ed3a0eca4b14bc98b9be71e9d947f51b77439
diff --git a/app-crypt/loop-aes-losetup/loop-aes-losetup-2.28.2.ebuild b/app-crypt/loop-aes-losetup/loop-aes-losetup-2.28.2.ebuild
new file mode 100644
index 000000000000..abeaf0b775d7
--- /dev/null
+++ b/app-crypt/loop-aes-losetup/loop-aes-losetup-2.28.2.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit autotools toolchain-funcs libtool flag-o-matic
+
+MY_PV="${PV/_/-}"
+MY_P="util-linux-${MY_PV}"
+LOOPAES_P="loop-AES-v3.7j"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Loop-AES losetup utility"
+HOMEPAGE="https://www.kernel.org/pub/linux/utils/util-linux/"
+SRC_URI="mirror://kernel/linux/utils/util-linux/v${PV:0:4}/${MY_P}.tar.xz
+ http://loop-aes.sourceforge.net/loop-AES/${LOOPAES_P}.tar.bz2"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~sparc ~x86"
+
+LICENSE="GPL-2 LGPL-2.1 BSD-4 MIT public-domain"
+SLOT="0"
+IUSE="nls selinux static"
+
+RDEPEND="selinux? ( sys-libs/libselinux )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ virtual/os-headers"
+
+PATCHES=(
+ "${WORKDIR}/${LOOPAES_P}/util-linux-${PV}.diff"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+lfs_fallocate_test() {
+ # Make sure we can use fallocate with LFS #300307
+ cat <<-EOF > "${T}"/fallocate.${ABI}.c
+ #define _GNU_SOURCE
+ #include <fcntl.h>
+ main() { return fallocate(0, 0, 0, 0); }
+ EOF
+ append-lfs-flags
+ $(tc-getCC) ${CFLAGS} ${CPPFLAGS} ${LDFLAGS} "${T}"/fallocate.${ABI}.c -o /dev/null >/dev/null 2>&1 \
+ || export ac_cv_func_fallocate=no
+ rm -f "${T}"/fallocate.${ABI}.c
+}
+
+src_configure() {
+ lfs_fallocate_test
+ # The scanf test in a run-time test which fails while cross-compiling.
+ # Blindly assume a POSIX setup since we require libmount, and libmount
+ # itself fails when the scanf test fails. #531856
+ tc-is-cross-compiler && export scanf_cv_alloc_modifier=ms
+ # We manually set --libdir to the default since on prefix, econf will set it to
+ # a value which the configure script does not recognize. This makes it set the
+ # usrlib_execdir to a bad value. bug #518898#c2, fixed upstream for >2.25
+ ECONF_SOURCE=${S} \
+ econf \
+ --libdir='${prefix}/'"$(get_libdir)" \
+ --disable-all-programs \
+ --disable-pylibmount \
+ --enable-libsmartcols \
+ --enable-losetup \
+ --without-ncurses \
+ --without-udev \
+ $(use_enable nls) \
+ $(use_with selinux) \
+ $(tc-has-tls || echo --disable-tls) \
+ $(use static && echo --enable-static-programs=losetup)
+}
+
+src_install() {
+ emake install DESTDIR="${T}/root"
+ newsbin "${T}/root/sbin/losetup" loop-aes-losetup
+ newman "${T}/root/usr/share/man/man8/losetup.8" loop-aes-losetup.8
+ use static && newsbin "${T}/root/bin/losetup.static" loop-aes-losetup.static
+}
diff --git a/app-crypt/loop-aes-losetup/metadata.xml b/app-crypt/loop-aes-losetup/metadata.xml
new file mode 100644
index 000000000000..12925882c9ff
--- /dev/null
+++ b/app-crypt/loop-aes-losetup/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>crypto@gentoo.org</email>
+ <name>Crypto</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">loop-aes</remote-id>
+ </upstream>
+</pkgmetadata>