summaryrefslogtreecommitdiff
path: root/app-crypt/osslsigncode/osslsigncode-2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /app-crypt/osslsigncode/osslsigncode-2.0.ebuild
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'app-crypt/osslsigncode/osslsigncode-2.0.ebuild')
-rw-r--r--app-crypt/osslsigncode/osslsigncode-2.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-crypt/osslsigncode/osslsigncode-2.0.ebuild b/app-crypt/osslsigncode/osslsigncode-2.0.ebuild
new file mode 100644
index 000000000000..f88975d1bc93
--- /dev/null
+++ b/app-crypt/osslsigncode/osslsigncode-2.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit autotools
+
+DESCRIPTION="Platform-independent tool for Authenticode signing of EXE/CAB files"
+HOMEPAGE="https://github.com/mtrojnar/osslsigncode"
+SRC_URI="https://github.com/mtrojnar/osslsigncode/archive/2.0.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="curl libressl"
+
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+ curl? ( net-misc/curl )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ eautoreconf
+ eapply_user
+}
+
+src_configure() {
+ econf $(use_with curl)
+}