summaryrefslogtreecommitdiff
path: root/app-crypt/p11-kit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /app-crypt/p11-kit
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'app-crypt/p11-kit')
-rw-r--r--app-crypt/p11-kit/Manifest2
-rw-r--r--app-crypt/p11-kit/p11-kit-0.24.0.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/app-crypt/p11-kit/Manifest b/app-crypt/p11-kit/Manifest
index 2ab3df59d8ba..cceba350c88a 100644
--- a/app-crypt/p11-kit/Manifest
+++ b/app-crypt/p11-kit/Manifest
@@ -1,3 +1,5 @@
DIST p11-kit-0.23.22.tar.xz 830016 BLAKE2B 4e1edfd9e2441d237c07a16c003aee5ffde38f1cf545c26e435645429f2cfa4fe7ca61cdc3c3940390aa040ba991f2ee3995b14cc31bb886d5eeffa8ed5e1721 SHA512 098819e6ca4ad9cc2a0bc2e478aea67354d051a4f03e6c7d75d13d2469b6dc7654f26b15530052f6ed51acb35531c2539e0f971b31e29e6673e857c903afb080
+DIST p11-kit-0.24.0.tar.xz 834392 BLAKE2B f967b51d3b021c6e95a0ddc1934527023aa4acbae2b193d64829620331ea0f094e1467fdea897a3121d05f30b1747607197a50c906a40609913230ab363c09e5 SHA512 48369d6fdae79b8c5a255c821fbdb982f0c649cce07c0d92f0ff0c16322fea8919faa94067cae2efede2da3646c0e69a71a3e399b769dc2327f247bcb113eb3c
EBUILD p11-kit-0.23.22.ebuild 2008 BLAKE2B e2c6140ad7266ed68c605c3fd157776bca69900f8f123d6a9c469ca8877099a809bc92b99a9e57605e75940955c52e0de5794b68f9e2865fe58dac0a540d875f SHA512 be9bab7ce91c482bdf6d6413573926bebb77b987b5a8a620b610347d07bba36c502e7067d90e8e1bbb9023aa63c706c0929fec30e957a590675f97ecc2046839
+EBUILD p11-kit-0.24.0.ebuild 2016 BLAKE2B 7075bab6be1a1b29a98350ccb547f7398244009e489d933a282b35b22ecedd44691fbbf77ac8f42958afa473440fd938173d20bc1798e2340c26045a2861bce4 SHA512 85196e2e2f382cc69fe18e87faa00dcb34aa500d7a7c5b8a9310a0f716570555b61b0ba25f3ede08fa3b21b101a52710c4d99c7565c2c419fcf7f91b4a9825de
MISC metadata.xml 461 BLAKE2B f08333756cc155a6cdf4114a5c486915ca0c328be382457981064997951bc89b4968fabcce89fad96fcf1c26e822d292aceb26684f1118520474df52b40dbf8e SHA512 043b9eb064bd25e69b57b0ec50193ce748efae48429e2b8518df0d2376262d213507bb11a809a2a5b4443d3991eca6c60d418538ea92845b3d71139b16e19fa2
diff --git a/app-crypt/p11-kit/p11-kit-0.24.0.ebuild b/app-crypt/p11-kit/p11-kit-0.24.0.ebuild
new file mode 100644
index 000000000000..7366c599dd8b
--- /dev/null
+++ b/app-crypt/p11-kit/p11-kit-0.24.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit multilib-minimal
+
+DESCRIPTION="Provides a standard configuration setup for installing PKCS#11"
+HOMEPAGE="https://p11-glue.github.io/p11-glue/p11-kit.html"
+SRC_URI="https://github.com/p11-glue/p11-kit/releases/download/${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+asn1 debug +libffi systemd +trust"
+REQUIRED_USE="trust? ( asn1 )"
+
+RDEPEND="asn1? ( >=dev-libs/libtasn1-3.4:=[${MULTILIB_USEDEP}] )
+ libffi? ( dev-libs/libffi:=[${MULTILIB_USEDEP}] )
+ systemd? ( sys-apps/systemd:= )
+ trust? ( app-misc/ca-certificates )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+pkg_setup() {
+ # disable unsafe tests, bug#502088
+ export FAKED_MODE=1
+}
+
+src_prepare() {
+ if [[ ${CHOST} == *-solaris2.* && ${CHOST##*-solaris2.} -lt 11 ]] ; then
+ # Solaris 10 and before doesn't know about XPG7 (XOPEN_SOURCE=700)
+ # drop to XPG6 to make feature_tests.h happy
+ sed -i -e '/define _XOPEN_SOURCE/s/700/600/' common/compat.c || die
+ # paths.h isn't available, oddly enough also not used albeit included
+ sed -i -e '/#include <paths.h>/d' trust/test-trust.c || die
+ # we don't have SUN_LEN here
+ sed -i -e 's/SUN_LEN \(([^)]\+)\)/strlen (\1->sun_path)/' \
+ p11-kit/server.c || die
+ fi
+ default
+}
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ $(use_enable trust trust-module) \
+ $(use_with trust trust-paths ${EPREFIX}/etc/ssl/certs/ca-certificates.crt) \
+ $(use_enable debug) \
+ $(use_with libffi) \
+ $(use_with asn1 libtasn1) \
+ $(multilib_native_use_with systemd)
+
+ if multilib_is_native_abi; then
+ # re-use provided documentation
+ ln -s "${S}"/doc/manual/html doc/manual/html || die
+ fi
+}
+
+multilib_src_install_all() {
+ einstalldocs
+ find "${D}" -name '*.la' -delete || die
+}