summaryrefslogtreecommitdiff
path: root/app-crypt/pinentry
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-25 05:40:31 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-25 05:40:31 +0000
commitd117dce29795dfc5a9824d31a128decaa37f73d2 (patch)
treeef95e8fa6dfdf9a769d594a457e755c8782a345b /app-crypt/pinentry
parentfa49bc1447d334c70e45ded349d3c37319dab7b4 (diff)
gentoo auto-resync : 25:02:2024 - 05:40:31
Diffstat (limited to 'app-crypt/pinentry')
-rw-r--r--app-crypt/pinentry/Manifest1
-rw-r--r--app-crypt/pinentry/pinentry-1.2.1-r5.ebuild107
2 files changed, 108 insertions, 0 deletions
diff --git a/app-crypt/pinentry/Manifest b/app-crypt/pinentry/Manifest
index 9047af969537..1810fb386ed2 100644
--- a/app-crypt/pinentry/Manifest
+++ b/app-crypt/pinentry/Manifest
@@ -3,4 +3,5 @@ AUX pinentry-1.2.1-automagic-capslock.patch 2831 BLAKE2B abe6c6815521dd80a227704
DIST pinentry-1.2.1.tar.bz2 547698 BLAKE2B aa47612aa3a6f74c3676bf4018780356cb22ed4078792c1f466f9e0465199428c151c0e20dfbe6c784ef93c2b42b673daff0b6adc74c8c98fed9921e65ed42ea SHA512 a665315628f4dcf07e16a22db3f3be15d7e7e93b3deec0546c7275b71b0e3bd65535a08af5e12d6339fd6595132df86529401d9d12bd17c428a3466e8dfafab6
DIST pinentry-1.2.1.tar.bz2.sig 238 BLAKE2B 01ba3dc296a8e76c546d21d0bb0cd13778476d5d5b3ef55a3401c6a0353a56d79250d11555afb31c77c5a77e63847ded0f8eaef395bb0dc2ee3ff1d6a4ed83bd SHA512 d0e8435dc169a58f111f057f1c9fbb6c70da32a850f1107d6abdf41357c1714832728109ae61507db313d7eaef9596e5faf92fd21bed78adcc46a8c8a590430b
EBUILD pinentry-1.2.1-r4.ebuild 2559 BLAKE2B 9119a96aad7f9866a7f10dda1048f4f42b9b7e4298ac82160a8e0bb47d4938ef6dc8f2e400a6fc8f9426c601516738e25b470ba668a29aab761285f0ad60965d SHA512 85e87975e0e5da0f026462291ea61ac19946117e565d9c163d4dc467d8d5d6a976c2d08921a78408816090930e32f0d0c56d2cbca63e2fb85f3b532ba4834c7c
+EBUILD pinentry-1.2.1-r5.ebuild 2512 BLAKE2B 74956d554d56a8e620ff55697fa4a75f20e897955591469d9481afd9dae050a142be5866e1f28d39391252d6b3370a87b5c668f3ba5891b9d8b96d0a609a57aa SHA512 ad9a55fdbd346ef225b572231695b7802ae304674901ecf5e2e9e0cbdec9e15cf2e87bc4cb97531b1a43f97c8b1bce9b81fae6a85adc682e193d9204dbcd41e9
MISC metadata.xml 344 BLAKE2B d71f184ae783d215e32dc94e346c1f753f158b298cc2df87c14d5b73454ff3b4bf0ce4744d2aa0359bc68cb993cd35d2d6f77a09769853fda5b66e1cc1da3580 SHA512 0ae1c64980d4d94b8bbc04040a17b358b7138bf4022dcd97b6d2c464bc5fac0911c9522bea253586f69c8d137b75fe3e302d7cd9802290c2720c77706d9a935f
diff --git a/app-crypt/pinentry/pinentry-1.2.1-r5.ebuild b/app-crypt/pinentry/pinentry-1.2.1-r5.ebuild
new file mode 100644
index 000000000000..4fab916751e3
--- /dev/null
+++ b/app-crypt/pinentry/pinentry-1.2.1-r5.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VERIFY_SIG_OPENPGP_KEY_PATH=/usr/share/openpgp-keys/gnupg.asc
+inherit autotools qmake-utils verify-sig
+
+DESCRIPTION="Simple passphrase entry dialogs which utilize the Assuan protocol"
+HOMEPAGE="https://gnupg.org/aegypten2/"
+SRC_URI="mirror://gnupg/${PN}/${P}.tar.bz2"
+SRC_URI+=" verify-sig? ( mirror://gnupg/${PN}/${P}.tar.bz2.sig )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~arm64-macos ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="caps efl emacs gtk keyring ncurses qt5 wayland X"
+
+DEPEND="
+ >=dev-libs/libassuan-2.1
+ >=dev-libs/libgcrypt-1.6.3
+ >=dev-libs/libgpg-error-1.17
+ efl? ( dev-libs/efl[X] )
+ keyring? ( app-crypt/libsecret )
+ ncurses? ( sys-libs/ncurses:= )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ wayland? ( kde-plasma/kwayland:5 )
+ X? (
+ dev-qt/qtx11extras:5
+ x11-libs/libX11
+ )
+ )
+"
+RDEPEND="
+ ${DEPEND}
+ gtk? ( app-crypt/gcr:0[gtk] )
+"
+BDEPEND="
+ sys-devel/gettext
+ virtual/pkgconfig
+ verify-sig? ( sec-keys/openpgp-keys-gnupg )
+"
+PDEPEND="emacs? ( app-emacs/pinentry )"
+IDEPEND=">=app-eselect/eselect-pinentry-0.7.2"
+
+DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.0.0-AR.patch"
+ "${FILESDIR}/${PN}-1.2.1-automagic-capslock.patch" # bug #819939, bug #837719
+)
+
+src_prepare() {
+ default
+
+ unset FLTK_CONFIG
+
+ eautoreconf
+}
+
+src_configure() {
+ export PATH="$(qt5_get_bindir):${PATH}"
+ export QTLIB="$(qt5_get_libdir)"
+
+ local myeconfargs=(
+ $(use_enable efl pinentry-efl)
+ $(use_enable emacs pinentry-emacs)
+ $(use_enable keyring libsecret)
+ $(use_enable gtk pinentry-gnome3)
+ $(use_enable ncurses fallback-curses)
+ $(use_enable ncurses pinentry-curses)
+ $(use_enable qt5 pinentry-qt)
+ $(use_enable wayland kf5-wayland)
+ $(use_enable X qtx11extras)
+ $(use_with X x)
+
+ --enable-pinentry-tty
+ --disable-pinentry-fltk
+ --disable-pinentry-gtk2
+
+ MOC="$(qt5_get_bindir)"/moc
+ ac_cv_path_GPGRT_CONFIG="${ESYSROOT}/usr/bin/${CHOST}-gpgrt-config"
+
+ $("${S}/configure" --help | grep -- '--without-.*-prefix' | sed -e 's/^ *\([^ ]*\) .*/\1/g')
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ rm "${ED}"/usr/bin/pinentry || die
+
+ use qt5 && dosym pinentry-qt /usr/bin/pinentry-qt5
+}
+
+pkg_postinst() {
+ eselect pinentry update ifunset
+}
+
+pkg_postrm() {
+ eselect pinentry update ifunset
+}