summaryrefslogtreecommitdiff
path: root/app-crypt/princeprocessor/princeprocessor-0.22-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-16 18:48:52 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-16 18:48:52 +0000
commitf265f17242b04ae036b4dc174fa95401d895dbc5 (patch)
tree8daa848087a673b8bf5dad576b0a08048d551da7 /app-crypt/princeprocessor/princeprocessor-0.22-r1.ebuild
parentd08ea43e9ada434f42f4be8e115b67ab22ce38af (diff)
gentoo auto-resync : 16:03:2024 - 18:48:51
Diffstat (limited to 'app-crypt/princeprocessor/princeprocessor-0.22-r1.ebuild')
-rw-r--r--app-crypt/princeprocessor/princeprocessor-0.22-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-crypt/princeprocessor/princeprocessor-0.22-r1.ebuild b/app-crypt/princeprocessor/princeprocessor-0.22-r1.ebuild
new file mode 100644
index 000000000000..2d17139bf757
--- /dev/null
+++ b/app-crypt/princeprocessor/princeprocessor-0.22-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2019-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo toolchain-funcs
+
+DESCRIPTION="Standalone password candidate generator using the PRINCE algorithm"
+HOMEPAGE="https://github.com/hashcat/princeprocessor"
+SRC_URI="https://github.com/hashcat/princeprocessor/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P}/src"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_compile() {
+ edo $(tc-getCC) -W -Wall -std=c99 ${CFLAGS} ${LDFLAGS} -DLINUX -o ${PN} pp.c mpz_int128.h
+}
+
+src_install() {
+ dobin ${PN}
+ dodoc ../{README.md,CHANGES}
+ #install rules after hashcat is fixed
+ #insinto /usr/share/hashcat
+ #doins ../rules/*.rules
+}