summaryrefslogtreecommitdiff
path: root/app-crypt/rotix/rotix-0.83-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /app-crypt/rotix/rotix-0.83-r1.ebuild
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'app-crypt/rotix/rotix-0.83-r1.ebuild')
-rw-r--r--app-crypt/rotix/rotix-0.83-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-crypt/rotix/rotix-0.83-r1.ebuild b/app-crypt/rotix/rotix-0.83-r1.ebuild
new file mode 100644
index 000000000000..659781528a35
--- /dev/null
+++ b/app-crypt/rotix/rotix-0.83-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit flag-o-matic
+
+DESCRIPTION="Rotix allows you to generate rotational obfuscations"
+HOMEPAGE="https://github.com/shemminga/rotix"
+SRC_URI="https://github.com/shemminga/${PN}/releases/download/${PV}/${PN}_${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+DEPEND="sys-devel/gettext"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}"/0.83-respect-CFLAGS-and-dont-strip.patch
+"${FILESDIR}"/rotix-0.83-locale.patch
+"${FILESDIR}"/rotix-0.83-interix.patch )
+
+src_prepare() {
+ default
+}
+
+src_configure() {
+ use elibc_glibc || append-flags -lintl
+ econf --i18n=1
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+}