summaryrefslogtreecommitdiff
path: root/app-crypt/sbctl/sbctl-0.11.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-28 09:49:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-03-28 09:49:11 +0100
commit115dcc7054f5934a2c8e26fd8a8eed5f3e29e9ce (patch)
treec31afe35699960753f76770d6b0b4ea48af9f686 /app-crypt/sbctl/sbctl-0.11.ebuild
parente292b671b113c2cc012beddad93a3df4f9410698 (diff)
gentoo auto-resync : 28:03:2023 - 09:49:10
Diffstat (limited to 'app-crypt/sbctl/sbctl-0.11.ebuild')
-rw-r--r--app-crypt/sbctl/sbctl-0.11.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-crypt/sbctl/sbctl-0.11.ebuild b/app-crypt/sbctl/sbctl-0.11.ebuild
new file mode 100644
index 000000000000..d12c8d756274
--- /dev/null
+++ b/app-crypt/sbctl/sbctl-0.11.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module verify-sig
+
+DESCRIPTION="Secure Boot key manager"
+HOMEPAGE="https://github.com/Foxboron/sbctl"
+SRC_URI="https://github.com/Foxboron/${PN}/releases/download/${PV}/${P}.tar.gz
+ https://dev.gentoo.org/~ajak/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz
+ verify-sig? ( https://github.com/Foxboron/${PN}/releases/download/${PV}/${P}.tar.gz.sig )"
+
+LICENSE="Apache-2.0 BSD BSD-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="app-text/asciidoc
+ verify-sig? ( sec-keys/openpgp-keys-foxboron )"
+
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}/usr/share/openpgp-keys/foxboron.asc"
+
+src_unpack() {
+ if use verify-sig; then
+ verify-sig_verify_detached "${DISTDIR}"/${P}.tar.gz{,.sig}
+ fi
+
+ default
+}
+
+src_install() {
+ emake PREFIX="${ED}/usr" install
+}