summaryrefslogtreecommitdiff
path: root/app-crypt/sbctl/sbctl-0.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-25 20:44:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-25 20:44:11 +0100
commit159ec3f090554ee5d7f61b2da553833fb7566f99 (patch)
tree8be8aa1641e20a8dfa1bab1b818367b702817c8a /app-crypt/sbctl/sbctl-0.12.ebuild
parent2000f81da4dc9971f6e1e5d00b315816d4188f4c (diff)
gentoo auto-resync : 25:10:2023 - 20:44:11
Diffstat (limited to 'app-crypt/sbctl/sbctl-0.12.ebuild')
-rw-r--r--app-crypt/sbctl/sbctl-0.12.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/app-crypt/sbctl/sbctl-0.12.ebuild b/app-crypt/sbctl/sbctl-0.12.ebuild
new file mode 100644
index 000000000000..3db9dbf47a9e
--- /dev/null
+++ b/app-crypt/sbctl/sbctl-0.12.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module verify-sig
+
+DESCRIPTION="Secure Boot key manager"
+HOMEPAGE="https://github.com/Foxboron/sbctl"
+SRC_URI="https://github.com/Foxboron/${PN}/releases/download/${PV}/${P}.tar.gz
+ verify-sig? ( https://github.com/Foxboron/${PN}/releases/download/${PV}/${P}.tar.gz.sig )"
+SRC_URI+=" https://dev.gentoo.org/~ajak/distfiles/${CATEGORY}/${PN}/${P}-deps.tar.xz"
+
+LICENSE="Apache-2.0 BSD BSD-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="app-text/asciidoc
+ verify-sig? ( sec-keys/openpgp-keys-foxboron )"
+
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}/usr/share/openpgp-keys/foxboron.asc"
+
+src_unpack() {
+ if use verify-sig; then
+ verify-sig_verify_detached "${DISTDIR}"/${P}.tar.gz{,.sig}
+ fi
+
+ default
+}
+
+src_install() {
+ emake PREFIX="${ED}/usr" install
+}