summaryrefslogtreecommitdiff
path: root/app-crypt/scdrand/scdrand-0.3.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /app-crypt/scdrand/scdrand-0.3.5.ebuild
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'app-crypt/scdrand/scdrand-0.3.5.ebuild')
-rw-r--r--app-crypt/scdrand/scdrand-0.3.5.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-crypt/scdrand/scdrand-0.3.5.ebuild b/app-crypt/scdrand/scdrand-0.3.5.ebuild
new file mode 100644
index 000000000000..da331728dfe5
--- /dev/null
+++ b/app-crypt/scdrand/scdrand-0.3.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_P=scdtools-${PV}
+DESCRIPTION="Feed kernel entropy pool from smartcard's TRNG"
+HOMEPAGE="https://incenp.org/dvlpt/scdtools.html"
+SRC_URI="https://incenp.org/files/softs/scdtools/$(ver_cut 1-2)/${MY_P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-libs/libgcrypt:=
+ dev-libs/libassuan:=
+ dev-libs/libgpg-error:="
+RDEPEND="${DEPEND}
+ app-crypt/gnupg"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ emake -C lib
+ emake -C src scdrand
+}
+
+src_test() { :; }
+
+src_install() {
+ emake DESTDIR="${D}" -C man man_MANS="scdrand.1" install
+ emake DESTDIR="${D}" -C src bin_PROGRAMS="scdrand" install
+}