summaryrefslogtreecommitdiff
path: root/app-crypt/simple-tpm-pk11
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-crypt/simple-tpm-pk11
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-crypt/simple-tpm-pk11')
-rw-r--r--app-crypt/simple-tpm-pk11/Manifest3
-rw-r--r--app-crypt/simple-tpm-pk11/metadata.xml11
-rw-r--r--app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.06.ebuild36
3 files changed, 50 insertions, 0 deletions
diff --git a/app-crypt/simple-tpm-pk11/Manifest b/app-crypt/simple-tpm-pk11/Manifest
new file mode 100644
index 000000000000..45cba3cdf6cd
--- /dev/null
+++ b/app-crypt/simple-tpm-pk11/Manifest
@@ -0,0 +1,3 @@
+DIST simple-tpm-pk11-0.06.tar.gz 28993 BLAKE2B b592acf3d9fe334993ed1e72152ee2c0a25ea3be777035c2d113323522f7d99e6c564bd7c4de0725b0f04f5b6dad90c5a35ede815d28f40a3fb53a6cc9e2bee6 SHA512 72df0637cefdb0d81f741480cdfe24ac0d6a05a93d729f5e2180adf49b5d7ddb0b60d8c6f7d5e79a67bf4cea202067390c8d4532c906273408f7de4fcc5e66e8
+EBUILD simple-tpm-pk11-0.06.ebuild 848 BLAKE2B 55327268ec66292471dd4e3bd6dbd3b3b832eef815f69708b3c144e1683b837c55f9136242be15f64cb4657d7f52d7a8018e628f5f0c26abcf28a2effca96f57 SHA512 4dbdb971fbb5932ec8d13ef67323174dce7b637d00277d680cfb1901e10b24c4b94b6bd1fcafb56e228b7ebd0752eeb8244951d7aae7c11db2689d430c89ea30
+MISC metadata.xml 417 BLAKE2B 814380b49341b7c00e8b6866fbb0676cedbc843424b6fec5d2f88ff159be7eed8a8247dc302172d2548125b737617bc2a755041e7d8134877ae2a650215aece5 SHA512 f62211877cd878f6a1a05456dcafd7564e687308f40a9512c9dafb7a9175a4a31fa709db15441846b0495da65939c4e9fe7c86417ff047c08e7bf31699e04fd5
diff --git a/app-crypt/simple-tpm-pk11/metadata.xml b/app-crypt/simple-tpm-pk11/metadata.xml
new file mode 100644
index 000000000000..44b53b64f090
--- /dev/null
+++ b/app-crypt/simple-tpm-pk11/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>perfinion@gentoo.org</email>
+ </maintainer>
+ <longdescription>A simple library for using the TPM chip to secure SSH keys</longdescription>
+ <upstream>
+ <remote-id type="github">ThomasHabets/simple-tpm-pk11</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.06.ebuild b/app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.06.ebuild
new file mode 100644
index 000000000000..1c0e8dc2f60f
--- /dev/null
+++ b/app-crypt/simple-tpm-pk11/simple-tpm-pk11-0.06.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Simple PKCS11 provider for TPM chips"
+HOMEPAGE="https://github.com/ThomasHabets/simple-tpm-pk11"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/ThomasHabets/${PN}.git"
+ inherit git-r3
+ KEYWORDS=""
+else
+ SRC_URI="https://github.com/ThomasHabets/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+IUSE="libressl"
+RESTRICT="test" # needs to communicate with the TPM and gtest is all broken
+
+DEPEND="app-crypt/tpm-tools[pkcs11]
+ dev-libs/opencryptoki[tpm]
+ app-crypt/trousers
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )"
+RDEPEND="${DEPEND}
+ net-misc/openssh[-X509]"
+
+src_prepare() {
+ eapply_user
+ eautoreconf
+}