summaryrefslogtreecommitdiff
path: root/app-crypt/stoken/stoken-0.92.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-12-23 20:48:53 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-12-23 20:48:53 +0000
commit51536d2fe4697ba9114d611178bb9e20d3d5b729 (patch)
tree30b91d98e65985a575940ed49e756697c1f049c2 /app-crypt/stoken/stoken-0.92.ebuild
parent4ab6db5717ef23f29320d4c6fb9ebdb8dec1f193 (diff)
gentoo resync : 23.12.2017
Diffstat (limited to 'app-crypt/stoken/stoken-0.92.ebuild')
-rw-r--r--app-crypt/stoken/stoken-0.92.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-crypt/stoken/stoken-0.92.ebuild b/app-crypt/stoken/stoken-0.92.ebuild
new file mode 100644
index 000000000000..6a8f901f3580
--- /dev/null
+++ b/app-crypt/stoken/stoken-0.92.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit autotools
+
+DESCRIPTION="Software Token for Linux/UNIX"
+HOMEPAGE="https://github.com/cernekee/stoken"
+SRC_URI="https://github.com/cernekee/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="gtk"
+
+# || ( dev-libs/nettle dev-libs/libtomcrypt ) libtomcrypt is not packaged
+RDEPEND="
+ dev-libs/nettle
+ gtk? ( >=x11-libs/gtk+-3.12:3 )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ eautoreconf
+ eapply_user
+}
+
+src_configure() {
+ econf $(use_with gtk)
+}