summaryrefslogtreecommitdiff
path: root/app-crypt/swtpm/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /app-crypt/swtpm/files
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'app-crypt/swtpm/files')
-rw-r--r--app-crypt/swtpm/files/swtpm-build-sys-Explicitly-link-libswtpm_libtpms-with-lcry.patch49
-rw-r--r--app-crypt/swtpm/files/swtpm-build-sys-Use-AC_COMPILE_IFELSE-to-check-for-unused-.patch56
2 files changed, 105 insertions, 0 deletions
diff --git a/app-crypt/swtpm/files/swtpm-build-sys-Explicitly-link-libswtpm_libtpms-with-lcry.patch b/app-crypt/swtpm/files/swtpm-build-sys-Explicitly-link-libswtpm_libtpms-with-lcry.patch
new file mode 100644
index 000000000000..d4ad9cda0c2d
--- /dev/null
+++ b/app-crypt/swtpm/files/swtpm-build-sys-Explicitly-link-libswtpm_libtpms-with-lcry.patch
@@ -0,0 +1,49 @@
+From d9bc718871810d18c70ba9d4e9ee23071bd6db36 Mon Sep 17 00:00:00 2001
+From: Stefan Berger <stefanb@linux.vnet.ibm.com>
+Date: Tue, 21 Jul 2020 18:39:07 -0400
+Subject: [PATCH 2/2] build-sys: Explicitly link libswtpm_libtpms with -lcrypto
+ (Gentoo)
+
+This patch fixes the following linker issue reported for Gentoo in
+issue #280.
+
+ld.lld: error: /var/tmp/portage/app-crypt/swtpm-0.3.1-r1/work/swtpm-0.3.1/src/swtpm/.libs/libswtpm_libtpms.so: undefined reference to EVP_sha512
+ld.lld: error: /var/tmp/portage/app-crypt/swtpm-0.3.1-r1/work/swtpm-0.3.1/src/swtpm/.libs/libswtpm_libtpms.so: undefined reference to PKCS5_PBKDF2_HMAC
+ld.lld: error: /var/tmp/portage/app-crypt/swtpm-0.3.1-r1/work/swtpm-0.3.1/src/swtpm/.libs/libswtpm_libtpms.so: undefined reference to SHA512
+
+Signed-off-by: Stefan Berger <stefanb@linux.ibm.com>
+---
+ configure.ac | 2 ++
+ src/swtpm/Makefile.am | 3 ++-
+ 2 files changed, 4 insertions(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 56d3f09..7aaa201 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -150,6 +150,8 @@ openssl)
+ AC_CHECK_HEADERS([openssl/aes.h],[],
+ AC_MSG_ERROR(Is openssl-devel/libssl-dev installed?))
+ AC_MSG_RESULT([Building with openssl crypto library])
++ LIBCRYPTO_LIBS=$(pkg-config --libs libcrypto)
++ AC_SUBST([LIBCRYPTO_LIBS])
+ ;;
+ esac
+
+diff --git a/src/swtpm/Makefile.am b/src/swtpm/Makefile.am
+index dd2a63a..b5f15e3 100644
+--- a/src/swtpm/Makefile.am
++++ b/src/swtpm/Makefile.am
+@@ -69,7 +69,8 @@ libswtpm_libtpms_la_LIBADD = \
+ $(LIBTPMS_LIBS) \
+ $(GLIB_LIBS) \
+ $(LIBRT_LIBS) \
+- $(LIBSECCOMP_LIBS)
++ $(LIBSECCOMP_LIBS) \
++ $(LIBCRYPTO_LIBS)
+
+ bin_PROGRAMS = swtpm
+ if WITH_CUSE
+--
+2.26.2
+
diff --git a/app-crypt/swtpm/files/swtpm-build-sys-Use-AC_COMPILE_IFELSE-to-check-for-unused-.patch b/app-crypt/swtpm/files/swtpm-build-sys-Use-AC_COMPILE_IFELSE-to-check-for-unused-.patch
new file mode 100644
index 000000000000..582199708057
--- /dev/null
+++ b/app-crypt/swtpm/files/swtpm-build-sys-Use-AC_COMPILE_IFELSE-to-check-for-unused-.patch
@@ -0,0 +1,56 @@
+From b6d16129a525f572ef37d20ba1cd70d59ca4f079 Mon Sep 17 00:00:00 2001
+From: Stefan Berger <stefanb@linux.vnet.ibm.com>
+Date: Tue, 21 Jul 2020 17:38:10 -0400
+Subject: [PATCH 1/2] build-sys: Use AC_COMPILE_IFELSE to check for unused
+ linker flags (clang)
+
+This patch fixes a clang issue report in issue #280.
+
+clang does not use ld, so we cannot grep for support of certain linker
+flags but have to test-compile.
+
+Signed-off-by: Stefan Berger <stefanb@linux.ibm.com>
+---
+ configure.ac | 26 +++++++++++++++++++-------
+ 1 file changed, 19 insertions(+), 7 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index b4d4258..56d3f09 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -357,13 +357,25 @@ if test "x$enable_hardening" != "xno"; then
+ if test -z "$TMP1" && test -n "$TPM2"; then
+ HARDENING_CFLAGS="$HARDENING_CFLAGS -D_FORTIFY_SOURCE=2 "
+ fi
+- dnl Check ld for 'relro' and 'now'
+- if $LD --help 2>&1 | $GREP '\-z relro ' > /dev/null; then
+- HARDENING_CFLAGS="$HARDENING_CFLAGS -Wl,-z,relro "
+- fi
+- if $LD --help 2>&1 | $GREP '\-z now ' > /dev/null; then
+- HARDENING_CFLAGS="$HARDENING_CFLAGS -Wl,-z,now "
+- fi
++ dnl Check linker for 'relro' and 'now'
++ save_CFLAGS="$CFLAGS"
++ CFLAGS="-Wl,-z,relro -Werror"
++ AC_MSG_CHECKING([whether linker supports -Wl,-z,relro])
++ AC_COMPILE_IFELSE(
++ [AC_LANG_SOURCE([[int main() { return 0; }]])],
++ [HARDENING_CFLAGS="$HARDENING_CFLAGS -Wl,-z,relro"
++ AC_MSG_RESULT(yes)],
++ [AC_MSG_RESULT(no)]
++ )
++ CFLAGS="-Wl,-z,now -Werror"
++ AC_MSG_CHECKING([whether linker supports -Wl,-z,now])
++ AC_COMPILE_IFELSE(
++ [AC_LANG_SOURCE([[int main() { return 0; }]])],
++ [HARDENING_CFLAGS="$HARDENING_CFLAGS -Wl,-z,now"
++ AC_MSG_RESULT(yes)],
++ [AC_MSG_RESULT(no)]
++ )
++ CFLAGS="$save_CFLAGS"
+ AC_SUBST([HARDENING_CFLAGS])
+ fi
+
+--
+2.26.2
+