summaryrefslogtreecommitdiff
path: root/app-crypt/tpm-emulator
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-05 21:17:31 +0100
commitdc7cbdfa65fd814b3b9aa3c56257da201109e807 (patch)
treec85d72f6f31f21f178069c9d41d41a7c1ff4b362 /app-crypt/tpm-emulator
parent0706fc6986773f4e4d391deff4ad5143c464ea4e (diff)
gentoo resync : 05.04.2019
Diffstat (limited to 'app-crypt/tpm-emulator')
-rw-r--r--app-crypt/tpm-emulator/Manifest1
-rw-r--r--app-crypt/tpm-emulator/tpm-emulator-0.7.5.ebuild82
2 files changed, 0 insertions, 83 deletions
diff --git a/app-crypt/tpm-emulator/Manifest b/app-crypt/tpm-emulator/Manifest
index ca6abaec814a..2f903578c00c 100644
--- a/app-crypt/tpm-emulator/Manifest
+++ b/app-crypt/tpm-emulator/Manifest
@@ -3,5 +3,4 @@ AUX tpm-emulator.confd 20 BLAKE2B 13dd9f09a0a4efb9a039bfeababb5f00b8b2c3c1777e60
AUX tpm-emulator.initd 776 BLAKE2B 0daa0247396d1b5f1c9542b28f825899a5cc45bd748b6b7e2328440fd466fd6b461e32487a955816a79827bf350cfb33bd71a6b197a8e67dbf5509750098cb59 SHA512 22d7b163dc6f567c1900a275ae545c4421b2d459ba535a24f48d7ad2609f5df36533849aa781d4dd704961db102eea08c99b79c01d0e3981fb46d2eb4e39d6fe
DIST tpm-emulator-0.7.5.tar.gz 222341 BLAKE2B c6dc7494800f4c6d1f5e622c6a47fdd5487e0f2cbc34173d9039d6eb5fd7541dd2c1f514efbf220c605424059844e18650b31ee9934eda6626427b915fd6bc53 SHA512 24c16ec36ca92c484d6e8dfa53c8ca00dbc5b58d78d7166041db1e9ae277d763f0fc0a6b0cbd7e62fcf4671f6ad2d8df1213256be0a4200b79b6ee61ab73b2ef
EBUILD tpm-emulator-0.7.5-r1.ebuild 1714 BLAKE2B 9859186e9745a64ccb8cc65d4a3aec3c6cc16a4481e453cfa2e6611687892734be5d878a62039c3f99d00b515c7391e40bb86c5ed285d6063bb9c1d360cb19f7 SHA512 79d8f027b36b54433aad52c3fe8dbd8bfa3c2a2e16b811b9d3f78571c13e51a769816dcab6f44e75254da5f964e81ede9bc04f3915bfbc7bc72e6ba4402f0561
-EBUILD tpm-emulator-0.7.5.ebuild 1858 BLAKE2B 9f11f93bc01efaaeeca6f200b0705b9093c3b109e4af46502f187f079993ce735a1653d101561ca66b12444a63f67363198a9f890e7af954d2d6fdc47725f64e SHA512 2150882b2cfcd440ba40688683c045c25337c570059d11cc37be4fc88723ae5f617cf2de452355f79fb964e1cc66445271e8cc0bd9e10df8c25a212a5352854a
MISC metadata.xml 395 BLAKE2B 053fec93e12819e95abadca4f2e9f871589c21ce8a7369092cfb04cb593a4fa687956458dfc2c7249b6951bb3b7c45f6c38fac1448d9e5d250ed8256f92df327 SHA512 dd69f6a31ebaa3971c316d967bd643654d11465bb0de20059ea82a4851691b605c42deb4846614627ae9c8b2b30075e6c44e53f9810999839ceaf2e9ee9aada8
diff --git a/app-crypt/tpm-emulator/tpm-emulator-0.7.5.ebuild b/app-crypt/tpm-emulator/tpm-emulator-0.7.5.ebuild
deleted file mode 100644
index 97b70a4785f0..000000000000
--- a/app-crypt/tpm-emulator/tpm-emulator-0.7.5.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-MODULES_OPTIONAL_USE="modules"
-inherit user linux-mod cmake-utils udev
-
-MY_P=${P/-/_}
-DESCRIPTION="Emulator driver for tpm"
-HOMEPAGE="https://github.com/PeterHuewe/tpm-emulator"
-SRC_URI="https://github.com/PeterHuewe/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="GPL-2"
-
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-IUSE="libressl mtm-emulator ssl"
-RDEPEND="ssl? (
- !libressl? ( dev-libs/openssl:0= )
- libressl? ( dev-libs/libressl:0= )
- )"
-DEPEND="${RDEPEND}
- !ssl? ( dev-libs/gmp )"
-
-PATCHES=(
- "${FILESDIR}/${P}-build.patch"
-)
-
-pkg_setup() {
- enewgroup tss
- enewuser tss -1 -1 /var/lib/tpm tss
- if use modules; then
- CONFIG_CHECK="MODULES"
- MODULE_NAMES="tpmd_dev(extra:tpmd_dev/linux:)"
- BUILD_TARGETS="all tpmd_dev.rules"
- BUILD_PARAMS="KERNEL_BUILD=${KERNEL_DIR}"
- linux-mod_pkg_setup
- fi
-}
-
-src_configure() {
- local mycmakeargs=(
- -DUSE_OPENSSL=$(usex ssl ON OFF)
- -DMTM_EMULATOR=$(usex mtm-emulator ON OFF)
- -DBUILD_DEV=OFF
- )
- cmake-utils_src_configure
-
- use modules && ln -s "${BUILD_DIR}/config.h" tpmd_dev/linux
-}
-
-src_compile() {
- cmake-utils_src_compile
- use modules && linux-mod_src_compile
-}
-
-src_install() {
- cmake-utils_src_install
- if use modules; then
- linux-mod_src_install
- udev_newrules "tpmd_dev/linux/tpmd_dev.rules" 60-tpmd_dev.rules
- fi
-
- newinitd "${FILESDIR}/${PN}.initd" "${PN}"
- newconfd "${FILESDIR}/${PN}.confd" "${PN}"
-
- keepdir /var/log/tpm
- fowners tss:tss /var/log/tpm
-}
-
-pkg_postinst() {
- if use modules; then
- linux-mod_pkg_postinst
-
- ewarn ""
- ewarn "The new init.d script does not load the tpmd_dev any more as it is optional."
- ewarn "If you use the tpmd_dev, please load it explicitly in /etc/conf.d/modules"
- ewarn ""
- fi
-
- einfo "tpmd socket is located at /var/run/tpm/tpmd_socket:0"
-}