summaryrefslogtreecommitdiff
path: root/app-crypt/tpm-tools
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-14 07:56:51 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-14 07:56:51 +0000
commit2e4747a36a51fd58c21f3f00db959709e83fe08b (patch)
tree55b3fa7393c53b4b2fa2bb96fdae27d9d4444a97 /app-crypt/tpm-tools
parent5c1e419582680cfb61e0ae777c693704f3a731e1 (diff)
gentoo auto-resync : 14:02:2023 - 07:56:50
Diffstat (limited to 'app-crypt/tpm-tools')
-rw-r--r--app-crypt/tpm-tools/Manifest1
-rw-r--r--app-crypt/tpm-tools/tpm-tools-1.3.9.2-r1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/app-crypt/tpm-tools/Manifest b/app-crypt/tpm-tools/Manifest
index bd4a5eb0cc3a..191c1cd8bc48 100644
--- a/app-crypt/tpm-tools/Manifest
+++ b/app-crypt/tpm-tools/Manifest
@@ -2,5 +2,6 @@ AUX tpm-tools-1.3.9.1-openssl-1.1.patch 5937 BLAKE2B b8ca021f3b1cd91656a0b0f43df
DIST tpm-tools-1.3.9.1.tar.gz 482859 BLAKE2B ee915679e23bead04672bf719ce59bb6f20b550be39855b5304caeff554bf54d3cfe9104d464af7762388995e51d2bed0f9bedad83e42146cb7457382d09f4b2 SHA512 63a9c0e761cd890cc0a218de79a9c0169e151aba7824c19bf6b7ec894cf41c4950de1f63bd849aa93a4bdff36cf0fe557bc17113912b6d77f57f2bf1190b6a08
DIST tpm-tools-1.3.9.2.tar.gz 431930 BLAKE2B bbea3848765d9907c6faa1b5f4a60002e94243040985ce503f392bc8d7392bea41b54317b15fd227b5d73d589cf2c330729532448751d4375484375725310dfa SHA512 b684716c71702140591d89eb03d3724ed5b448e7ba2881bc44de9d44ffc23a9f7dfcf4351eec24e5438cc883f49a7dafee82bb19f90800610cf764ce74e60ccb
EBUILD tpm-tools-1.3.9.1-r1.ebuild 954 BLAKE2B f53bed313b12de4bd985c76d168a110a5f2e66448afb39636f8ccbef173810ec2ce60d0a01a39fb289cdc82b723237e58091b4f561668b77e28144d141592969 SHA512 045475346c2c8778ce588cf8fe893c24eca0c9d6ecf27161a2807f35d47737ba75f16d44d7b3c244b5ce35dc382a24c52ba3bd9c72e48bff9dfd8d488465a40e
+EBUILD tpm-tools-1.3.9.2-r1.ebuild 1101 BLAKE2B 67423e414641a9467e533011fd20293ff19cf199c54062221b14e1bf62489c61d088aec566e7a81248b7cb45f9590fb382ea17f128c3b82029160d4cb6113d58 SHA512 4966ad5f4dc0eaa4847546c3beabbbc442a4a70711e9c2271d16ef8562b5c9ff373438276d91f1b2c434cca8aab002f8b69b6305e2b4f53be40882878f3d044d
EBUILD tpm-tools-1.3.9.2.ebuild 1094 BLAKE2B f635866f67a93e3d4aac3d5435ff39399753978a8d2a67e404d0416e7dace32135aa54a80146a0b44de7d65391d977d038b7d0fa34a8923740ef34605eeed2de SHA512 310612239dc290c2b013c69a968c09013a1215a6cb6607ed1b49ebd4fb60e6afafbd413450f975f3fe8f258dc4e939294218408a05999ef1d025009e4f3f45f2
MISC metadata.xml 655 BLAKE2B 32c7f70c902ebfbc7f182b4ff474b97163112e4418597f12e2c4f10e082f7803a27948e1cbf17bfea491564a26a1c968fa5d7ec51878eaa79eb3e9598ee51ad9 SHA512 57f1c5a445c98a90025ab2b19fa00b55071bec42e3b130dae8dae203e1a81544cbcf723f8b4d4bfcc47771060e350663bb1c0ea976595c6c044809ed358f7ad0
diff --git a/app-crypt/tpm-tools/tpm-tools-1.3.9.2-r1.ebuild b/app-crypt/tpm-tools/tpm-tools-1.3.9.2-r1.ebuild
new file mode 100644
index 000000000000..68163a060786
--- /dev/null
+++ b/app-crypt/tpm-tools/tpm-tools-1.3.9.2-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="TrouSerS' support tools for the Trusted Platform Modules"
+HOMEPAGE="http://trousers.sourceforge.net"
+SRC_URI="mirror://sourceforge/trousers/${PN}/${P}.tar.gz"
+
+LICENSE="CPL-1.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~m68k ~s390 ~x86"
+IUSE="nls pkcs11 debug"
+
+DEPEND=">=app-crypt/trousers-0.3.15-r1
+ dev-libs/openssl:0=
+ pkcs11? ( dev-libs/opencryptoki )"
+RDEPEND="${DEPEND}"
+BDEPEND="nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ default
+
+# upstream didn't generate the tarball correctly so we must bootstrap
+# ouselves
+ mkdir -p po || die
+ mkdir -p m4 || die
+ cp -R po_/* po/ || die
+ touch po/Makefile.in.in || die
+ touch m4/Makefile.am || die
+
+ sed -i -r \
+ -e '/CFLAGS/s/ -m64//' \
+ configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ append-cppflags $(usex debug -DDEBUG -DNDEBUG)
+
+ econf \
+ $(use_enable nls) \
+ $(use pkcs11 || echo --disable-pkcs11-support)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}