summaryrefslogtreecommitdiff
path: root/app-crypt/tpm2-tools/tpm2-tools-3.1.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-02 21:45:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-02 21:45:28 +0100
commit2018227e9344edb9da15fc6a4a8298086cc2aa77 (patch)
treec18e1c09e605e94e2a1e93345ad25746cc9e14b9 /app-crypt/tpm2-tools/tpm2-tools-3.1.4.ebuild
parent6f8038813c460b4f0572d5ef595cdfa94af3a94d (diff)
gentoo resync : 02.06.2019
Diffstat (limited to 'app-crypt/tpm2-tools/tpm2-tools-3.1.4.ebuild')
-rw-r--r--app-crypt/tpm2-tools/tpm2-tools-3.1.4.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-crypt/tpm2-tools/tpm2-tools-3.1.4.ebuild b/app-crypt/tpm2-tools/tpm2-tools-3.1.4.ebuild
new file mode 100644
index 000000000000..c9391925f760
--- /dev/null
+++ b/app-crypt/tpm2-tools/tpm2-tools-3.1.4.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Tools for the TPM 2.0 TSS"
+HOMEPAGE="https://github.com/tpm2-software/tpm2-tools"
+SRC_URI="https://github.com/tpm2-software/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="libressl test"
+
+RDEPEND=">=app-crypt/tpm2-tss-2.0:=
+ net-misc/curl:=
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )"
+DEPEND="${RDEPEND}
+ test? ( dev-util/cmocka )"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.1.3-libressl.patch"
+)
+
+src_configure() {
+ econf \
+ --disable-hardening \
+ $(use_enable test unit)
+}