summaryrefslogtreecommitdiff
path: root/app-crypt/tpm2-tools/tpm2-tools-4.1.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
commitceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (patch)
tree9f47ee47c31a0f13f9496879cd88a1042550aa81 /app-crypt/tpm2-tools/tpm2-tools-4.1.1.ebuild
parent53cba99042fa967e2a93da9f8db806fe2d035543 (diff)
gentoo (leap year) resync : 29.02.2020
Diffstat (limited to 'app-crypt/tpm2-tools/tpm2-tools-4.1.1.ebuild')
-rw-r--r--app-crypt/tpm2-tools/tpm2-tools-4.1.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/app-crypt/tpm2-tools/tpm2-tools-4.1.1.ebuild b/app-crypt/tpm2-tools/tpm2-tools-4.1.1.ebuild
new file mode 100644
index 000000000000..a2ad7f1f2dcc
--- /dev/null
+++ b/app-crypt/tpm2-tools/tpm2-tools-4.1.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Tools for the TPM 2.0 TSS"
+HOMEPAGE="https://github.com/tpm2-software/tpm2-tools"
+SRC_URI="https://github.com/tpm2-software/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="libressl test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=app-crypt/tpm2-tss-2.3.1:=
+ net-misc/curl:=
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )"
+DEPEND="${RDEPEND}
+ test? ( dev-util/cmocka )"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${P}-libressl.patch"
+)
+
+src_configure() {
+ econf \
+ $(use_enable !libressl hardening) \
+ $(use_enable test unit)
+}