summaryrefslogtreecommitdiff
path: root/app-crypt/tpm2-tss/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-31 13:43:35 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-31 13:43:35 +0000
commit2891d29af8907ce881662f4a02844926d7a293c7 (patch)
tree56979d96839d0827aa52008b81b746b4934d88df /app-crypt/tpm2-tss/files
parentde49812990871e1705b64051c35161d5e6400269 (diff)
gentoo resync : 31.12.2018
Diffstat (limited to 'app-crypt/tpm2-tss/files')
-rw-r--r--app-crypt/tpm2-tss/files/tpm2-tss-2.1.0-build.patch49
-rw-r--r--app-crypt/tpm2-tss/files/tpm2-tss-2.1.0-tests.patch30
2 files changed, 79 insertions, 0 deletions
diff --git a/app-crypt/tpm2-tss/files/tpm2-tss-2.1.0-build.patch b/app-crypt/tpm2-tss/files/tpm2-tss-2.1.0-build.patch
new file mode 100644
index 000000000000..930c173239ed
--- /dev/null
+++ b/app-crypt/tpm2-tss/files/tpm2-tss-2.1.0-build.patch
@@ -0,0 +1,49 @@
+Next version removes these using --disable-defaultflags
+
+---
+
+diff --git a/configure.ac b/configure.ac
+index c42b487f..f9118642 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -189,19 +189,6 @@ AM_CONDITIONAL([ENABLE_INTEGRATION],[test "x$enable_integration" = "xyes"])
+
+ gl_LD_VERSION_SCRIPT
+
+-AX_ADD_COMPILER_FLAG([-std=c99])
+-AX_ADD_COMPILER_FLAG([-Wall])
+-AX_ADD_COMPILER_FLAG([-Wextra])
+-AX_ADD_COMPILER_FLAG([-Wformat-security])
+-AX_ADD_COMPILER_FLAG([-Werror])
+-AX_ADD_COMPILER_FLAG([-fstack-protector-all])
+-AX_ADD_COMPILER_FLAG([-fpic])
+-AX_ADD_COMPILER_FLAG([-fPIC])
+-
+-AX_ADD_PREPROC_FLAG([-D_DEFAULT_SOURCE])
+-AX_ADD_PREPROC_FLAG([-D_BSD_SOURCE])
+-AX_ADD_PREPROC_FLAG([-D_POSIX_SOURCE])
+-
+ AC_ARG_WITH([maxloglevel],
+ [AS_HELP_STRING([--with-maxloglevel={none,error,warning,info,debug,trace}],
+ [sets the maximum log level (default is trace)])],
+@@ -227,20 +214,9 @@ AC_ARG_ENABLE([debug],
+ [enable_debug=$enableval],
+ [enable_debug=no])
+ AS_IF([test "x$enable_debug" = "xyes"], AX_ADD_COMPILER_FLAG([-ggdb3 -Og]))
+-AS_IF([test "x$enable_debug" = "xno"], [AX_ADD_PREPROC_FLAG([-U_FORTIFY_SOURCE])
+- AX_ADD_PREPROC_FLAG([-D_FORTIFY_SOURCE=2])
+- AX_ADD_COMPILER_FLAG([-g -O2])])
+-AX_ADD_LINK_FLAG([-Wl,--no-undefined])
+-AX_ADD_LINK_FLAG([-Wl,-z,noexecstack])
+-AX_ADD_LINK_FLAG([-Wl,-z,now])
+-AX_ADD_LINK_FLAG([-Wl,-z,relro])
+
+ AC_SUBST([PATH])
+
+-# work around GCC bug #53119
+-# https://gcc.gnu.org/bugzilla/show_bug.cgi?id=53119
+-AX_ADD_COMPILER_FLAG([-Wno-missing-braces])
+-
+ dnl --------- Physical TPM device -----------------------
+
+ AC_ARG_WITH([ptpm],
diff --git a/app-crypt/tpm2-tss/files/tpm2-tss-2.1.0-tests.patch b/app-crypt/tpm2-tss/files/tpm2-tss-2.1.0-tests.patch
new file mode 100644
index 000000000000..d537c40e1a90
--- /dev/null
+++ b/app-crypt/tpm2-tss/files/tpm2-tss-2.1.0-tests.patch
@@ -0,0 +1,30 @@
+From 1ea85a32c0ae20a104badcec807b72ef458d356d Mon Sep 17 00:00:00 2001
+From: Andreas Fuchs <andreas.fuchs@sit.fraunhofer.de>
+Date: Tue, 25 Sep 2018 09:35:33 +0200
+Subject: [PATCH] ESYS: Fix crypto_ossl return code
+
+Fix returncode and thus test of interal hmac_finish function.
+
+Fixes: #1157
+
+Signed-off-by: Andreas Fuchs <andreas.fuchs@sit.fraunhofer.de>
+---
+ src/tss2-esys/esys_crypto_ossl.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/tss2-esys/esys_crypto_ossl.c b/src/tss2-esys/esys_crypto_ossl.c
+index 43088f4a..91871de1 100644
+--- a/src/tss2-esys/esys_crypto_ossl.c
++++ b/src/tss2-esys/esys_crypto_ossl.c
+@@ -448,7 +448,7 @@ iesys_cryptossl_hmac_finish(IESYS_CRYPTO_CONTEXT_BLOB ** context,
+ IESYS_CRYPTOSSL_CONTEXT *mycontext =
+ (IESYS_CRYPTOSSL_CONTEXT *) * context;
+ if (mycontext->type != IESYS_CRYPTOSSL_TYPE_HMAC) {
+- return_error(TSS2_ESYS_RC_BAD_VALUE, "bad context");
++ return_error(TSS2_ESYS_RC_BAD_REFERENCE, "bad context");
+ }
+
+ if (*size < mycontext->hmac.hmac_len) {
+--
+2.19.2
+