summaryrefslogtreecommitdiff
path: root/app-dicts/dictd-vera
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-dicts/dictd-vera
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-dicts/dictd-vera')
-rw-r--r--app-dicts/dictd-vera/Manifest5
-rw-r--r--app-dicts/dictd-vera/dictd-vera-1.22.ebuild35
-rw-r--r--app-dicts/dictd-vera/dictd-vera-1.23.ebuild35
-rw-r--r--app-dicts/dictd-vera/metadata.xml5
4 files changed, 80 insertions, 0 deletions
diff --git a/app-dicts/dictd-vera/Manifest b/app-dicts/dictd-vera/Manifest
new file mode 100644
index 000000000000..8cf198bb2245
--- /dev/null
+++ b/app-dicts/dictd-vera/Manifest
@@ -0,0 +1,5 @@
+DIST vera-1.22.tar.gz 229397 BLAKE2B ad3e195a10a03191292c0161b0ee98c591f80d1cae3b4432a2b953451f6257c5583c13aee14e6cac48551dc33bc171722ed202d3c231c68314f91464b7166a02 SHA512 3fe10ae52d8aa593bc4ce23eaffbf8d1cbc0127fcce3538508389335a9e1bc2964d1ca8915616b0711cc9da36f8ea231e050dbeddf75bef799f21e538731234a
+DIST vera-1.23.tar.gz 236439 BLAKE2B fdbecb4bf2abdac0a858be29fe544474dab69623967e2e9c8f8e02188ce7b8a8f39a099bcf7ff6e0d846afb0ec0cedd8e4ec64ba1b27a66eee963f3de088a4c1 SHA512 f16f2d24715131f60238c49f43d79bcd02b47c8e999de381c2139289f05859659a9f3ae79e3ed8d4b3dae447666cb8391ad7a072dff91275857b901fd0748c78
+EBUILD dictd-vera-1.22.ebuild 882 BLAKE2B 9b0658eca1928a339f695e2ea505948fe469562c714dfcc2c2a8364714be775d50075073f08aa4156e0a2e3b46b4d5312199aa08e16c09dfdd68ad644527b4e1 SHA512 3dd6091b4d7f4c13c98811c89b486eec2ffa7b5463f54bab784793c9d33ff1b266f3fd7ef2ae130a7d8408e0e0608e4d05e13f2e312ac425c4c68a8d4d3e336b
+EBUILD dictd-vera-1.23.ebuild 887 BLAKE2B a3f9a34da68241ed3545ad47447875f234852d5d1d01992cf5ed9983a0c5adbbe3a455cfcc9f110568d14e4ad1b67df2e933f3e2aa9df0c536569eb067750bcc SHA512 6772fa5fcbb49054362a02f1f8e549c7043268618acf4c911fef1e476ee2d5e97c0321246da11a54ba93b28ff81e7877f4d57927979a736f78573885da12ae83
+MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/app-dicts/dictd-vera/dictd-vera-1.22.ebuild b/app-dicts/dictd-vera/dictd-vera-1.22.ebuild
new file mode 100644
index 000000000000..cf8e02f8feee
--- /dev/null
+++ b/app-dicts/dictd-vera/dictd-vera-1.22.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DESCRIPTION="V.E.R.A. -- Virtual Entity of Relevant Acronyms for dict"
+HOMEPAGE="http://home.snafu.de/ohei/vera/vueber-e.html"
+SRC_URI="mirror://gnu/vera/vera-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="FDL-1.3"
+KEYWORDS="amd64 ppc ppc64 sparc x86"
+
+DEPEND=">=app-text/dictd-1.5.5"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/vera-${PV}
+
+src_compile () {
+# sed -f debian/dict-vera/sedfile vera.? >vera1 || die
+# sed '1,2!s/^/ /' vera. > vera || die
+# cat vera1>>vera || die
+ cat vera.[0-9a-z] | /usr/bin/dictfmt -f -u http://home.snafu.de/ohei \
+ -s "V.E.R.A. -- Virtual Entity of Relevant Acronyms" \
+ vera || die
+ /usr/bin/dictzip -v vera.dict || die
+}
+
+src_install () {
+ dodir /usr/lib/dict
+ insinto /usr/lib/dict
+ doins vera.dict.dz
+ doins vera.index
+ dodoc changelog README
+}
diff --git a/app-dicts/dictd-vera/dictd-vera-1.23.ebuild b/app-dicts/dictd-vera/dictd-vera-1.23.ebuild
new file mode 100644
index 000000000000..fb0b405a0537
--- /dev/null
+++ b/app-dicts/dictd-vera/dictd-vera-1.23.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+DESCRIPTION="V.E.R.A. -- Virtual Entity of Relevant Acronyms for dict"
+HOMEPAGE="http://home.snafu.de/ohei/vera/vueber-e.html"
+SRC_URI="mirror://gnu/vera/vera-${PV}.tar.gz"
+
+SLOT="0"
+LICENSE="FDL-1.3"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND=">=app-text/dictd-1.5.5"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/vera-${PV}
+
+src_compile () {
+# sed -f debian/dict-vera/sedfile vera.? >vera1 || die
+# sed '1,2!s/^/ /' vera. > vera || die
+# cat vera1>>vera || die
+ cat vera.[0-9a-z] | /usr/bin/dictfmt -f -u http://home.snafu.de/ohei \
+ -s "V.E.R.A. -- Virtual Entity of Relevant Acronyms" \
+ vera || die
+ /usr/bin/dictzip -v vera.dict || die
+}
+
+src_install () {
+ dodir /usr/lib/dict
+ insinto /usr/lib/dict
+ doins vera.dict.dz
+ doins vera.index
+ dodoc changelog README
+}
diff --git a/app-dicts/dictd-vera/metadata.xml b/app-dicts/dictd-vera/metadata.xml
new file mode 100644
index 000000000000..6f49eba8f496
--- /dev/null
+++ b/app-dicts/dictd-vera/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<!-- maintainer-needed -->
+</pkgmetadata>