summaryrefslogtreecommitdiff
path: root/app-dicts/eblook/eblook-1.6.1_p16-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-30 16:42:15 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-30 16:42:15 +0100
commitaca0af8133e724b7edf0b5c6efe12c39077a3dc9 (patch)
tree77f3ebc779dbb8fda935ed9895b424d3201f7804 /app-dicts/eblook/eblook-1.6.1_p16-r1.ebuild
parentd97adbb13d8d4ce3f0521498a11e3d3af2154de2 (diff)
gentoo auto-resync : 30:07:2023 - 16:42:14
Diffstat (limited to 'app-dicts/eblook/eblook-1.6.1_p16-r1.ebuild')
-rw-r--r--app-dicts/eblook/eblook-1.6.1_p16-r1.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/app-dicts/eblook/eblook-1.6.1_p16-r1.ebuild b/app-dicts/eblook/eblook-1.6.1_p16-r1.ebuild
new file mode 100644
index 000000000000..ce4c207a67e0
--- /dev/null
+++ b/app-dicts/eblook/eblook-1.6.1_p16-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Interactive search utility for electronic dictionaries"
+HOMEPAGE="http://openlab.ring.gr.jp/edict/eblook/"
+SRC_URI="http://openlab.ring.gr.jp/edict/eblook/dist/${PN}-$(ver_cut 1-3).tar.gz"
+SRC_URI+=" mirror://debian/pool/main/e/eblook/eblook_$(ver_cut 1-3)-$(ver_cut 5).debian.tar.xz"
+S="${WORKDIR}"/${PN}-$(ver_cut 1-3)
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~riscv ~x86"
+
+DEPEND=">=dev-libs/eb-3.3.4"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${WORKDIR}"/debian/patches
+ "${FILESDIR}"/${PN}-1.6.1-clang-16-buildfix.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-eb-conf="${EPREFIX}"/etc/eb.conf
+}