summaryrefslogtreecommitdiff
path: root/app-dicts/gwaei/gwaei-3.6.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /app-dicts/gwaei/gwaei-3.6.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'app-dicts/gwaei/gwaei-3.6.2.ebuild')
-rw-r--r--app-dicts/gwaei/gwaei-3.6.2.ebuild73
1 files changed, 73 insertions, 0 deletions
diff --git a/app-dicts/gwaei/gwaei-3.6.2.ebuild b/app-dicts/gwaei/gwaei-3.6.2.ebuild
new file mode 100644
index 000000000000..d1e6c6457f68
--- /dev/null
+++ b/app-dicts/gwaei/gwaei-3.6.2.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="4"
+
+inherit gnome2-utils eutils
+
+DESCRIPTION="Japanese-English Dictionary for GNOME"
+HOMEPAGE="http://gwaei.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gwaei/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk hunspell nls test mecab"
+
+RDEPEND=">=net-misc/curl-7.20.0
+ >=dev-libs/glib-2.31
+ gtk? (
+ x11-libs/gtk+:3
+ >=app-text/gnome-doc-utils-0.14.0
+ )
+ hunspell? ( app-text/hunspell )
+ nls? ( virtual/libintl )
+ mecab? ( app-text/mecab )"
+DEPEND="${RDEPEND}
+ test? (
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/scrollkeeper-dtd
+ )
+ gtk? (
+ x11-themes/gnome-icon-theme-symbolic
+ >=app-text/gnome-doc-utils-0.14.0
+ )
+ nls? ( >=sys-devel/gettext-0.17 )
+ app-text/rarian
+ dev-util/intltool
+ virtual/pkgconfig"
+
+src_configure() {
+ econf \
+ $(use_with gtk gnome) \
+ $(use_enable nls) \
+ $(use_with hunspell) \
+ $(use_with mecab) \
+ --disable-static \
+ --docdir=/usr/share/doc/${PF}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ find "${D}" -name '*.la' -delete
+
+ dodoc AUTHORS README
+}
+
+pkg_preinst() {
+ if use gtk ; then
+ gnome2_schemas_savelist
+ fi
+}
+
+pkg_postinst() {
+ if use gtk ; then
+ gnome2_schemas_update
+ fi
+}
+
+pkg_postrm() {
+ if use gtk ; then
+ gnome2_schemas_update
+ fi
+}