summaryrefslogtreecommitdiff
path: root/app-dicts/ipadic/ipadic-2.7.0-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /app-dicts/ipadic/ipadic-2.7.0-r2.ebuild
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'app-dicts/ipadic/ipadic-2.7.0-r2.ebuild')
-rw-r--r--app-dicts/ipadic/ipadic-2.7.0-r2.ebuild17
1 files changed, 9 insertions, 8 deletions
diff --git a/app-dicts/ipadic/ipadic-2.7.0-r2.ebuild b/app-dicts/ipadic/ipadic-2.7.0-r2.ebuild
index fba0b8b37b2d..54a6d1d4850d 100644
--- a/app-dicts/ipadic/ipadic-2.7.0-r2.ebuild
+++ b/app-dicts/ipadic/ipadic-2.7.0-r2.ebuild
@@ -1,23 +1,25 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="4"
-inherit autotools eutils
+EAPI=7
+
+inherit autotools
DESCRIPTION="Japanese dictionary for ChaSen"
HOMEPAGE="http://sourceforge.jp/projects/ipadic/"
SRC_URI="mirror://sourceforge.jp/${PN}/24435/${P}.tar.gz"
LICENSE="ipadic"
-KEYWORDS="amd64 ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
SLOT="0"
-IUSE=""
+KEYWORDS="amd64 ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
-DEPEND=">=app-text/chasen-2.3.1"
-RDEPEND=""
+BDEPEND=">=app-text/chasen-2.3.1"
+
+PATCHES=( "${FILESDIR}"/${PF}-gentoo.patch )
src_prepare() {
- epatch "${FILESDIR}/${PF}-gentoo.patch"
+ default
+ mv configure.{in,ac} || die
eautoreconf
}
@@ -26,5 +28,4 @@ src_install() {
insinto /etc
doins chasenrc
- dodoc AUTHORS ChangeLog NEWS README
}