summaryrefslogtreecommitdiff
path: root/app-dicts/myspell-en/myspell-en-20230901.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-04 22:22:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-04 22:22:10 +0100
commit16dba5216d31038098e918bd83df2aaa1849d4e9 (patch)
tree0d2284cd8987cba0f4c8bda80c2c4e6d172249aa /app-dicts/myspell-en/myspell-en-20230901.ebuild
parent0979d3ddb6ea14d17e52fd0ba2e01f928948384a (diff)
gentoo auto-resync : 04:09:2023 - 22:22:10
Diffstat (limited to 'app-dicts/myspell-en/myspell-en-20230901.ebuild')
-rw-r--r--app-dicts/myspell-en/myspell-en-20230901.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/app-dicts/myspell-en/myspell-en-20230901.ebuild b/app-dicts/myspell-en/myspell-en-20230901.ebuild
new file mode 100644
index 000000000000..ba549ba9ab85
--- /dev/null
+++ b/app-dicts/myspell-en/myspell-en-20230901.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit myspell-r2
+
+DESCRIPTION="English dictionaries for myspell/hunspell"
+HOMEPAGE="
+ https://extensions.libreoffice.org/extensions/english-dictionaries
+ https://proofingtoolgui.org
+ https://github.com/marcoagpinto/aoo-mozilla-en-dict
+"
+SRC_URI="https://extensions.libreoffice.org/assets/downloads/41/1693549382/dict-en-20230901_lo.oxt"
+
+LICENSE="BSD MIT LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+PLOCALES=( "en-AU" "en-CA" "en-GB" "en-US" "en-ZA" )
+IUSE+="+l10n_en ${PLOCALES[@]/#/l10n_}"
+REQUIRED_USE="|| ( l10n_en ${PLOCALES[@]/#/l10n_} )"
+
+src_prepare() {
+ if use l10n_en-GB || use l10n_en; then
+ MYSPELL_HYPH+=( "hyph_en_GB.dic" )
+ fi
+ if use l10n_en-US || use l10n_en; then
+ MYSPELL_THES+=(
+ "th_en_US_v2.dat"
+ "th_en_US_v2.idx"
+ )
+ MYSPELL_HYPH+=( "hyph_en_US.dic" )
+ fi
+
+ MYSPELL_DICT=( )
+ for lang in "${PLOCALES[@]}"; do
+ if [[ "${lang}" == "en" ]]; then
+ continue
+ fi
+ local mylinguas="${lang//-/_}"
+ if use "l10n_${lang}" || use l10n_en; then
+ MYSPELL_DICT+=( "${mylinguas}.aff" "${mylinguas}.dic" )
+ else
+ rm "README_${mylinguas}.txt" || die
+ if [[ ${lang} == "en-US" ]]; then
+ rm "README_hyph_en_US.txt" || die
+ fi
+ if [[ ${lang} == "en-GB" ]]; then
+ rm "README_hyph_en_GB.txt" || die
+ rm "README_en_GB_thes.txt" || die
+ fi
+ fi
+ done
+
+ default
+}