summaryrefslogtreecommitdiff
path: root/app-dicts
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-04-02 01:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2025-04-02 01:33:41 +0100
commit6be74aaad3f65bab8561cebfef177dc28d802d9f (patch)
treea68f98ee3b67b95f841c93f5056c9b610fa4e6e2 /app-dicts
parent9cb5d77a6732fadf391fd38da00e6921f3e23112 (diff)
gentoo auto-resync : 02:04:2025 - 01:33:40
Diffstat (limited to 'app-dicts')
-rw-r--r--app-dicts/Manifest.gzbin31479 -> 31482 bytes
-rw-r--r--app-dicts/myspell-en/Manifest2
-rw-r--r--app-dicts/myspell-en/myspell-en-20250401.ebuild62
3 files changed, 64 insertions, 0 deletions
diff --git a/app-dicts/Manifest.gz b/app-dicts/Manifest.gz
index c14f1bcd100e..f4afb855a9df 100644
--- a/app-dicts/Manifest.gz
+++ b/app-dicts/Manifest.gz
Binary files differ
diff --git a/app-dicts/myspell-en/Manifest b/app-dicts/myspell-en/Manifest
index ed322497dbf1..f797b2093466 100644
--- a/app-dicts/myspell-en/Manifest
+++ b/app-dicts/myspell-en/Manifest
@@ -1,3 +1,5 @@
DIST dict-en-20250101_lo.oxt 6115082 BLAKE2B 9df18fb12fc42199e11c8bd1ed9f7f052733c462347704e538df6fe525de234726ebd230ab6cfabed7f6ec09bac15c13a9cd17b548b9580be0c951d4d6c47e84 SHA512 667b82ad592db3002c7b3d359480d5f55585385861ee4a04b040e28dcaac33bfddc9386f3b1a7af49ff1652c50676605257f4f8798db622f3c4fb9518629ec0a
+DIST dict-en-20250401_lo.oxt 6273269 BLAKE2B 3f7a90a445cc343229bf0a9360928dbcd68e440563c62512a147646bc52cc5953a8da9b9e57211b5fe2cdd759e7ee3fec72c18de11d58483dec29cf3b5f31424 SHA512 20ba9670cd748d3cd05d0e8857a02b76321cafeed16a8ed1806606078824a5f4b9269d1f82166dd2cdbe9a5207a67eaa18d603bd9440ce12062c96751ff28f41
EBUILD myspell-en-20250101.ebuild 1697 BLAKE2B 16d16a1ecf95bf4b346d81fd82076f34579379b0d31b637b0590f320fbf11eda2b65116cca69427210a16c58a560496a926639a73e37fc7b5ed34b16a9c3c473 SHA512 c91e0fd3078a16c78184083477c4f02d30b3a0ed87b40cf6f21f1c1f757b9554d5363138f91b18cbff3cbe0708d0f0cd1ef6e6f5d1915c0f7f383d37f11d3983
+EBUILD myspell-en-20250401.ebuild 1704 BLAKE2B 974f982840ea4be7f489024492c5a3829673a8ea81c19c92f5121374048351003e90d8e3a81a9e899e84ebe19fcbeee14a2f66536ed5ce4ba9592a1da8f4e02a SHA512 5a3f482e36d97189f4dbe049544e9e5d8d14b0f4c42580919717702728ab35a3aa6e843193a5168f2215f1decdc7555a71069ac584d39a77327f465a1a79bda1
MISC metadata.xml 289 BLAKE2B 3b19ce0204dedac8876e4a00fa12dd23cadca14d8b422165467e4da65edfb91e3bb924505016333bad4ed1cb2612db674bb857f1a3dc9e1033b53dcdf20cb164 SHA512 9147be5e8b62a3de0ee8aafc33c61132f9856b28653a390be9ee7a89e3057cf06cc0b53149f08c525a6f01b2fac91e8ba6d1ed89ea46e33d8c279e76c22bec54
diff --git a/app-dicts/myspell-en/myspell-en-20250401.ebuild b/app-dicts/myspell-en/myspell-en-20250401.ebuild
new file mode 100644
index 000000000000..b8c6c15618a3
--- /dev/null
+++ b/app-dicts/myspell-en/myspell-en-20250401.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit myspell-r2
+
+DESCRIPTION="English dictionaries for myspell/hunspell"
+HOMEPAGE="
+ https://extensions.libreoffice.org/extensions/english-dictionaries
+ https://github.com/marcoagpinto/aoo-mozilla-en-dict
+ https://proofingtoolgui.org
+"
+SRC_URI="https://extensions.libreoffice.org/assets/downloads/41/1743477350/dict-en-20250401_lo.oxt"
+
+LICENSE="BSD MIT LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+PLOCALES=( "en-AU" "en-CA" "en-GB" "en-US" "en-ZA" )
+IUSE="${PLOCALES[*]/#/+l10n_}"
+REQUIRED_USE="|| ( ${PLOCALES[*]/#/l10n_} )"
+
+src_prepare() {
+ # This thesaurus is used by all the English dictionaries, see
+ # ./dictionaries.xcu in the distfile, lines 71-81.
+ MYSPELL_THES=(
+ "th_en_US_v2.dat"
+ "th_en_US_v2.idx"
+ )
+
+ local non_us_dic_used=0
+ local mylinguas
+ for lang in "${PLOCALES[@]}"; do
+ mylinguas="${lang/-/_}"
+ if use "l10n_${lang}"; then
+ MYSPELL_DICT+=( "${mylinguas}.aff" "${mylinguas}.dic" )
+ if [[ ${lang} == en-US ]]; then
+ MYSPELL_HYPH=( "hyph_en_US.dic" )
+ else
+ non_us_dic_used=1
+ fi
+ else
+ rm "README_${mylinguas}.txt" || die
+ if [[ ${lang} == "en-US" ]]; then
+ rm "README_hyph_en_US.txt" || die
+ elif [[ ${lang} == "en-GB" ]]; then
+ rm "README_en_GB_thes.txt" || die
+ fi
+ fi
+ done
+
+ if [[ non_us_dic_used -eq 1 ]]; then
+ # This is used by every English variety, except for the en-US, see
+ # ./dictionaries.xcu, lines 60-70.
+ MYSPELL_HYPH+=( "hyph_en_GB.dic" )
+ else
+ rm "README_hyph_en_GB.txt" || die
+ fi
+
+ default
+}