summaryrefslogtreecommitdiff
path: root/app-doc/abs-guide/abs-guide-10.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /app-doc/abs-guide/abs-guide-10.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'app-doc/abs-guide/abs-guide-10.ebuild')
-rw-r--r--app-doc/abs-guide/abs-guide-10.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-doc/abs-guide/abs-guide-10.ebuild b/app-doc/abs-guide/abs-guide-10.ebuild
new file mode 100644
index 000000000000..366c35099099
--- /dev/null
+++ b/app-doc/abs-guide/abs-guide-10.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+DESCRIPTION="An in-depth exploration of the art of shell scripting"
+HOMEPAGE="https://www.tldp.org/LDP/abs/html"
+
+SRC_URI="http://bash.deta.in/abs-guide-final.tar.bz2
+ pdf? ( http://bash.deta.in/abs-guide.pdf )"
+
+LICENSE="public-domain"
+IUSE="pdf"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ~mips ppc sparc x86"
+
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/abs"
+
+src_unpack() {
+ unpack abs-guide-final.tar.bz2
+ use pdf && cp "${DISTDIR}"/abs-guide.pdf "${S}"
+}
+
+src_install() {
+ dodoc -r *
+ docompress -x /usr/share/doc/${PF}
+}
+
+pkg_postinst() {
+ echo
+ elog "The HTML docs can be accessed through /usr/share/doc/${P}/HTML/index.html"
+ elog "Example scripts from the book are installed in /usr/share/doc/${P}/"
+ use pdf && elog "along with the pdf version."
+ echo
+}