summaryrefslogtreecommitdiff
path: root/app-doc/casting-spels-emacs/casting-spels-emacs-19-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-01 19:24:10 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-01 19:24:10 +0100
commitb052fbf151106a4f47cac7fdf0ffff983decb773 (patch)
tree5d21279a4eeaf4076caee87654b610a0fe8a4051 /app-doc/casting-spels-emacs/casting-spels-emacs-19-r3.ebuild
parentc3b55a6be7da027d97d8aef00ef88c3011121a42 (diff)
gentoo auto-resync : 01:09:2022 - 19:24:10
Diffstat (limited to 'app-doc/casting-spels-emacs/casting-spels-emacs-19-r3.ebuild')
-rw-r--r--app-doc/casting-spels-emacs/casting-spels-emacs-19-r3.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/app-doc/casting-spels-emacs/casting-spels-emacs-19-r3.ebuild b/app-doc/casting-spels-emacs/casting-spels-emacs-19-r3.ebuild
new file mode 100644
index 000000000000..e3f9c9c18b3c
--- /dev/null
+++ b/app-doc/casting-spels-emacs/casting-spels-emacs-19-r3.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit elisp-common
+
+DESCRIPTION="Casting SPELs in Lisp - A Comic Book (Emacs Lisp Edition)"
+HOMEPAGE="https://www.lisperati.com/casting-spels-emacs/html/casting-spels-emacs-1.html
+ https://www.gnu.org/software/emacs/casting-spels-emacs/"
+SRC_URI="https://casting-spels-emacs.googlecode.com/files/${PN}-v${PV}.zip"
+S="${WORKDIR}/${PN}"
+
+LICENSE="GPL-2+ FDL-1.2"
+SLOT="0"
+KEYWORDS="amd64 ~riscv x86"
+
+RDEPEND=">=app-editors/emacs-23.1:*"
+DEPEND="app-arch/unzip"
+
+src_prepare() {
+ sed -i 's/\r$//' *.txt html/*.html {lisp,test}/*.el || die
+ # needs cl extensions
+ eapply "${FILESDIR}/${P}-require-cl.patch"
+ eapply_user
+}
+
+src_install() {
+ elisp-install ${PN} lisp/*.el
+ dodoc README.txt test/walk-through-commands.el
+ docinto html
+ dodoc html/*.html
+ docinto html/images
+ dodoc images/*.jpg images/*.png
+ dosym html/images /usr/share/doc/${PF}/images
+ dosym ${SITELISP}/${PN} /usr/share/doc/${PF}/lisp
+}